Results 1 to 8 of 8

Thread: Window Scaling

  1. #1

    Default Window Scaling

    Hi,

    I've had a problem with the main window scaling incorrectly to my PC (using Windows 8.1). When BibleWorks is not in full screen there is a nice boarder all around the outside. However, when I make it full size the boarder is lost on the right and left see pictures). This means it looks cramped and my cursor is almost to the very edge of my screen in the search bar. I've installed all the updates, restarted my computer, experimented with the scaling options - nothing works. Has anyone had the same problem? Does anyone know how to fix it?
    Attached Images Attached Images   

  2. #2
    Join Date
    Apr 2012
    Posts
    288

    Default

    Quote Originally Posted by T G Drummond View Post
    Hi,

    I've had a problem with the main window scaling incorrectly to my PC (using Windows 8.1). When BibleWorks is not in full screen there is a nice boarder all around the outside. However, when I make it full size the boarder is lost on the right and left see pictures). This means it looks cramped and my cursor is almost to the very edge of my screen in the search bar. I've installed all the updates, restarted my computer, experimented with the scaling options - nothing works. Has anyone had the same problem? Does anyone know how to fix it?
    BW main toolbar, Tools, Options, General, Flags, Startup Options has a few different window/graphics options. Did you try them all? Some changes may require running as an administrator and a reboot to take effect.

    If nothing helps, there might be some benefit in trying this: Make the BW window non-maximized. Move the left upper corner of BW to the left upper corner of the screen. Drag the right lower corner to almost fill up the screen. See if that helps. Usually windows sizes are remembered when a program is closed, so you may only need to do it once. If it does open maximized, try restoring it. That may cause it to remember where it was last time.

  3. #3

    Default

    Quote Originally Posted by now john View Post
    BW main toolbar, Tools, Options, General, Flags, Startup Options has a few different window/graphics options. Did you try them all? Some changes may require running as an administrator and a reboot to take effect.

    If nothing helps, there might be some benefit in trying this: Make the BW window non-maximized. Move the left upper corner of BW to the left upper corner of the screen. Drag the right lower corner to almost fill up the screen. See if that helps. Usually windows sizes are remembered when a program is closed, so you may only need to do it once. If it does open maximized, try restoring it. That may cause it to remember where it was last time.
    I tried all those settings to no avail. I may try uninstalling and reinstalling BW, I know it's a small thing but it bugs me.

  4. #4
    Join Date
    Apr 2012
    Posts
    288

    Default

    Quote Originally Posted by T G Drummond View Post
    I tried all those settings to no avail. I may try uninstalling and reinstalling BW, I know it's a small thing but it bugs me.
    Before you uninstall and reinstall BW you might want to see if there is a BibleWorks checkpoint that you could roll back to. If that doesn't help, you might try deleting the .ini file to see if that helps.

    Start BW with the shift key held down and then click to start BW as usual. It should bring up an options window allowing you to access the options above.

  5. #5

    Default

    Quote Originally Posted by now john View Post
    Before you uninstall and reinstall BW you might want to see if there is a BibleWorks checkpoint that you could roll back to. If that doesn't help, you might try deleting the .ini file to see if that helps.

    Start BW with the shift key held down and then click to start BW as usual. It should bring up an options window allowing you to access the options above.
    I tried rolling back to a few different checkpoints as well as deleting the .ini files. Nothing worked. I'm starting to think the problem is with my computer, though no other programs have this issue. Whenever I finally get around to uninstalling and reinstalling BW I'll update with whether or not it fixed the problem.

  6. #6

    Default Same behavior

    I just checked and I am experiencing the same behavior. It has just never bothered me so I can't tell you if this is a new issue or just the way the program behaves. I am running it on Windows 10.

  7. #7
    Join Date
    Mar 2009
    Posts
    771

    Default

    I also just tested it to see if this happened for me (under Windows 7). The border I have is just a thin red line (due to the color scheme I'm using, I suppose), and it disappears in full-screen view.

    But ... But ... I hate to minimize anyone else's experience, but I can't imagine that this would hinder my use of the program. I do think that visual aesthetics are important to a good work environment. (I believe one proof of the existence of the Creator is that we can think that things are beautiful!) But honestly, I don't see this as a significant problem. Obviously your mileage varies, T G!
    David Rensberger
    Atlanta, Georgia

  8. #8
    Join Date
    Apr 2012
    Posts
    288

    Default

    I took the time to check this behavior on 6 different machines that I have access to. All of them display the same change. When not maximized there is a fixed-pixel-width border on all four sides of the screen. When the program is maximized that border disappears. The cursor in the search window is a certain distance from that border in the non-maximized state. When the program is maximized it seems that the cursor is then that same distance from the left edge of the now borderless screen. So at least it seems that there is no actual loss of information when the program is maximized.

    It appears that I found a bug in the program in the process of checking this out.

    Go to Main toolbar, Tools, Options, General, Flags, Startup Options, System Scaling Options.
    All of the machines were set to the first option. I reset the option to the second, followed the instructions to close and restart BW. But after that the choice always reverted to the first option. I added a reboot, ran with admin privileges, and on different Windows OS's, but could not change the setting.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •