Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Notes pane keeps switching the keyboard layout to en-US

  1. #1
    Join Date
    Oct 2018
    Posts
    5

    Default Notes pane keeps switching the keyboard layout to en-US

    Hello!

    I am trying to configure BW10 to use the norwegian keyboard layout everywhere. It contains all english characters anyways, and I can also make use of the norwegian diacritics at the same time. How can I achieve this?

    I read the documentation, which is kind of dishearting, mentioning that the language settings "may" work well for "some" languages.

    The only place which seems to ignore my settings is the Notes editor. It jumps to en-US as soon as it receives focus and it would not switch back to any other layout when it looses focus.

    Any ideas how to set this up?

    Best regards,
    Catalin

  2. #2
    Join Date
    Apr 2012
    Posts
    279

    Default

    Windows or Mac?

    What is the default system keyboard?
    Last edited by now john; 10-19-2018 at 05:13 AM.

  3. #3
    Join Date
    Oct 2018
    Posts
    5

    Default

    Windows 10, Enterprise.

    I don't know what you mean by "system keyboard". Default input method is "English (United States) - Norwegian". That is the display language of the OS is English but the "keyboard layout" (they call it input method/language) is Norwegian.

    Before installing BW10 it was the only option. After installing BW10 I got this button on the task bar which now has 3 options. Among these is "English (United States) - US keboard". This is what BW10 defaults to. I managed to set it back to Norwegian keyboard by means of the keyboard options under tools. It works everywhere I tried (I am not an advanced BW-user) except the notes pane where it bumps back to en-US.

    I also noticed that under Tools->Interface/Settings->BibleWorks Keyboard I can choose Norwegian, but it default back to en-US some times later. Either during the session or when i close BW and start it up again. It seems like a setting which is not preserved from session to session. But even when it is set to Norwegian, the Notes pane still switches to en-US.

  4. #4
    Join Date
    Apr 2012
    Posts
    279

    Default

    Quote Originally Posted by DoruCatalin View Post
    I read the documentation, which is kind of disheartening, mentioning that the language settings "may" work well for "some" languages.
    Unfortunately the wording of the documentation mentioned above indicates that sometimes language setting don't work or may work for a while and then not work.

    A Google search on "windows 10 language keeps changing" indicates that such behavior is a common problem with Windows 10.

    This link (https://superuser.com/questions/9769...-in-windows-10) is about this problem.
    This is from that post.
    So I recently did a clean install of Windows 10 English. I configured it to have English UI language but Norwegian keyboard. I have several problems with that setup:
    The keyboard language keeps switching to English constantly

    BibleWorks 10 can also change language settings. I did not know that until I recently installed a Swedish Bible in BibleWorks to help someone who was having a searching problem with a Swedish Bible. As I only use an "English (United States) - US keyboard" I was surprised to discover after helping him that some of my number row keys were not working correctly. BibleWorks had changed the keyboard to Swedish. I learned that I could return to BibleWorks, double click on the name of an English Bible to make it the search version, and after that the number rows keys (English and Swedish keyboards have some of the number row keys different) returned to normal.

    So there may be some conflict between the OS and Bibleworks as they both change the same settings. It may be that there is no permanent solution, as the search results above indicate. (If you find a solution, please post it.) A work-around would be to find a way, or better, the most efficient way to force the Notes editor to accept Norwegian input and to manually return other BibleWorks windows to the desired input language if it gets changed. Perhaps it would be to change the BibleWorks search version to the desired language. I would at least try opening the Notes Editor and see if making the search version Norwegian would cause the Notes editor to switch. Or perhaps first switching to an English search version and then to a Norwegian one.
    Last edited by now john; 10-19-2018 at 12:14 PM.

  5. #5
    Join Date
    Apr 2012
    Posts
    279

    Default

    I just tried what I suggested in the previous post. It did not work as expected.

    Try this.

    Right click on the Windows Icon in the task bar.
    Click on Settings > Time & Language > Region & Language (I have English, Swedish, Norwegian keyboards installed) > Advanced keyboard settings
    [x] Let me use a different input for each app window
    [x] Use the desktop language bar when it's available
    (both checked)
    Click on Language bar options > Advanced Key Settings
    Keyboard short cuts can be created here to change the language settings of the current window
    There were some comments in the Google search refered to in the previous post that sometimes the keyboard shortcuts did not work.

    The language settings of the current window can also be set by clicking on the language icon in the Windows taskbar.

    This seems to work reliably in the Notes editor window but not in the Browse window. But changing the search version did work in the Browse window.

    The windows key + space bar also cycles the current window through the installed languages of the Notes editor but not the Browse window.
    The windows key + space bar and clicking on the Windows taskbar icon both change the language settings for this editor as you can see: , , ;;''
    Last edited by now john; 10-19-2018 at 01:15 PM.

  6. #6
    Join Date
    Apr 2012
    Posts
    275

    Default

    Quote Originally Posted by DoruCatalin View Post
    Hello!

    I am trying to configure BW10 to use the norwegian keyboard layout everywhere. It contains all english characters anyways, and I can also make use of the norwegian diacritics at the same time. How can I achieve this?

    I read the documentation, which is kind of dishearting, mentioning that the language settings "may" work well for "some" languages.

    The only place which seems to ignore my settings is the Notes editor. It jumps to en-US as soon as it receives focus and it would not switch back to any other layout when it looses focus.

    Any ideas how to set this up?

    Best regards,
    Catalin
    Hi Catalin,

    The keyboard setup in BW has always been the touchiest (and, for those using non-US keyboards, most aggravating) part of BW. You should be aware that the language setting that opens up with you double-click on bottom menu bar is separate from the ones in the notes function and in the editor. To change those, go into each one, click on the wrench icon (it should be the third icon on the menu bar) and then, in the menu that pops up, put in the local language you want everywhere in the right-hand column (and click ok, of course!).

    I hope that will get you where you want to go!

    Don Cobb
    Aix-en-Provence, France

  7. #7
    Join Date
    Apr 2012
    Posts
    279

    Default

    Quote Originally Posted by Donald Cobb View Post
    click on the wrench icon and then, in the menu that pops up, put in the local language you want everywhere in the right-hand column
    Hi Don,

    I am running BW10 on a PC running Windows 10. I use English, Finnish, and Swedish languages and keyboards. The Windows language is English. I tried what you said, and it doesn't seem to work.

    The Browse Window language is Swedish as I am using a Swedish Bible for my search version. I used the Editor "wrench" and set it to the same Language - Keyboard (Swedish). While the Editor is the active window I also set Windows to Swedish. Then I can enter Swedish characters into the editor. I just did that. But as soon as I leave that active window and activate an English language window (like I just did to type this) the Editor Window reverts to English. I checked the Editor "wrench" setting, and it still says Swedish but the toolbar at the bottom of the Editor window says English (it said Swedish before) and English is entered when I type. To enter Swedish I need to manually revert to Swedish by clicking the input language icon in the taskbar or using a keyboard short cut.

    So it seems that even though I can set a language using the Editor "wrench," when I leave the Editor and use the default input language in another window the Editor follows and also reverts to the default input language.

    Perhaps I have missed something. If your Editor resists that change, I would be glad to learn how to do that.

    It may be that if the OS is a non-English language and that same non-English language is the language set by the Editor "wrench" so both are the same that there is no reverting (or at least it isn't apparent because it only reverted to what it was before the reverting). But when they don't agree, it seems to revert to the language setting of the OS.

    John
    Last edited by now john; 10-20-2018 at 02:28 PM.

  8. #8
    Join Date
    Apr 2012
    Posts
    275

    Default

    Quote Originally Posted by now john View Post
    It may be that if the OS is a non-English language and that same non-English language is the language set by the Editor "wrench" so both are the same that there is no reverting (or at least it isn't apparent because it only reverted to what it was before the reverting). But when they don't agree, it seems to revert to the language setting of the OS.
    Hi John,

    That's quite possible. I have set the BW keyboard(s) set to French for everything, and that's also my default keyboard setting on my MacBook Pro. Interestingly, I was talking with two (French) friends Friday who have exactly the same problem. One has BW 9 installed on his MacBook Pro, the other on his PC. They set it BW to a French keyboard, but it automatically reverts back to English, and moreover changes the computer's default keyboard to English in the process. Very frustrating!

    For some reason, I haven't really had this problem in BW10 recently. It was more a recurring issue in BW9. I had made the suggestion to BW a few years back that for version 11, they simply integrate the computer's keyboard settings to function as is in BW, as do all other programs, Bible software or otherwise. If Mike Bushell is still up to it, perhaps he could fiddle with this issue, although I won't set my hopes too high on that.

    Catalin, has changing the settings in the editor and notes been helpful?

    Regards,

    Don

  9. #9
    Join Date
    Oct 2018
    Posts
    5

    Default

    Hello,

    Thanks for the reply. In the mean time I messed with the keyboard settings in the registry so right now Tools->Interface/Settings->BibleWorks Keyboard would not load the norwegian keyboard anymore. It seems to still work for greek and hebrew, though. If this becomes a problem I will reinstall my system.

    The tip to set the keyboard layout for the Notes / Editor itself (the wrench button) seems to work. Thank you so much for pointing that out.

    I was thinking that it might be useful to have a master keyboard setting in BW called "Allow BW to adapt the keyboard layout for you". So that those users who need help customizing the keyboard layouts can continue to get this help from BW, and those who do not need it can effectively prevent BW from "helping out". A lot of the European languages map all the english letters as part of their own native character sets, so they do not benefit from BW jumping back to en-US every now and then.

    Somewhat off topic:

    I hope BW will come back stronger and better. I bought it first in 2001 (BW5) and I remember now that I had issues with the keyboard layout back then also. Than I did not use it anymore for many years until I bought BW10 in january/february this year. And when they announced that they would discontinue the product I bought all their lexicons. But this keyboard issue constantly breaks the flow of my thoughts which are already severely tasked when trying to understand as much as possible from the Word. So fixing this keyboard issue in hopefully future versions of BW is really important.

    For now, it seems I can go back to the study after setting the Notes and Editor panes to Norwegian. Thanks again for the help.

    Best regards,
    Catalin

  10. #10
    Join Date
    Apr 2012
    Posts
    275

    Default

    Quote Originally Posted by DoruCatalin View Post
    Hello,

    Thanks for the reply. In the mean time I messed with the keyboard settings in the registry so right now Tools->Interface/Settings->BibleWorks Keyboard would not load the norwegian keyboard anymore. It seems to still work for greek and hebrew, though. If this becomes a problem I will reinstall my system.

    The tip to set the keyboard layout for the Notes / Editor itself (the wrench button) seems to work. Thank you so much for pointing that out.

    I was thinking that it might be useful to have a master keyboard setting in BW called "Allow BW to adapt the keyboard layout for you". So that those users who need help customizing the keyboard layouts can continue to get this help from BW, and those who do not need it can effectively prevent BW from "helping out". A lot of the European languages map all the english letters as part of their own native character sets, so they do not benefit from BW jumping back to en-US every now and then.

    Somewhat off topic:

    I hope BW will come back stronger and better. I bought it first in 2001 (BW5) and I remember now that I had issues with the keyboard layout back then also. Than I did not use it anymore for many years until I bought BW10 in january/february this year. And when they announced that they would discontinue the product I bought all their lexicons. But this keyboard issue constantly breaks the flow of my thoughts which are already severely tasked when trying to understand as much as possible from the Word. So fixing this keyboard issue in hopefully future versions of BW is really important.

    For now, it seems I can go back to the study after setting the Notes and Editor panes to Norwegian. Thanks again for the help.

    Best regards,
    Catalin
    Hi again Catalin,

    Good to know that helped. One question. Has changing the notes and editor language effected the stability of the other things, like the search language? Or are you still encountering the same problems? I'd be interested in knowing because in talking with my friends here in France, I couldn't help them work out the problem of BW switching languages and changing the default language on their computers.

    DC

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •