Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Annoying problem: BW keeps changing my keyboard layout

  1. #1
    Join Date
    Aug 2004
    Posts
    252

    Default Annoying problem: BW keeps changing my keyboard layout

    Hi all,
    I have begun to experience an annoying problem: BW keeps changing my keyboard layout to American after a search in BGM, BGT or the like databases. When I revert to Word to write, my keyboard layout has changed, if I do not manually change the search database in BW to a Danish database (or click the Analysis window to make it active).
    It has not always been so. I don't know if the change is an implementation in BW 10 or some conflicting setting between Windows 10 and BW 10. Previously, I never had this issue.

    Can this be solved by a setting somewhere?

    I guess the problem is that BW impact Window's overall language setting.

    Morten

  2. #2

    Default Possible solution together with another keyboard problem

    Hi Morten,

    I use a UK keyboard and I'd been having this problem for quite a time until a few weeks ago. I found that I needed to reset the keyboard layout settings as follows.

    Name:  BW Keyboard Layout Settings.jpg
Views: 325
Size:  62.1 KB

    This works for me.

    I find it rather more annoying that BibleWorks always loads a US Keyboard on my UK Win10 systems. This inevitably causes me problems. I'm used to toggling between UK English, Greek and Hebrew keyboards as I type, but the addition of a fourth and unnecessary US English keyboard is disruptive and causes me to make typing errors. Once loaded, the annoying US keyboard remains and cannot be removed unless I reboot and don't reopen BibleWorks. BibleWorks is my only application that does this and, while it is my go-to software for working with biblical and other texts, I find myself increasingly using a rival product if I know that I'm going to be doing a significant amount of typing in a work session. Do any other non-US users find this to be a problem?

    John

  3. #3
    Join Date
    Aug 2004
    Posts
    252

    Default

    Kendall,
    Thanks for the reply.

    Unfortunately that does not cut it for me. Still, when do a search in e.g. BGM, the keyboard changes to English (American), and when I return to Word, the change is global. Is this not still the problem for you? Try doing a search in BGM or BGT and observe if the keyboard in BW does not change to American.

    The heart of the problem seems to be that BW affects the global keyboard setting.

    I am just thinking: This cannot be true. It would mean that all users world-wide - accept those preferring an American keyboard - would be affected by this change.

    Is there a setting somewhere that we have overlooked?

    Morten

  4. #4
    Join Date
    Aug 2004
    Posts
    252

    Default

    One thing more: It seems to me that there is a change more: I used to be able to type in signs in the command line with my Danish keyboard, when doing searches in e.g. BGM (. ' / and the like) after which the keyboard automatically would shift to Greek. Now BGM is tied to the American keyboard and I can no longer use my keyboard-layout to type in search parameters (I have to click them on the icons, which is time consuming).

    Has the command line been redesigned to unicode or something like that, which causes these highly unwanted changes as well?

    Morten

  5. #5

    Default

    Quote Originally Posted by MortenJensen View Post
    Unfortunately that does not cut it for me. Still, when do a search in e.g. BGM, the keyboard changes to English (American), and when I return to Word, the change is global. Is this not still the problem for you? Try doing a search in BGM or BGT and observe if the keyboard in BW does not change to American.
    I'm sorry to hear this. I no longer have the problem of the keyboard shifting to US within BibleWorks when I type on the command line and perform a search, whether in BGM, BGT or any other database.

    I don't recall having a problem with the keyboard actually changing to US English in Word or other applications, just that the US keyboard loads in the background into Win10 when BibleWorks starts. My Win10 system otherwise only loads UK English, and Unicode Greek and Hebrew keyboards on startup.

    Quote Originally Posted by MortenJensen View Post
    Is there a setting somewhere that we have overlooked?
    Now you ask this, I've just remembered that in my effort to find a solution, I tweaked the bw1000.ini file changing all references to the US English keyboard (04090409) to UK English (08090809). In my desperation, I had hoped that this might also stop BibleWorks loading the US keyboard on Win10, but it didn't.

    John

  6. #6

    Default

    Quote Originally Posted by MortenJensen View Post
    One thing more: It seems to me that there is a change more: I used to be able to type in signs in the command line with my Danish keyboard, when doing searches in e.g. BGM (. ' / and the like) after which the keyboard automatically would shift to Greek. Now BGM is tied to the American keyboard and I can no longer use my keyboard-layout to type in search parameters (I have to click them on the icons, which is time consuming).

    Has the command line been redesigned to unicode or something like that, which causes these highly unwanted changes as well?
    This is the problem that I was having. For me, it was caused by the keyboard automatically shifting to US English (within BibleWorks alone) whenever I entered text on the command line. As you note, this messes up the entry of search parameters when working with an non-US keyboard.

    I don't believe that there's been any intended redesign of the command line, and certainly not a move to Unicode.

    John

  7. #7
    Join Date
    Apr 2012
    Posts
    275

    Default

    Quote Originally Posted by MortenJensen View Post
    Kendall,
    Thanks for the reply.

    Unfortunately that does not cut it for me. Still, when do a search in e.g. BGM, the keyboard changes to English (American), and when I return to Word, the change is global. Is this not still the problem for you? Try doing a search in BGM or BGT and observe if the keyboard in BW does not change to American.

    The heart of the problem seems to be that BW affects the global keyboard setting.

    I am just thinking: This cannot be true. It would mean that all users world-wide - accept those preferring an American keyboard - would be affected by this change.

    Is there a setting somewhere that we have overlooked?

    Morten
    Hello Morten,

    IMO, the keyboard settings is indeed one of the weak points of BW, one with which users outside of the US are regularly confronted. It would be nice to simply have BW adapt to whatever keyboard setting is used by the computer, like most other computer programs.

    One thing you may be missing: have you tried putting the default languages to Danish when you have a Greek (or Hebrew) work open, e.g., BGT or WTT?

    One other thing: the notes and the editor windows also have to be set (separately) to the language you want to type in. Switching to either one of them could cause the keyboard to default back to American English, if they are not set for something else.

    I hope that can help. I've experienced problems with this in the past but haven't noticed any peculiar behavior as of late.

    Regards,

    Donald Cobb
    Aix-en-Provence, France

  8. #8
    Join Date
    Aug 2004
    Posts
    252

    Default

    Thanks for the replies.

    My observances are as follows:
    - my default keyboard is Danish.
    - when I go to the Analysis panes, Danish is chosen.
    - when I go the Command Line, Danish is kept UNTIL i shift search database to BGM, BGT, WTM etc.
    - when I try to change the keyboard layout, I get the following message in the dialogue box for keyboard layouts:

    Name:  Udklip.PNG
Views: 307
Size:  25.1 KB.

    - when I return to Word, US English is the global keyboard layout.
    - I have to return to BW and change it by switching search database to a Danish one e.g. - or by clicking the Analysis window.

    Since it has not always been so, I am wondering what has caused the change. I don't think I have observed this a long as I have been using BW10.

    What to do?

    Morten

  9. #9
    Join Date
    Aug 2004
    Posts
    252

    Default

    Hey, I think, I found the solution - just by reading the box properly. It says that it can be changed below ... and when the first two options are clicked off, it works.
    Name:  Udklip2.PNG
Views: 265
Size:  18.9 KB
    I will just let the picture stand for a while to speak of my stupidity .
    I hope I am good now though I have not tested it thoroughly yet,
    Morten

  10. #10
    Join Date
    Mar 2004
    Posts
    1,076

    Default Try this

    Quote Originally Posted by MortenJensen View Post
    Hey, I think, I found the solution - just by reading the box properly. It says that it can be changed below ... and when the first two options are clicked off, it works.
    Name:  Udklip2.PNG
Views: 265
Size:  18.9 KB
    I will just let the picture stand for a while to speak of my stupidity .
    I hope I am good now though I have not tested it thoroughly yet,
    Morten
    I just posted a new executable and help file. This changes the way the default keyboard is determined by BibleWorks. You may need to initialize your INI file for the changes but you can try it first without doing that. See the help section on "Keyboard Layouts".

    Another thing you can try under Windows 10 is to go to the Control Panel and select advanced options under "Language". Enable the option that says "Let me set a different input method for each app window." This should isolate changes in the BibleWorks keyboard from your system default when you exit BibleWorks.

    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •