Results 1 to 10 of 10

Thread: Israeli Keyboard

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Apr 2004
    Posts
    2,122

    Default Israeli Keyboard

    When I press Ctrl-H in the BW notes/editor, it doesn't allow me to type Hebrew with the Israeli Keyboard, even though that is the option I have set, i.e., I have the option flag checked for the Israeli Keyboard. Instead, it types in the BW default Hebrew Keyboard when I am in the BW notes/editor.

    It works fine on the CL, but not the notes/editor.

    Is it supposed to be that way?

  2. #2
    Join Date
    Apr 2004
    Posts
    1,157

    Default

    When in doubt, look in "Help". Here are two pertinent sections:
    Chapter 50:
    " Use Israeli keyboard on command line
    This flag will tell BibleWorks to use the Israeli Keyboard for Hebrew input. This will be in effect only when vowel point sensitive searching is turned OFF. For vowel point sensitive searching you must use the normal BibleWorks keyboard layout. Because the Israeli keyboard does not distinguish Shin and Sin, the "a" key has Shin and the "q" key has Sin"

    Chapter 56
    "the second is an Israeli keyboard provided by SBL. To install either keyboard just double click on the filename. Note that these keyboard are only useable in application that support Unicode (like the BibleWorks editor and Word 2003). The keyboards can only be installed under Windows XP."
    So, the Israeli keyboard should work in the BibleWorks editor, unless it is true that it still works only in XP (and not Vista or 7).
    Does this give you any clues?
    Mark Eddy
    Last edited by Mark Eddy; 08-02-2010 at 11:21 PM.

  3. #3
    Join Date
    Apr 2004
    Posts
    2,122

    Default

    Thanks, Mark.

    I confess, I never thought of looking help on this one, even though that is what I generally tell everyone else to try first.

    And in that vein, from the quote portion that you provided, it appears that the Israeli keyboard should work in the BW notes/editor, but it doesn't for me, not if I press Ctrl-H to type Hebrew there.

    Does it work for you? Or anyone else?

  4. #4
    Join Date
    Apr 2004
    Posts
    2,134

    Default

    Quote Originally Posted by Adelphos View Post
    Thanks, Mark.

    I confess, I never thought of looking help on this one, even though that is what I generally tell everyone else to try first.

    And in that vein, from the quote portion that you provided, it appears that the Israeli keyboard should work in the BW notes/editor, but it doesn't for me, not if I press Ctrl-H to type Hebrew there.

    Does it work for you? Or anyone else?
    It's my understanding that the help section says the Israeli keyboard toggle is specifically for the *command line*. So I think it can be used in the editor, but to do that you'd have to change your Windows keyboard (the left alt-shift combo), rather than the control-h toggle, which is only for the command line.
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  5. #5
    Join Date
    Apr 2004
    Posts
    2,122

    Default

    Ah, you are correct, Michael. I misread Mark's last paragraph by mistaking his own last comment for part of the help file, which I still had not consulted.

    So now I see the way to do it.

  6. #6
    Join Date
    Apr 2004
    Posts
    2,122

    Default

    Maybe this will help someone...

    I have found that when I paste the WTT from the Browse window into my notes that my keyboard automatically reverts to the Israeli keyboard, which means if I want to now type something I'm all set for the Israeli keyboard. I have my "Copy To Clipboard" options set to Unicode, and of course I have the Israeli keyboard enabled in the option flags.

    I usually type all my Hebrew in Davka and then paste it over into the notes, but when you want to just add a word or two to your notes, and if you want to use the Israeli keyboard in your notes, if you paste a single word into the notes from the Browse window you can now automatically type with the Israeli keyboard. Same is true if you paste directly from Davka, of course.

    I am as familiar with the Israeli keyboard as I am with the English keyboard, so I never have to hunt for keys with the Israeli keyboard, including vowels when I type a pointed text, which I sometimes do, but the BW keyboard I have never learned.

    I said that to say this... I think BW should keep the BW keyboard only as a backward compatible option and make the Israeli keyboard the default in the future, as the Israeli keyboard is really the standard for typing Hebrew.

    I love the BW Greek keyboard, probably because I learned it and became comfortable with it, but I do think BW ought to move towards standardized keyboards whenever possible.

    Just another round of my two cents.
    Last edited by Adelphos; 08-03-2010 at 02:42 PM.

  7. #7

    Default

    Quote Originally Posted by Adelphos View Post
    When I press Ctrl-H in the BW notes/editor, it doesn't allow me to type Hebrew with the Israeli Keyboard, even though that is the option I have set, i.e., I have the option flag checked for the Israeli Keyboard. Instead, it types in the BW default Hebrew Keyboard when I am in the BW notes/editor.

    It works fine on the CL, but not the notes/editor.

    Is it supposed to be that way?
    As has already been mentioned, the Hebrew keyboard needs to be selected from windows and not with the Ctl-H; the note windows uses Microsoft's editor and the command line uses Bibleworks internal processing. The Hebrew keyboard actually works well in the Note's window, but doesn't work nearly as well in the command line. In the command line, special searches are impossible i.e. typing @* with the Israeli keyboard does not work and the sin/shin is different. I end up using the graphical search engine quite a bit when doing Hebrew searches because many of the searches are impossible to enter from the command line when the Israeli keyboard is selected.

    The keyboard does work better in bibleworks 9 then it did in Bibleworks 8; in Bibleworks 8 the Israeli keyboard would cause gibberish to be entered into the command line unless CAPS lock is on (backwards of what would be expected with the Israeli keyboard that is supposed to type Latin CAPS when the CAPS lock is on). In bibleworks 9 the CAPS lock is ignored and Hebrew characters are typed regardless of the CAPS state in the command line; in the notes window the CAPS works as expected in both Bibleworks 8 and 9.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •