Results 1 to 4 of 4

Thread: Retaining Greek & Hebrew fonts/characters in Mac

  1. #1
    Join Date
    Jul 2010

    Default Retaining Greek & Hebrew fonts/characters in Mac

    I am currently working on an academic thesis on a PC. The thesis includes extensive quotes in Hebrew and Greek copied from Bible Works 8. Recently I started experiencing problems on the PC and decided to copy these documents to my Mac Airbook by saving the docs to a DVD and then copying these to Mac MSWord. The MS Word on my Mac is the latest version, namely 12.1.
    All went well except for the Greek and Hebrew fonts/characters which have been replaced with Roman characters .
    Incidentally, exactly the same happened when I saved these docs to my iPhone using Docs-to-Go. Gr/Heb characters replaced with Roman characters.
    Does any one know what I need to do to restore the Gr/Heb characters on Mac? and if you know how to do the same on iPhone you will make my day !

  2. #2

    Default Retaining Greek and Hebrew fonts in Mac

    I do not know for certain, but my guess would be that the font you are using on the PC is not located on the Mac. I have had the same problem with some fonts in the past, and that was usually the culprit.

    In Christ,


  3. #3
    Join Date
    Nov 2007

    Default Got Unicode?

    Quote Originally Posted by Stoney View Post
    ...All went well except for the Greek and Hebrew fonts/characters which have been replaced with Roman characters .
    Are, you exporting/cut and pasting text as Unicode?
    To confirm whether yes or no, you should do the following:

    Go to

    1. Tools
    2. Options
    3. Fonts
    4. Export fonts
    5. Now, look at the Unicode Fonts (Export Only) at the bottom half of the Export fonts window.
    6. At the bottom half of the screen mentioned above You should see three check boxes with the options:

    (a) Export Greek Resources (Analysis Window, lexicons) as Unicode,
    (b) Export Hebrew Resources (Analysis Window, Lexicons) as Unicode,
    (c) Use these Unicode settings also for Verse text (override the settings in the Output Format Options)

    If the former three options are checked off, you should in theory be cutting/pasting in the Unicode format. Now, if that happens to be the case then it maybe logical to assume that Unicode is either not enabled or installed on you mac computer and applications. SBL, SIL, and Cardo have freely download able Unicode fonts that may work for you.
    Last edited by bkMitchell; 07-14-2010 at 11:27 PM.
    Brian K. Mitchell
    חפשו בתורה היטב ואל תסתמכו על דברי

  4. #4
    Join Date
    Jul 2010

    Default Hi Brian & Bret

    Hi Brian and Bret. Many thanks for your suggestions. Really appreciated!
    Brian, I will work through the steps you suggested but I am pretty sure you are right in that I am not using Unicode as export mode. Neither Mac nor iPhone would be able to read the characters if not in Unicode.
    Many thanks again. I will try your suggestions and get back to you.
    Have a great day!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts