Results 1 to 2 of 2

Thread: Search problem of BW7 in Vista

  1. #1
    Join Date
    Dec 2008

    Question Search problem of BW7 in Vista

    Dear all,

    I use Vista Home Basic and BW7 and I have CU5 & CUS successfully installed. I can type and see Chinese charaters in the search command line but BW7 canít do the search and error message appears. Some said the problem was caused by Unicode and suggested to search by right clicking word/phrase in Chinese bible but I found it doesnít work either.

    Whatever is the cause of the problem, I would like to know if other users have same problem. Do you know if BW8 has the same problem?


  2. #2
    Join Date
    Apr 2004


    Yes, I have the same problem, sometimes. And yes, BibleWorks 8 has the same problem. I alerted the programmers to the problem in beta testing. Since none of the programmers knows any Chinese (and I know only a few characters) they did not know how even to tell if a search was being done correctly or not. Sometimes I can search for a phrase by highlighting it, and BibleWorks does the search. When I search for multiple-character words (I just searched on the characters for the number 80), the search worked. But other phrase searches do not work. When I first tred to search for a single character word (I tried searching on the word for "God") BW failed to list any search results. But just now I tried a phrase search (first 4 characters of John 3:16, which worked properly), so I clicked on the first character again, and this time BW did a search and produced a list of all the verses with the character for "God." I seem to have "primed the pump" for Chinese searches, since they are working now, after the first few failed. I searched on the two characters for "eternal" and the search worked fine. Always before BW had given an error message or simply did not show any search results. I do not know enough Chinese to understand why some string searches work and others do not. I do not yet understand how to type anything in Unicode, so of course I have never been able to type Chinese onto the command line of BibleWorks. Sorry.
    Mark Eddy
    P.S. When Chinese searches work, the letters "IME" display in yellow in the upper right hand corner of the command line. Perhaps it takes BibleWorks a few times searching by the highlight-and-click method before I understands which language keyboard is being used.
    Last edited by Mark Eddy; 08-18-2009 at 10:54 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts