Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Problems typing Greek Unicode in Editor

  1. #1

    Default Problems typing Greek Unicode in Editor

    Before I file a bug report I'd like to see if anyone else is having trouble typing unicode Greek accents in the editor?

    When I type: λόγος I'm getting λο?γος

    I can't guess where this started. I can still paste correctly and I can type of course just fine in bwgrkl, but I prefer to work in unicode. Any comments?

  2. #2
    Join Date
    Apr 2004
    Posts
    2,136

    Default

    What Unicode font is it using?
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  3. #3

    Default

    Quote Originally Posted by tcblack View Post
    Before I file a bug report I'd like to see if anyone else is having trouble typing unicode Greek accents in the editor?

    When I type: λόγος I'm getting λο?γος

    I can't guess where this started. I can still paste correctly and I can type of course just fine in bwgrkl, but I prefer to work in unicode. Any comments?
    I have never been able to use the Unicode Greek. None of the accents work, with Arial MS, Gentium or any other font. Isn't there a long-standing thread on this? Has anyone ever been able to get it to work?

  4. #4

    Default Previous thread on this problem

    Here's the previous thread:
    https://www.bibleworks.com/forums/sho...=8803#post8803

    no solutions reported
    Mark G. Vitalis Hoffman
    Glatfelter Professor of Biblical Studies
    United Lutheran Seminary at Gettysburg & Philadelphia
    uls.edu - CrossMarks.com
    Biblical Studies and Technological Tools

  5. #5
    Join Date
    Apr 2004
    Posts
    2,136

    Default Correction: it works perfectly for me now.

    Go to this website: http://www.biblicalgreek.org/links/fonts/keyboard.html

    Following the first half of their instructions, I can get BW Editor to work successfully in Unicode Greek.

    Windows XP-
    1. In the Windows XP standard Start menu, click Start, and then click Control Panel.

      In the Windows XP classic Start menu, click Start, click Settings, and then click Control Panel.
    2. Double-click Regional and Language Options.
    3. Click the Languages tab, and then click Details under "Text Services and Input Languages".
    4. Click Add under "Installed Services", and then click Greek Polytonic to add and the keyboard layout for the language.
    5. To configure the settings for the Language bar, click Language Bar under "Preferences".
    Experiment with those exact instructions.

    Note: In the Language Control Panel I also went to Keyboard Settings and made Left-alt-shift toggle between keyboards. Now in BW I hit Left-alt-shift and it goes back and forth from Greek Unicode to English.
    Last edited by Michael Hanel; 11-06-2006 at 07:24 PM.
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  6. #6

    Default

    Does not work.

    I can type in unicode Greek in any number of other programs, including MS Word. I already have the language settings set up for switching between languages and use the Logos Hebrew and Greek keyboards for that.

    Logos' Unicode support is far superior to BW's (IMO).

  7. #7

    Default Part of the problem identified...

    Very interesting that you got it to work, Mike... and now it becomes clearer why the BW folks were thinking that it works and were unable to replicate the difficulties many of us were having.

    Your success made me suspect that perhaps it was the keyboard setup that I am using that is the problem. I have been using the Logos keyboard (perhaps the programs don't like playing with each other!), because it offers a much easier (IMO) way to enter accents and breathing marks. They are entered after you type the vowel, and you can type both an accent and a breathing mark (or vice versa) sequentially to got both placed over the vowel. You don't have to remember what shift-key stroke is what combined accent. It also automatically knows to convert final sigmas.

    I installed the Logos keyboard and I tried using the built in Greek Polytonic keyboard which you apparently are using, and idou! the accenting works.

    I don't know how high on the list of things to check this issue goes for the BW support. I hate to switch to a different keyboard. For now, I've been doing my typing in WordPad and then copy/paste into the BW editor.
    Mark G. Vitalis Hoffman
    Glatfelter Professor of Biblical Studies
    United Lutheran Seminary at Gettysburg & Philadelphia
    uls.edu - CrossMarks.com
    Biblical Studies and Technological Tools

  8. #8
    Join Date
    Apr 2004
    Posts
    2,136

    Default

    I don't use Logos for any Unicode stuff, so I'm not in a good position to explain how that program is or isn't working. I'm also not an expert on how Windows is or isn't using Unicode keyboard controls, all I know is when I follow the instructions in my post above it works. As the blind man from John says, "All I know is that now I can see." And it works really well at that (in my opinion).

    Even right now in Firefox, I hit alt-shift and boom ι καν τυπε ιν Γρεεκ πολυτονιψ Alt and shift and I'm out of it.
    You want accents?
    ά ᾱ ὰ ᾳ ᾰ ἇ ἆ etc. they all seem to work both in here and in the Editor.

    From a programming perspective, I don't know how you isolate what the "problem" is. When Windows uses the "Greek Polytonic" keyboard, things seem to work in BW. When it isn't, there seems to be that problem.
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  9. #9
    Join Date
    Apr 2004
    Posts
    2,136

    Default

    Quote Originally Posted by MGVH View Post
    I installed the Logos keyboard and I tried using the built in Greek Polytonic keyboard which you apparently are using, and idou! the accenting works.
    So what did you do differently to make it go from not working to working? What is left that is not working?
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  10. #10

    Default Clarification

    >>>>> I UN-installed the Logos keyboard and I tried using the built in Greek Polytonic keyboard which you apparently are using, and idou! the accenting works.

    I meant to write "uninstalled" the Logos one and used the WinXP Greek Polytonic and things work fine just as you describe.

    There are still issues with how these keyboards handling accenting: do you have to type the accent/breathing before or after the vowel? Can you use both accent and breathing or do you have to use a combination? Does the resulting character show up as a combined one (where it simply adds the components together) or a pre-composed one (where it substitutes the character with the proper accent/breathing)?

    Mark
    Mark G. Vitalis Hoffman
    Glatfelter Professor of Biblical Studies
    United Lutheran Seminary at Gettysburg & Philadelphia
    uls.edu - CrossMarks.com
    Biblical Studies and Technological Tools

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •