View Full Version : Mappiq Search

04-15-2005, 06:40 PM
When I search for a hey with a mappiq in WTT it returns Deu. 32:36 and highlights the first hey, which does not have a mappiq. That's the only verse it returns, even though there are of course others where hey contains a mappiq.

Likewise, when I search for an aleph with a mappiq (or is that perhaps a dagesh in Gen. 43:26???) in WTT, I get --

"The following word or form cannot be found in the current search version" --

even though I'm looking at one in Gen. 43:26 in "come." I even copied that one to the CL so that it would be correct.

I also played with WTM and with the accents on/off, etc., but I still get no joy.

Anybody know what's going on?

http://www.lamblion.net (http://www.lamblion.net/)

04-15-2005, 08:04 PM
Actually, here is an example of the searches I've tried in WTT/WTM --


And so forth. I've tried it with accents on and off. Of course, I am aware that WTM requires different sytax, but I tried every combo I could think of.

http://www.lamblion.net (http://www.lamblion.net/)

Philip Brown
04-16-2005, 02:02 PM
Chairein, Adelphos,

To search for mappiqs or dageshs: Tools | Options | Option Flags | General Hebrew Options > uncheck Ignore Dageshes in Hebrew searches.

Then with vowel-point sensitive searching ON, in the WTT type .H*


04-16-2005, 08:07 PM
To search for mappiqs or dageshs: Tools | Options | Option Flags | General Hebrew Options > uncheck Ignore Dageshes in Hebrew searches. Then with vowel-point sensitive searching ON, in the WTT type .H*

toda raba, Philip, but I still can't get it to work. If I check vowel point sensitive searching, it won't let me type in the syntax without turning red, meaning error. If I leave it unchecked, but also uncheck Ignore Dageshes, I don't get accurate results.

If it works for you, then I suspect I have some flag checked somewhere -- or not checked -- that is fouling things up.

I might also add, that I didn't mean to start a discussion on mappiqs, dageshes, and the gutterals, albeit there are so many grammatical rules that SEEM to be broken in the Hebrew text in some of these extraordinary readings that I was just curious if someone had some little-known or hard-to-find info on the mappiq in the aleph, as I think I remember reading or hearing somewhere that somebody had actually labeled it as a dagesh, and if they did, then I was simply looking for the justification, but as I said, that discussion is probably best left alone on this forum.

In short, I'd simply like to get my search working properly.

http://www.lamblion.net (http://www.lamblion.net/)

Philip Brown
04-16-2005, 10:09 PM
Ok, let's try this.

Here are the options I have set for Hebrew. Everything the same there?

Make sure you're using the WTT with vowel point sensitive searching ON.

If that doesn't work, you may find the verse lists that list the items you want attached. At least you get the data, until you can figure out which button you haven't pushed yet.

04-16-2005, 11:09 PM
Ok, let's try this...

Philip, thanks for the vls lists; they are mighty helpful. However, I STILL can't get my own search to work.

I made sure my options were identical to yours, but I still get the same problem; i.e. --

When I have vowel sensitivity ON, after I type the period or semicolon, or whatever, when I type the "H" it beeps and turns red, thus indicating an error.

The ONLY way I can avoid the beep and the error is to have vowel sens. OFF, and then I of course get inaccurate results.

I have no idea what's going on.

I'd really like to know why you don't get a beep and a red letter with vowel sens. on, while I do.


Philip Brown
04-17-2005, 07:53 AM
Oh, it's the beep and red that's the problem ...

1. I turned the beep off a long, long time ago. :o) I think it's under Command Line Options
2. The letter turns red because BW thinks you are trying to start a Hebrew word with a hey-mappiq. And, of course, no such word exists.

HOWEVER, ignore the red. You know better than BW what you are trying to do. Follow one of the following sequences exactly to bypass the "red-shift"
Both options require WTT with vowel-point sensitive searching ON

Option 1 -- no red error flagging
1. type a period
2. hit the insert key (Allows placement of special characters on CL when vowel-point sensitive searching is ON)
3. type an asterisk
4. move the cursor to the left of the asterisk
5. type Shift-H (line should now be .H*)
6. hit enter

Option 2 -- ignore red error flagging
1. type a period
2. type Shift-H (line becomes red)
3. move the cursor to the right of the hey-mappiq
4. hit the insert key
5. type an asterisk
6. hit enter

Have a blessed Lord's Day!

04-17-2005, 05:46 PM
HOWEVER, ignore the red. You know better than BW what you are trying to do.


Thank you. I should have bullied my way through. I had no idea that one could boss BW around that way! ;) Now I wonder what else I can do in BW with this new-found disobedience!


04-17-2005, 06:02 PM
Philip, just out of curiosity, how do you get the aleph with mappiq on the CL?

The only way I've been able to do this is by copying it from one of the verses where it occurs. Is there a way to type it in from the keyboard?


Philip Brown
04-22-2005, 05:02 PM
Sorry about the delay in responding -- out of town.

Follow these steps:
1. Tools | Font Maps
2. Click the Keymap Tables button
3. In the Key Maps dialog, choose Hebrew
4. Set magnification to 250% or similar large size
5. Scroll down looking for Aleph-mappiq -- you should find it at location 130.

[You can enter on the Command Line any character listed in the keymaps dialog by typing the following sequence:
With the ALT key held down, type 0 followed by the location number. In this case it would be ALT + 0130]
6. Return to CL and type ALT + 0130 for the aleph mappiq

Hope that helps.

04-25-2005, 07:28 PM
Now there's some kismet for you. I just now -- not less than thirty minutes ago -- walked in the door from being out of town myself.

As usual, thanks again for the key manipulation technique. This was something I was suspecting as Aleph w/ mappiq ain't a high profile consonant.

On the other hand, there can be some nice surprises with the inclusion or exclusion of the mappiq, especially with the final Hey, all of which have bearing on textual criticism and the fixing of the canonical text for a specific tradition.

The only problem is -- there is FAR too much data for anyone to master it well while at the same time have life.:eek: