View Full Version : Chinese Version Navigation Problem

06-20-2013, 04:01 PM
This problem has been fixed! (updated 4/29/2014)

In other versions, if we want to go to a certain verse in the same book, we don't need to type the book name. For example, if we are in Gen 1:1, and we want to go to Gen 9:25, typing 9 25 is enough.

However, it seem that in Chinese version, BW does not recognize the "space" between 9 and 25. When I type 9 25, it reads 925. (see the screen shot below.)

But if I type gen 9 25, it works.

Hope this problem can be fixed soon.


Jim Wert
06-21-2013, 08:58 PM
I am running BW9,, Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit.
I have done nothing special to enable any language or keyboard, have never experimented with IME (Microsoft Input Method Editor.

All the BibleWorks documentation that I could find about the Command Line and Chinese versions applied to BW7. In BW7 I am able to navigate normally from the Command Line. (As described in the documentation I refer to below, BW7 has 3 input modes for the Command Line. The first 2 handle navigation normally, the third, called Automatic, behaves just like BW8 and BW9 do (as you described above).

In BW8 and BW9, when the search version is CUS, the Command Line turns a pale yellow, with IME in the upper right hand corner:

If I right click in the Command Line, I get some additional lines at the top of the popup:

In both BW8 and BW9 clicking on any of the options provided had exactly the same effect: no change in behaviour. Which may be because I haven't done anything about keyboards. Still, it seems a step backwards to take away the simple navigation capabilities of BW7.


BW7 Help Section 18b The Command Line - Arabic and Far Eastern Languages
BW8 Help Section 26 The Command Line - Arabic and Far Eastern Languages
BW9 Help Section 36 The Command Line - Arabic and Far Eastern Languages
BW Forum FAQ item http://kb.bibleworksllc.com/kmp/index.php?/article/AA-02854/0/How-Do-I-Use-An-Input-Method-Editor-in-BibleWorks-for-Chinese-and-Korean.html

All 4 of these items describe the situation in BW7; items 1, 2, & 3 appear to be identical.


06-21-2013, 10:50 PM
Hi Jim,

Do you mean you don't have any problem with that?

I have tried again.
The color also turned to yellow. The IME is also present.
If I type "gen 1 2", it works well.
But if I type "1 2", it doesn't work.

I didn't change the keyboard either.


Jim Wert
06-22-2013, 11:40 PM
Hi Jim,

Do you mean you don't have any problem with that?

In BW8 and BW9 I have exactly the same problem that you have.

All the confusing stuff I said in my previous post was an attempt to say that:

BW7 handled navigation fine.
With the introduction of BW8 BibleWorks changed how it handled Chinese navigation, so that it no longer works for me, and the changes carry over to BW9.
All current BibleWorks documentation that I could find (BW9 Help and BW Forum FAQ) describe how BW7 worked, not how BW9 works.

Hope this isn't even more confusing.


06-23-2013, 07:22 PM
Thank you very much!
Pardon me, cause I was wondering, if you don't have the same problem, it would be my own problem...

Glenn Weaver
06-24-2013, 08:59 AM
Hi Folks,

I have sent a bug report and a link to this thread to our programmers. I'm sure that they will take a look at it and provide a solution to the problem. I do not know how soon this may be fixed, as I do not know their programming schedule or the reason for the problem.


06-24-2013, 05:38 PM
Thanks a lot, Glenn.

04-28-2014, 10:44 AM
Seems the problem has not been solved.
No matter what I type, either "5 5", "5.5" or "5:5", it returns the same error. However, if I type "Dan 5 5", or "Dan 5.5" or "Dan 5:5", it works well.

Mark Eddy
04-28-2014, 10:26 PM
Apparently BW does not remember the book name when we search using a Chinese version. The same problem occurs with Japanese, Korean, Thai, and Arabic versions, those with double-bit fonts. It is impossible to do any searches in Vietnamese, since there are no numerals on the Vietnamese keyboard. You can't use the Cyrillic font to do searches by book, chapter, and verse either, since it substitutes Cyrillic letters for the book names. At least in Chinese you can search by using English book names.
Mark Eddy

04-29-2014, 09:53 AM
I'm so glad that it has been fixed in the most recent update. I've updated and tested it, and it really works now!
very grateful.