View Full Version : Hebrew and English Order of Letters

Yaku Lee
07-31-2009, 10:25 AM
(I prepared this post on MS Word, and copy-patested it here. And it is really frustrating that it does not come out the same, and it is messed up here. I tried to edit this post and it does not respond as I would expect it to on Word. So I leave it as is. But please ttry it on MS Word and hopefully you will see what I mean.) There seems to be a conflict in the order of letters when Hebrew text is copied into English text, and I would like to know if you have the same experience as I do as in the following:

(1) Select Gen 30:11 Hebrew text and Coltrol+C copy in the normal way.

(2) Go to MS Office Word (2007), and Contol+V paste it on a separate line. Everything is OK like this:

WTT Genesis 30:11וַתֹּאמֶר לֵאָה )בְּגָד] (בָּא] [גָד[ וַתִּקְרָא אֶת־שְׁמוֹ גָּד

Here the letters in “[ ] [ ] ( ) WTT Genesis 30:11” are from left to right in order, but the rest of the Hebrew letters are from right to left.

(3) Now write something and stop in the middle of a line as in “This is what happens in the middle of a line:” then on the same line Control+V paste the Hebrew text. And this is what I get:

“This is what happens in the middle of a line:WTT Genesis 30:11וַתֹּאמֶר לֵאָה )בְּגָד] (בָּא] [גָד[ וַתִּקְרָא אֶת־שְׁמוֹ גָּד

What happened is that the consecutive L-to-R English text is put together first in a right justified line, and then the Hebrew text is kept R-to-L with the internal “[ ] ( )” in the L-to-R order.

(4) Now put the cursor in the middle of English text, and insert or delete spaces to make the line longer or shorter to observe the behavior of “[ ] ( )” when they come at the end of the line.

I observe that the internal brackets and parens behave L-to-R in the middle of R-to-L Hebrew letters. And this behavior of the letter order seems to cause all the problems in copying Hebrew text into English text.

Do you have the same experience as I do, or is this my problem alone?

I have updated the BW8 as of July 31, 2009, and I am using MS Office Word 2007 on Windows XP OS. And I tried deleting “bw800.ini” with the same result.

Thanks for your cooperation.