View Full Version : Bizarre behavior with context tab

04-08-2009, 11:26 AM
I've never used the context tab in the analysis window before, but playing around with it just now I've discovered something completely bizarre. When I have this tab open and am looking at 1 Sam 2:1 in the browse window, with various versions displayed, including WTT, when I hover my mouse over a Hebrew word, it displays a word from several verses later in 1 Sam 2. As I move the mouse, the words change, but remain in the later verse. For instance, if I'm in 1 Sam 2:1, the words displayed are from 1 Sam 2:11. And if I click the verse number box to change to a different verse, it says that the current verse is 2:11, not 2:1! If I do change to 2:11, the mouse-over words and the verse number box actually are in 1 Sam 2:18.

This happens in other OT books as well, and with other ancient-language versions (BGT, TAR), but only when the context tab is displayed, not when other analysis window tabs are displayed. Is there something about this tab that I'm not getting? Or what?

David Rensberger

04-08-2009, 01:39 PM
David, I may be misunderstanding you. When I have the context tab displayed, it displays the context of the current search version only. I get a pericope context book context and chapter context. "Mousing over" does not really change anything in that display because the smallest focus, the pericope is larger than a given verse. I am attaching a screen print. Are we seeing the same thing?

Mark Eddy
04-08-2009, 09:10 PM
I would guess that David is talking about the pop-up "word tips" which can display when the cursor is over a word. They work fine on my computer, with or without the Context tab being open. If you close down BibleWorks and re-open it, does the same problem occur for you?
The only problem I see in 1Sa 2:1 is that the word tips for the words

are missing the defintion line. This may be a bug, or an anomaly in a database.
Mark Eddy

04-09-2009, 12:18 AM
I'm sorry, I was looking for something to actually change in the context tab. I did turn word-tips on, and see no problems with what is displayed. I ran for a while with the context tab active and cannot reproduce the problem.

04-09-2009, 01:42 PM
Sorry that I wasn't clear before. Yes, I'm talking about the word tips. I restarted BW, and then I rebooted my computer, and the problem persists. It seems to be confined to biblical texts in Greek, Hebrew, and Aramaic (since, I guess, the context tab only works with biblical texts, and those are the languages with the word tips).

I'm attaching a screenshot that shows the problem. The mouse is hovered over the third word of 1 Sam. 2:1 (rm;aTow:); but the word tip displayed is for ht'm'r"h', the third word of 1 Sam. 2:11.

This is happening using BW 8.0.008f.1, which I think is the most current update.

David Rensberger

04-09-2009, 06:14 PM
I fixed a synchronization problem (8.0.008i) with the context tab refresh code. This should fix this problem but let us know if it rears its head again.


04-10-2009, 11:38 AM
Thank you! Problem solved! This is just amazingly responsive program support, very rare and very much appreciated!

Let me wish you, Mike, and all your colleagues at BibleWorks a blessed Good Friday and a joyous Easter to come.

David Rensberger