View Full Version : New copying quirk

06-14-2004, 07:58 AM
This weekend, as I typed up my Sunday School lesson, I ran into a new copying problem.

I use BW's 6, latest updates, and Microsoft Word.

In CL I typed in a range of 4 verses. 2Pe 1:1-4.

I opened several other verses, did some searches, etc. and started to type my lesson.

I use the popup copy window and found I was getting 4 copies of the same verse. I also found this was true sometimes when using the copy center. Having more time this morning I think I have discovered that the number of verses I get when copying with the popup window correstponds with the number of verses in a range of verses typed in the CL.

The copy center and popup window will remember the largest range and use that even if a range of just one verse has been called for after the four verse range mentioned above.

If I close the cc and reopen it the cc will correctly copy one verse (sometimes) but the popup window remembers the longer range. This problem doesn't seem to go away until BW's is closed and reopened.

Thank you.


Joseph B. Modica
06-14-2004, 05:46 PM
I too had the same problem as Al (believe it or not, I was also working on 2 Peter 1 last week). The problem described by Al was resolved only by exiting the program. I have not tried to replicate the problem since then.
Grace and peace, --Joe

Mark Langley
06-14-2004, 06:21 PM
I am following Al's example but I am unable to dup his problem.

John Fallahee
06-15-2004, 05:47 PM
Steps to reduplicate copy bug:
1) View > Browse Mode (uncheck this selection)
2) Enter in a range of verses (John 1:1-10) in the command line, press enter
3) Open a Word Document
4) Press ctrl+shift+b
5) Enter a single verse (Mark 1:1), choose one translation
6) Click on the copy button
7) You will see a re-pasting of the single verse correspond to the number of verse in the "non-browse" mode

1) view > Browse Mode (check this selection) or click on the "feet icon"

Mark Langley
06-15-2004, 11:31 PM
I must be missing something. Still not able to dup.

Joe Fleener
06-16-2004, 12:21 AM
I followed John's steps and did not see the error here, I got Mark 1:1 in the NAU (as I chose) just fine. ??

John Fallahee
06-16-2004, 10:59 AM

I reduplicated the steps and now I can not duplicate the error
(Word 2003, BW 6.0.01f0)

Very Strange!

- John

06-16-2004, 11:09 AM
As the one who started this thread, I'd like to suggest that it ought to stop. The patch posted yesterday said: "BibleWorks Executable (Rev 1 6.0.010f)

BibleWorks Automatic Update Notification
Date: 06/15/04 at 22:07:15
Title: BibleWorks Executable (Rev 1 6.0.010f)
This patch contains the latest executable.

A recent patch to fix an issue relating to the Results Window remembering ranges in multi version mode has cause some unforeseen side effect. The fix has been removed and the issue will be revisited later in a PREVIEW version."

So this is a non-issue for now, BW's has replicated this problem and will work on it.

Thanks for the feed back on this.