View Full Version : Internet Connection Problem

Michael Burer
06-20-2006, 08:57 AM
I recently updated to 7.0.015b and started having problems connecting to the internet to look for updates. Previously I had no problem, but now whenever I check for updates BW tries to start a connection. When I cancel that window, I get an error message stating that BW could not connect to the internet and I do not see any new updates. I only connect to the internet through a high-speed LAN, and I know it is working fine; I can get e-mail, go to web sites, etc. I have doublechecked my internet connection settings, and I am certain that "never dial a connection" is checked.

Is anyone else having this problem?

06-20-2006, 10:00 AM
Have you recently done any updates to Windows or installed any new security software? A number of firewall programs will prevent outgoing connections from unknown programs. I have to specifically give BibleWorks permission to access the internet. If I don't the firewall stops it from making any connections and the program will tell me that the connection failed.

Other than that, I've had no problems connecting BibleWorks to get updates.

Michael Burer
06-20-2006, 11:58 AM
No, nothing of that sort.

Interestingly, I rolled back to 7.0.014z, and could connect fine. I then saw the update to 7.0.015c and tried that, but could not connect. I have since rolled back to 7.0.014z again and can connect fine. My hunch is that something happened in rev 15b which should not have. I will contact tech support to let them know.

06-20-2006, 02:55 PM
That's odd since I'm running 7.0.015c and have no trouble connecting. Just tried and it got the latest BDAG update with no problem.

06-20-2006, 03:53 PM
I'm not having the problem now but have had this in the past. It has always turned out to be the firewall in Norton Internet Security. For some reason the program control for BibleWorks gets reset to block all. Even though I'm connected to the Internet through a cable modem, the dialer is invoked and I just can't get past it.

This doesn't explain why rolling back to previous versions of BibleWorks would work. It does, however, explain why only BibleWorks is affected. Check the program-specific settings in your firewall to make sure that's not it.

Tom R.

06-20-2006, 08:57 PM
Though I'm not highly familiar on the inner workings of firewall programs, my thought is that when a program is approved the firewall takes a "snapshot" of that program so that when the program tries to access the outside world, the firewall has a few details to verify the program is the original program and isn't a hijacked version. When the program gets updated, those details change and the firewall needs a new snapshot (needs you to approve it again) in order to work. In this case, my suspicion is that backing down to the old version of BibleWorks returns the program to the details the computer is already familiar with - a snapshot of the older version matches the snapshot stored by the firewall, so the firewall approves. Upgrade BibleWorks and the snapshot is different so the firewall requires the program to be re-approved.

06-21-2006, 06:02 AM
I have installed Windows Live One Care and BibleWorks is the only program that is causing this behaviour.

Is there a setting in BibleWorks to prevent it?

The program looks for a dial up connection, but I use a broadband router.

If anyone knows a solution I'd love to hear it.

David McKay
www.gontroppo.blogspot.com (http://www.gontroppo.blogspot.com)

06-21-2006, 01:42 PM
Looking for a dialup connection is sort of default behavior when an internet connection is not detected. I use OneCare and the only action needed is to add BibleWorks to the firewall exception/allow list, though for me this has to be done every time I update BibleWorks. Usually it pops up a message and asks me if I want to give it permission, but if you're not getting the popup you can do it manually through OneCare settings for the firewall. I'd tell you exactly where to go for that but I'm in Vista at the moment and OneCare doesn't run on Vista.

06-23-2006, 01:00 AM
Thanks Columcille.
I wondered why it is always asking permission when I thought I had given it permission.

Still wish it wouldn't, but!
David McKay
www.gontroppo.blogspot.com (http://www.gontroppo.blogspot.com)