View Full Version : Searching help

04-18-2006, 01:23 PM
In BW5 when searching a morphological version you could right click and search for the exact form or all forms of a given word. In BW7 when I try this I get the same hits for "search this form" as I do "search on all forms of lemma". How come I cannot get it to search for the exact form when searching with right clicking in the browse window? Is there a setting I have missed?

Can anyone help with this?



Ben Spackman
04-18-2006, 01:48 PM
Looks like a programming error, as I get the same thing.

Of course, you can always just double click on the word in the non-morph version (though with hebrew that means same form+ whatever prepositions it's attached to.

Philip Brown
04-18-2006, 08:04 PM
Just tried WTM and BGM, neither morphology version gives the same number of hits for the options
"Search on form"
"Search on All forms of lemma"

What word(s) did you try?

04-18-2006, 09:09 PM
I just opened BGM to 2 Peter 1:21 checked most of the words in the verse and got the same results searching on form or all forms of lemma. Try it and see. I originall found the problem in SCM with any word I tried.
I don't know what is happening unless it is a setting I have wrong.


04-18-2006, 09:17 PM
The only way to get the correct hits on "search form" is when you are not in a morphological database. Then it works. But I have tried SCM, BGM, BNM and have the problem with all of them.


04-18-2006, 09:51 PM
But I have tried SCM, BGM, BNM and have the problem with all of them.

I can duplicate the same behavior.

04-19-2006, 12:48 PM
Is this a problem in the programming? Should BibleWorks be notified of a error?


Philip Brown
04-19-2006, 11:08 PM
Hi, Todd and others on this thread,

I was able to duplicate your problem, but it depends on where you click in a morphology version.

In 2 Peter 1:21,
1. right click on profhtei,a (I mean directly on the Greek text itself)
2. choose "Search on form"
3. Notice that the CL reads profhtei,a@*

1. right click on the parsing codes appended to profhtei,a
2. choose "Search on form"
3. Notice that the CL now reads profhtei,a@nnfsc

The "problem" is that the form isn't being searching on when you right-click the Greek word, but rather only when you right-click the parsing codes.

I'll report this to the development team.

04-19-2006, 11:56 PM
Hi Philip,

This is actually intentional, though it periodically raises questions and probably is not worth keeping the way it is for that reason. The rational is that when you click on a form and choose to look up the lemma, it does just that - looks up the lemma. But it copies the lemma and the clicked morphology the the command line. The assumption is that if you look up the lemma (xxx@*) and want to investigate further, you will probably want to edit the code+lemma to do a new search, so that is what is copied to the command line. So the stuff copied to the command line is not intended to reflect what was searched, but just to provide a starting point for refining the search. Sorry it is confusing.

04-20-2006, 08:06 AM
I found my problem. I have the view set to interlinear mode!
In this mode you cannot click on just the codes. Switch to interlinear and there is no way to search on exact form. (from right click)

Can this be fixed, I like the interlinear view.