Results 1 to 5 of 5

Thread: Copy Hebrew to Excel

Hybrid View

  1. #1

    Default Copy Hebrew to Excel

    When I copy Hebrew words to Microsoft Word, the font is just as appointed, whether Ezra SIL or SBL Hebrew. But when I copy the Hebrew words to Microsoft Excel, the font does not work. It becomes English letters.

    I wonder if it is only the problem on my computer, or it is a bug?

  2. #2
    Join Date
    Apr 2012
    Posts
    136

    Default

    Quote Originally Posted by Martinzh View Post
    When I copy Hebrew words to Microsoft Word, the font is just as appointed, whether Ezra SIL or SBL Hebrew. But when I copy the Hebrew words to Microsoft Excel, the font does not work. It becomes English letters.

    I wonder if it is only the problem on my computer, or it is a bug?
    I get similar results. BWheb and BWgrkl paste in fine (although I have to go back and type in the name of the font in order for the words to appear in Hebrew or Greek), but unicode comes out as ???????????. You may want to get in touch with BW directly to see if they have a solution. If there is one out there, thanks for letting us know!

    Regards,

    Don Cobb
    Aix-en-Provence, France

  3. #3

    Default

    Quote Originally Posted by Donald Cobb View Post
    I get similar results. BWheb and BWgrkl paste in fine (although I have to go back and type in the name of the font in order for the words to appear in Hebrew or Greek), but unicode comes out as ???????????. You may want to get in touch with BW directly to see if they have a solution. If there is one out there, thanks for letting us know!

    Regards,

    Don Cobb
    Aix-en-Provence, France
    I Have got reply from their custom support. Here is the solution:

    One solution I found was to go to Tools | Options | General | Flags | Export Options and check Enable HTML output to clipboard.

    That allowed me to paste Hebrew text into an Excel cell for it to display in Hebrew.
    Hope it helps other people as well.

  4. #4
    Join Date
    Mar 2004
    Posts
    839

    Default Hebrew in Excel

    Quote Originally Posted by Martinzh View Post
    I Have got reply from their custom support. Here is the solution:



    Hope it helps other people as well.
    The reason this is necessary is that Excel does not support RTF input, only HTML. HTML export in BW is turned off by default because normally you don't want to export HTML to Word. It just doesn't work as well as RTF. If we put both RTF and HTML on the clipboard Word chooses HTML unless you select copy special and force it to use RTF.

    Mike

  5. #5
    Join Date
    Apr 2012
    Posts
    136

    Default

    Quote Originally Posted by MBushell View Post
    The reason this is necessary is that Excel does not support RTF input, only HTML. HTML export in BW is turned off by default because normally you don't want to export HTML to Word. It just doesn't work as well as RTF. If we put both RTF and HTML on the clipboard Word chooses HTML unless you select copy special and force it to use RTF.

    Mike
    Thank you Martin, and thank you Mike! That's good to know. It works like a charm!

    DC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •