Results 1 to 5 of 5

Thread: Tip: BibleWorks on Parallels - Shift key doesn't freeze Word Analysis Window

Hybrid View

  1. #1
    Join Date
    Nov 2012
    Posts
    4

    Lightbulb Tip: BibleWorks on Parallels - Shift key doesn't freeze Word Analysis Window

    Numerous people have reported in the past, that the Shift key does not freeze the Word Analysis Window when using BibleWorks 7 or 8 on Parallels 6, 7 or 8. This bug has been present since at least 2008 (see posts here, here and here) This does not happen when running BW in VMware or VirtualBox. Looking through the BW forums it was suggested to use the Option/Alt key as a work around. I used this for months, but was never satisfied with it as you had to click the Browse Window again to continue updating the Word Analysis Window.

    While looking for a solution in the Parallels forums, I found out, that the bug is caused by a faulty way of handling the Shift Key in Parallels Desktop. It is a known issue as admitted by Parallels staff: "PD delays shift until other key is pressed as it is a part of some shortcut which should not go to VM." Even though promised by them this has never been fixed in the default installation of PD, as I still had the problem after upgrading to PD8.

    There is a simple solution, though, which I have not seen mentioned in the BibleWorks forum. Just change the settings for your VM as follows: In the Parallels Desktop menu go to 'Virtual Machine' --> 'Configure...'. Then in the configuration dialog click on 'Options' then select 'Advanced' and then activate the Option 'Optimize modifier keys for games'.

    I eventually found a Parallels Knowledgebase article with screenshots about this, which in spite of the title, also applies to BW: Problems with Ctrl, Alt, Cmd, Shift and other modifiers in games http://kb.parallels.com/en/7072

    I hope this helps someone. Please let me know, if it works for you.

  2. #2
    Join Date
    Apr 2012
    Posts
    102

    Default

    Quote Originally Posted by ChrisW View Post
    Numerous people have reported in the past, that the Shift key does not freeze the Word Analysis Window when using BibleWorks 7 or 8 on Parallels 6, 7 or 8. This bug has been present since at least 2008 (see posts here, here and here) This does not happen when running BW in VMware or VirtualBox. Looking through the BW forums it was suggested to use the Option/Alt key as a work around. I used this for months, but was never satisfied with it as you had to click the Browse Window again to continue updating the Word Analysis Window.

    While looking for a solution in the Parallels forums, I found out, that the bug is caused by a faulty way of handling the Shift Key in Parallels Desktop. It is a known issue as admitted by Parallels staff: "PD delays shift until other key is pressed as it is a part of some shortcut which should not go to VM." Even though promised by them this has never been fixed in the default installation of PD, as I still had the problem after upgrading to PD8.

    There is a simple solution, though, which I have not seen mentioned in the BibleWorks forum. Just change the settings for your VM as follows: In the Parallels Desktop menu go to 'Virtual Machine' --> 'Configure...'. Then in the configuration dialog click on 'Options' then select 'Advanced' and then activate the Option 'Optimize modifier keys for games'.

    I eventually found a Parallels Knowledgebase article with screenshots about this, which in spite of the title, also applies to BW: Problems with Ctrl, Alt, Cmd, Shift and other modifiers in games http://kb.parallels.com/en/7072

    I hope this helps someone. Please let me know, if it works for you.
    At first glance, this seems to work perfectly! Thanks for sharing the tip. Have you seen any snags that have been caused by this modification?

    Donald Cobb
    Aix-en-Provence, France

  3. #3
    Join Date
    Apr 2004
    Posts
    20

    Default

    Quote Originally Posted by Donald Cobb View Post
    At first glance, this seems to work perfectly! Thanks for sharing the tip. Have you seen any snags that have been caused by this modification?

    Donald Cobb
    Aix-en-Provence, France
    I tried it and it works great!
    Brian Tipton
    Teacher
    North Oaks Church of Christ
    Valencia, California

  4. #4
    Join Date
    Nov 2012
    Posts
    4

    Default

    Quote Originally Posted by Donald Cobb View Post
    At first glance, this seems to work perfectly! Thanks for sharing the tip. Have you seen any snags that have been caused by this modification?
    Using BW in Parallels (Windows 7 or XP guest OS) works fine with this modified setting. I have not seen any side-effects on other programs either, but I don't use a whole lot of Windows applications any more.

    Parallels doesn't actually explain very well what this setting does. The user guide states regarding enabling Optimize modifier keys for games: "Option (Alt), Ctrl, Shift,... signals from these keys will be processed faster." But really without enabling this option the Shift key doesn't get processed at all in BW as well as other programs like CorelDraw. Thus I think even some other applications in your VM might benefit from the change.

  5. #5

    Default

    This is brilliant. Thanks.
    Ben

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •