Results 1 to 8 of 8

Thread: Settings for local languages

Hybrid View

  1. #1
    Join Date
    Apr 2012
    Posts
    123

    Default Settings for local languages

    Hello all,

    I have been trying to resolve a problem that many of you would probably never be confronted with, but I'll give it a shot anyway!

    When exporting French Bible versions from BW9 into a Word document in French, with French set as the default language in Word, the Bible verses are imported as English language text; i.e., the spell checker sees them as English words and applies the English check to them. Of course, this doesn't work: practically every word is underlined as misspelt.

    Obviously, I can highlight the text in my Word document, then go into "language" and change it manually to French. That's what I've been doing up to now. But it requires 3-4 additional steps and when I'm preparing a course with frequent Scripture quotations (as I'm doing right now), it quickly becomes laborious...

    So my question is this: is there any setting in Bible works that would allow me to export French text as French text?

    I imagine anyone working with other languages would have the same problem I do. Have others run up against this? If nothing exists at present that would allow different languages to be exported for what they are, would it be possible to add this feature in a subsequent version of BW (or, better, as a patch in BW9)? (Question for the folks at BW!)

    Any help or insights would be much appreciated. Thanks!

    Blessings,

    Don Cobb
    Aix-en-Provence, France

  2. #2
    Join Date
    Apr 2004
    Posts
    181

    Default Language settings

    You could do something similar to programming the function keys in this thread:

    http://www.bibleworks.com/forums/sho...simulatneously

  3. #3
    Join Date
    Apr 2012
    Posts
    123

    Default

    Quote Originally Posted by Greg Ward View Post
    You could do something similar to programming the function keys in this thread:

    http://www.bibleworks.com/forums/sho...simulatneously
    Thanks Greg for pointing me to this. I suppose setting up a macro in Word could be a solution. If there is any way of changing the output text already at the BW level, that would be simpler, though. I'm still open to other suggestions, although if there is nothing else, I will definitely give the macro solution a try!

    Blessings,

    Donald Cobb
    Aix-en-Provence, France

  4. #4
    Join Date
    Sep 2007
    Posts
    1,206

    Default

    Hey Donald,

    I have experienced the issue that you are now experiencing. It is not a BibleWorks problem. It is a Microsoft Office 2010 issue. I cannot remember exactly how I did it; it took a little time and patience. But there is a setting(s) in Word that you need to tinker with to ensure that the right spellchecker and language are active. I eventually got it working. To reiterate, it is a setting in Word that you need to adjust, not BibleWorks.

    Irving

  5. #5
    Join Date
    Apr 2012
    Posts
    123

    Default

    Quote Originally Posted by ISalzman View Post
    Hey Donald,

    I have experienced the issue that you are now experiencing. It is not a BibleWorks problem. It is a Microsoft Office 2010 issue. I cannot remember exactly how I did it; it took a little time and patience. But there is a setting(s) in Word that you need to tinker with to ensure that the right spellchecker and language are active. I eventually got it working. To reiterate, it is a setting in Word that you need to adjust, not BibleWorks.

    Irving
    Thanks Irving. It's nice to know that at least I'm not alone on this one! I'll see what I can do by looking through all the obscure hidden corners and arcane menus of Word.

    A couple things, though. First, I already had this problem when working with Word 97, so the problem isn't new. I'm now working on Word 2011, so if it is a problem with Word, it's one that has been recurrent for some time. Second, interestingly, I don't have the same problem when importing text from sites like this one (this is a link to the French Bible Society)--Word reads it as French in my French language document:

    http://lire.la-bible.net/

    I'll see what I can come up with and, if others have been encountering the same problem and are looking for a solution, I can certainly pass along any information that might be useful.

    Blessings,

    Donald

  6. #6
    Join Date
    Sep 2007
    Posts
    1,206

    Default

    Hey Donald,

    Sorry for all the troubles you've been experiencing. Your experience is a little baffling. I hope there is an easy solution to this. It could just be a setting in MS Word (which was my experience).

    By the way, I clicked on your link to the French Bible Society. I love the way La Bible en franšais courant reads. There is a real simple beauty to it, in my opinion. So I guess the passe simple is still used even in Francais courant, huh?

    Irving

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •