Results 1 to 4 of 4

Thread: BibleWorks and Wine - Keyboard Problem

  1. #1
    Join Date
    Dec 2008
    Posts
    8

    Default BibleWorks and Wine - Keyboard Problem

    Hi,

    I have BibleWorks 7.0.020d installed on WINE in Ubuntu 10.04. When I start BibleWorks, I get the message "The following Keyboard Layout Could not be loaded: English (United States) (00000409). You need to add support for this language. Click on Help for more information."

    How can I tell WINE (or BibleWorks) the right setting?

    Greetings,

    Joker

  2. #2
    Join Date
    Mar 2009
    Posts
    16

    Default

    Same problem with the BW 8, under Linux Mint KDE 12. Does anybody know the solution yet?

    Dmitry
    Last edited by dmivapi; 02-08-2012 at 09:48 AM.

  3. #3
    Join Date
    Mar 2009
    Posts
    16

    Default

    Add the following regedit file to wine's registry (it worked for me)
    (can be done like this: wine regedit.exe 1.reg)

    REGEDIT4

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Keyboard Layouts\00000409]
    "Layout File"="KBDUS.DLL"
    "Layout Text"="American"
    "Layout Display Name"="@%SystemRoot%\\system32\\input.dll,-5000"

    [HKEY_CURRENT_USER\Keyboard Layout\Preload]
    "1"="00000409"

  4. #4

    Default

    Quote Originally Posted by dmivapi View Post
    Add the following regedit file to wine's registry (it worked for me)...
    @dmivapi - thanks for this! It worked for me too.

    FWIW - I'm running BWks 7 under Wine 1.4 with Linux Mint 12 LXDE. It's the happiest I've ever seen BWks in Linux. Menu bars display, searches are lightning fast, etc. Marvellous! (For some odd reason, my previous distro, Lubuntu, didn't work at all well on this front. Odd!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •