Results 1 to 9 of 9

Thread: Squiggly lines in Microsoft Word?

  1. #1

    Default Squiggly lines in Microsoft Word?

    I am not sure if anyone else has had this problem, but whenever I post any kind of Biblical language into Word, I get those squiggly lines telling me it is spelled wrong or the grammar is incorrect.

    I know how to turn off the lines. But I don't want to do that, because I want them to show up when I am typing eny English documents.

    Does anyone know how to set it so that the lines don't show up just for Heb/Greek/etc?

    Thanks for the help!

    Eric

  2. #2

    Question Squiggly lines in MS Word

    I feel your pain!
    This happened every time I typed "OT" for Old Testament, so I put OT in the dictionary. So now when I accidentally type "ot" instead of "to," it doesn't show up! I would lvoe to have my "ot"s automatically corrected, but I still want to be able to type "OT!"

    And I have the problem you described, too, of course.

    David McKay
    http://members.ozemail.com.au/~musicke

  3. #3

    Lightbulb Auto spell checking in Word for Greek & Hebrew

    Quote Originally Posted by ericjdaniels
    Does anyone know how to set it so that the lines don't show up just for Heb/Greek/etc?
    Hi, Eric,

    Yes, there is a way.
    In BW
    1. Compile a word list of all the words in the WTT. Using the Word List Manager, be sure to include vowel points & accent marks (if you export accented Hebrew). Don't include morphology.
    2. In Word (I'm using 2000) go to Tools | Options | Spelling & Grammar tab and click the dictionaries button.
    3. In the Custom Dictionaries dialog, click the New... button to create a new dictionary.
    4. Entitle it Hebrew.dic. Click OK.
    5. Now choose/highlight your newly created Hebrew.dic and click the Edit... button. This will open the dictionary as a Word document.
    6. Return to BW's Word List Manager: under Select, choose Select All
    7. Under Edit, choose Copy selected words to clipboard
    8. Return to Word Hebrew.dic file and paste all WTT word forms into the file.
    9. Do a search a replace to get rid of all the stat numbers. I export English in Times New Roman font, so I would do a search and replace for any ^# in Times New Roman -- this will avoid deleting any Hebrew characters associated with a number (though I don't remember there being any).
    10. Then save the file. When Word says the file contains features that are not compatible with Text Only format, ignore and save anyway.

    Viola! Word should now regard every form in the WTT as a legitimately spelled word.

    Hope that points you in the right direction. Same idea for Greek.dic.
    Last edited by Philip Brown; 09-25-2004 at 10:19 PM.

  4. #4

    Default Figured it out! Hebrew need not be flagged as spelling error in Word

    Hi, Eric,

    Here's what you do:
    1. Follow all the steps given previously until you get to #10. By this point you will have stripped out all the frequency numbers.
    2. I'm assuming that the Hebrew is still in the Hebrew font face. If it isn't, change it back to Bwhebb.
    3. When you save Hebrew.dic, do NOT save it as a Text Only file. Save it as a Word document. However, there is a trick here. When you change the File type to Word document, Word will automatically add a ".doc" extension to the file name, UNLESS you place the file name in quotes.
    4. On the File name line, the name should read "Hebrew.dic" (quotes included).
    5. Save File.

    Hebrew is no longer being spell checked! Thanks for the challenge, this has bugged me for a long time.

  5. #5

    Default

    Quote Originally Posted by Gontroppo
    I feel your pain!
    This happened every time I typed "OT" for Old Testament, so I put OT in the dictionary. So now when I accidentally type "ot" instead of "to," it doesn't show up! I would lvoe to have my "ot"s automatically corrected, but I still want to be able to type "OT!"
    Hi David

    I wrote a little macro to correct "ot" when I want "to". I have a shortcut key "Cntrl-Shift-O" which runs it every time I need it. Here it is, just open up your Word Macro editor and paste this in at the bottom:

    Sub FixOT()
    '
    ' FixOT Macro
    ' Macro recorded 1/1/99 by Donald C S Johnson
    '
    Selection.MoveLeft Unit:=wdWord, Count:=1
    Selection.MoveRight Unit:=wdCharacter, Count:=1, Extend:=wdExtend
    Selection.Cut
    Selection.MoveRight Unit:=wdCharacter, Count:=1
    Selection.Paste
    Selection.MoveRight Unit:=wdCharacter, Count:=1
    End Sub

    Just be sure to run this macro with the cursor immediately after the "ot" or "ot " ("ot" with a space following).

    Hope that helps
    Maranatha!
    Don Johnson
    Pastor
    aaaaaGrace Baptist Church of Victoria
    aaaaaVictoria, BC
    Jeremiah 33.3 Call unto me, and I will answer thee, and shew thee great and mighty things, which thou knowest not.

  6. #6

    Question ot to to macro

    G'day Don
    I haven't done this before, and I don't understand how to "open up the word macro editor and paste this at the bottom"

    I tried this:
    Go to
    Tools/Macro/Macros
    and I get a list of Macros, but can't figure out how to add a new one.

    I also tried
    Tools/Macro/Record new macro

    Later, I think I stumbled on getting the routine into the bottom of the file, but it doesn't seem to be working.

    How do I assign the control shift O as a command?

    Thanks for your help.
    David McKay
    http://members.ozemail.com.au/~musicke

  7. #7

    Default Opening Word's macro editor

    Hi, Dave,

    In Word, press Alt + F11.
    In the screen that opens, go to the bottom, and paste the text Don posted earlier.

  8. #8
    Join Date
    Apr 2004
    Posts
    29

    Default

    Quote Originally Posted by Philip Brown
    9. Do a search a replace to get rid of all the stat numbers. I export English in Times New Roman font, so I would do a search and replace for any ^# in Times New Roman -- this will avoid deleting any Hebrew characters associated with a number (though I don't remember there being any).
    Betraying my stupidity with Word here, but I can't figure out a way to do this that doesn't also destroy all the hard returns! I use Word 2003, but I'm sure it's the same in 2000 or 2002. Can you help me out with the wildcards, etc.? Thanks!

    Clay Johnson

  9. #9

    Post Removing stats numbers from exported word list

    Hi, Clay,

    In Word:
    1. Edit | Replace
    2. In the Find what box: type ^#
    3. If the search options are not showing click the More button
    4. Click the format button and choose Font
    5. Type/choose Times New Roman (or whatever font the English was exported from BibleWorks in) and click OK (don't specify any thing else)
    6. Leave the Replace with box empty
    7. Click the replace all button.
    That should do it, unless I'm misunderstanding your question.
    Last edited by Philip Brown; 11-20-2004 at 03:36 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •