Results 1 to 9 of 9

Thread: Search Field + Hebrew Problem Windows 7

Hybrid View

  1. #1
    Join Date
    Jan 2010
    Posts
    3

    Default Search Field + Hebrew Problem Windows 7

    I couldn't open new thread other in FAQ . so i opened it here.

    Hello , I have Windoes 7 64 bit + BibleWorks 7
    I have hebrew keyboard , and dont have hebrew problem in other programs/web.

    - The Problem: I see wierd letters when trying to search something in hebrew on WTT .

    - I can Serach in english ( in KJV ) without any problem.

    - I write/see hebrew normal in the Editor.

    - Tried playing with fonts and etc.

    - Reinstall many times + playing with trouble shooting options .

    - No problem in programs/web = System Locale = Hebrew(Israel) = In the picture I'v add to this post - you can see that when pressing enter on the search field - the pop up window that says that the word is not found - shows the text ok as hebrew .

    - I didnt find the option
    "Tools|Options|Option Flags|Command Line Configuration Options|Use Israeli keyboard on command line"
    which I found somewhere on the fourum here.

    http://img341.imageshack.us/img341/442/67554462.jpg

    thanks for the help
    Last edited by BreakingBad; 01-06-2010 at 02:01 PM.

  2. #2
    Join Date
    Nov 2007
    Posts
    473

    Default

    I suggest you take a look at these treads:

    Searching and Typing in Hebrew
    http://www.bibleworks.com/forums/sho...raeli+keyboard


    Typing Hebrew in the Search w/ Vista and BW8
    http://www.bibleworks.com/forums/sho...raeli+keyboard
    Brian K. Mitchell
    חפשו בתורה היטב ואל תסתמכו על דברי
    http://www.adfontes.mitchellbk.com/


  3. #3
    Join Date
    Jan 2010
    Posts
    3

    Default

    didn't help.

    I have a temporary sulotion , using the GUI Hebrew Keyboard , which means , typing a dot "." then to clicks on the word that i want from the GUI Hebrew Keyboard .

    * It's not the standrand hebrew keyboard keys , its a mass.
    * It's anooying.

    If there was a way to just change the Hebrew Keyboard , this temporary sulution would be perfect.


  4. #4
    Join Date
    Nov 2007
    Posts
    473

    Default

    Quote Originally Posted by BreakingBad View Post
    didn't help.

    I have a temporary sulotion , using the GUI Hebrew Keyboard , which means , typing a dot "." then to clicks on the word that i want from the GUI Hebrew Keyboard.
    Please Keep in mind that

    By default the command line keyboard changes to match the current search version. Also, the Hebrew/Greek keyboards used by Bibleworks are mapped the the standard US English key board. So, becareful about changing the keyboards because not every keyboard has all the functions or characters that BW uses.

    Here is how I think you can do it:

    In older versions of Bibleworks

    1. Click open Keyboard Layout Dialog
    2. Select "Automatically"
    3. Chose the XXX Language (not the XXX language Layout)
    4. exit
    5. select WTT as you search version


    In BibleWorks 8

    1. Select Options
    2. Click open Flags
    3. Under Flags Click Command Line Configuration Options
    4. Check off the use Israeli Keyboard on the command line.

    If none of this works then I highly recommend you contact customer service directly: http://www.bibleworks.com/support.html

    POST SCRIPT:

    Bibleworks uses it's own internal Boolean search commands and wild-card commands. AND one, of these operators must be used at the beginning of any search in any language conducted on the command line.

    . = an And search

    / = an OR search


    ' = a phrase search

    ; = a Linear Phrase Search

    ( ) = a Compound search

    SO, that "dot" is not a temporary function if you want to search for two independent words.
    Brian K. Mitchell
    חפשו בתורה היטב ואל תסתמכו על דברי
    http://www.adfontes.mitchellbk.com/


  5. #5
    Join Date
    Jan 2010
    Posts
    3

    Default

    * Didn't work
    * If you read , I said using version 7.
    * I was hoping to get answer from customer service here

    I changed the serach font to hebrew , and now i can type in hebrew , but when i'm trying to write ' , i'm getting 3/4 then than the serach does nothing

    Well , using the jew's bible without checking out the israeli's keyboard first? Program Design Fail

  6. #6

    Default Customer support

    Quote Originally Posted by BreakingBad View Post
    I was hoping to get answer from customer service here
    This isn't BW customer service, it's a BW users forum. To contact customer service, go to their website for support, where you can find FAQ section, with your query at service@bibleworks.com

    Dale A. Brueggemann

    כִּי עֶזְרָא הֵכִין לְבָבוֹ לִדְרוֹשׁ אֶת־תּוֹרַת יְהוָה וְלַעֲשֹׂת וּלְלַמֵּד בְּיִשְׂרָאֵל חֹק וּמִשְׁפָּט (Ezra 7:10)


  7. #7
    Join Date
    Nov 2007
    Posts
    473

    Default

    Quote Originally Posted by BreakingBad View Post
    Well , using the jew's bible without checking out the israeli's keyboard first? Program Design Fail
    It's called the תַּנַ"ךְ TANAKH or the מקרא MIKRA. And, not every Jew is an Israeli ! Also, not every Israeli is a Jew. By the way BibleWorks has two different databases to search on the טעמי המקרא this makes it pretty much irreplaceable at the moment.
    משה משה הנחה את העם ראה אני כל-כך עיף ורוצה לישן עוד אני עודן נער

    Quote Originally Posted by BreakingBad View Post
    * Didn't work
    * If you read , I said using version 7.

    אני מצטער מאוד
    BUT, I thought I also left instructions for older versions of Bibleworks.
    I'll keep looking for a way around this though.
    Till, then look at the post before this one then give Customer Service a call directly or send them an E-mail And don't give up or lose heart.


    מחצים האנשים אוהבים מחציתם שונאים והיכן מקומי בין המחציות המתאמות כל-כך
    Last edited by bkMitchell; 01-08-2010 at 08:24 PM.
    Brian K. Mitchell
    חפשו בתורה היטב ואל תסתמכו על דברי
    http://www.adfontes.mitchellbk.com/


  8. #8

    Default

    Hebrew in the command line is horribly broken on most windows platforms i.e. vista, Windows 7, etc...

    However, you can work around the problem for basic searches by setting the caps lock on before you type, then after typing a ".", "/", "'" you will be able to type Hebrew characters; however, many of the advanced searches are impossible to type from the command line because the symbols like '@" can not be placed correctly on the command line because the cursor jumps to the left of the text entered i.e. it doesn't correctly handle the right to left typing with the special characters.

    I have reported these problems to bibleworks many times over the last year now and so far they have remained unaddressed. I love the program and use it nearly every day, but this bug is well documented and extremely frustrating and it is a little disappointing that more effort has not been made to resolve it.





    Quote Originally Posted by BreakingBad View Post
    I couldn't open new thread other in FAQ . so i opened it here.

    Hello , I have Windoes 7 64 bit + BibleWorks 7
    I have hebrew keyboard , and dont have hebrew problem in other programs/web.

    - The Problem: I see wierd letters when trying to search something in hebrew on WTT .

    - I can Serach in english ( in KJV ) without any problem.

    - I write/see hebrew normal in the Editor.

    - Tried playing with fonts and etc.

    - Reinstall many times + playing with trouble shooting options .

    - No problem in programs/web = System Locale = Hebrew(Israel) = In the picture I'v add to this post - you can see that when pressing enter on the search field - the pop up window that says that the word is not found - shows the text ok as hebrew .

    - I didnt find the option
    "Tools|Options|Option Flags|Command Line Configuration Options|Use Israeli keyboard on command line"
    which I found somewhere on the fourum here.

    http://img341.imageshack.us/img341/442/67554462.jpg

    thanks for the help

  9. #9
    Join Date
    Feb 2010
    Posts
    1

    Default Cannot get the patah to work in Search command line

    So everything is great trying to type Hebrew on the command line EXCEPT the patah, which doesn't work either from the keyboard ";" or in the GUI keyboard. I just get ";" instead. The other vowel points work but not patah.

    Any ideas out there

    Grace and peace

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •