Results 1 to 6 of 6

Thread: Hebrew text copied to clipboard and pasted into Word is always right-adjusted

  1. #1
    Join Date
    Apr 2004
    Posts
    5

    Default Hebrew text copied to clipboard and pasted into Word is always right-adjusted

    It seems as if hebrew text copied to the clipboard and pasted into Word is always right-adjusted. Is this so? I've been toggling export options, font options, hebrew options and can't get left-adjusted pasting to work in Word like I could with BW7.
    Any hope for me?

  2. #2
    Join Date
    Apr 2004
    Posts
    2,081

    Default

    Quote Originally Posted by wergeland View Post
    It seems as if hebrew text copied to the clipboard and pasted into Word is always right-adjusted. Is this so? I've been toggling export options, font options, hebrew options and can't get left-adjusted pasting to work in Word like I could with BW7.
    Any hope for me?
    One potential problem with BW8 is there are more ways than ever to export text. That's actually a good thing (I think), but it makes troubleshooting a bit more problematic. Can you give more information about how you're exporting (i.e. what settings you're using, the method of copying, etc.)? It's really hard to troubleshoot just this part, but if people know more, we might be able to solve the problem.
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  3. #3
    Join Date
    Sep 2007
    Posts
    166

    Default

    Hi,

    I discovered by trial and error that if you copy and paste any element(s) within a line but excluding everything from the verse reference part, the paste is left justified as in a normal English text. If the highlighted portion for copy crosses the line boundary, then the paste will be right justified.

    If someone can explain why it works that way, then we will be on a firm ground.

    Regards,
    Yaku Lee
    Last edited by Yaku Lee; 03-31-2009 at 04:56 AM. Reason: typographic.

  4. #4

    Default

    I copy text over using the select-and-drag method. I'm set up to do so with the SBL-Hebrew font (as export font, I think), and that seems to avoid the problem.
    Ben

  5. #5
    Join Date
    Apr 2004
    Posts
    5

    Default

    Thanks for the replies so far. None of them help, though.

    I'm so used to typing/editing hebrew text from left to right that I turn off Unicode exporting. To do that, I have to uncheck the boxes at the bottom of the Options | General | Fonts screen and the "Export Unicode Hebrew" box on the Options | Output Format Options | Selected Browse Text screen.

    The funny thing is that when I export in Unicode, the text pastes in left-justified. When I export in Bwhebb, it pastes in right-justified.

    service@bibleworks.com suggested I try checking the "Filter RTF Export for maximum compatibility" at Options | General | Flags | Export Options. Doesn't help.

    I've tried all the combinations of the CRLF choices under Export Options. I've tried unchecking "Export formatting to clipboard and editor".

    When I check "Export Refrence String when Exporting Browse text.", the text is left-justified. Maybe just because text with latin letters is automatically left-justified? But I don't want the reference string! I tried "tricking" BW by choosing neither "Place reference before text" nor "Place reference after text". I even deleted everything in the "Reference Format" box.

    Any more ideas?

  6. #6
    Join Date
    Apr 2004
    Posts
    5

    Default

    It doesn't matter either how I copy (CTRL-C CTRL-V, right click & copy to clipboard, right click & copy to Word, drag and drop).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •