Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: How to prevent auto change of search version?

  1. #11

    Default

    Quote Originally Posted by DavidR View Post
    And it just keeps getting better. As of today's update to v. 8.0.008j.1, when I do a right-click "search on lemma" in multi-version mode with an English-language version designated as search version, the search is done in the ancient-lenguage morphology version, and once the results are displayed the search version goes back to the English version. Perfect! (At least I think so!)

    David Rensberger
    I don't get this. I am on version 8.0.008n.1 and when I do this the search version is always changed on me to Greek/Hebrew (as the case may be). I have to go back and manually change it every time. It's frustrating enough that I have taken to using a separate tab for searches, otherwise it is very clunky to use.

    In fact, I am find that the only real way to get back to my English search version is to perform another search in English this time. Very frustrating.
    Last edited by FredGreco; 04-11-2009 at 12:11 PM.
    Fred Greco
    Senior Pastor, Christ Church PCA (Katy, TX)
    Christ Church Blog

    "The heart is the main thing in true religion...It is the hinge and turning-point in the condition of man's soul. If the heart is alive to God and quickened by the Spirit, the man is a living Christian. If the heart is dead and has not the Spirit, the man is dead before God." (J.C. Ryle)

  2. #12
    Join Date
    Mar 2009
    Posts
    382

    Default

    I haven't updated to 008n, and maybe I won't! It's definitely working in 008j. Perhaps when fixing something else in 008n, they broke this again?
    David Rensberger
    Atlanta, Georgia

  3. #13
    Join Date
    Apr 2004
    Posts
    211

    Default n .1 works fine here

    I tried this with version 008n.1 and worked fine. Of course if your first hit is in a deutero-canonical and the English version does not have the book. Oops, you get just the Greek text displayed. But the search version remains English, just the results list shows the original language you did the lemma search upon. Fred I don't know what you should do next; maybe you should send a link to this thread and a copy of your ini file to support folk. Your problem seems resistant to the fix they have implemented.
    SkipB

    "Ambitious to be well-pleasing unto him"
    RJ Blackburn
    Reformed Episcopal Seminary

    http://www.reseminary.edu



  4. #14
    Join Date
    Mar 2009
    Posts
    382

    Default

    I've got it working with version 008o.1. Fred, have you checked your option settings (Tools - Options - Flags - Browse Window Configuration Options)? I have "Automatically make morphology versions display versions" unchecked, and "Maintain search version after lemma search" checked. In fact, let me just attach a screenshot of my Browse Window settings. I hope that will help.
    Attached Images Attached Images  
    David Rensberger
    Atlanta, Georgia

  5. #15

    Default

    David,

    I have the same settings. Here is something weird: it works fine for Hebrew lemma searches, but not for Greek. So is I search in John 1:2 on "arche" it makes GNT the search version, and does not come back to English. But if I search in Hebrew on "elohim" (for example) it keeps the English version as the search version.

    Is there some setting relating solely to Greek?
    Fred Greco
    Senior Pastor, Christ Church PCA (Katy, TX)
    Christ Church Blog

    "The heart is the main thing in true religion...It is the hinge and turning-point in the condition of man's soul. If the heart is alive to God and quickened by the Spirit, the man is a living Christian. If the heart is dead and has not the Spirit, the man is dead before God." (J.C. Ryle)

  6. #16
    Join Date
    Mar 2009
    Posts
    382

    Default

    Hmmm. I assume you're right-clicking on a word in GNT and selecting "Search on Lemma." When I do this, it switches very briefly to GNT, then to GNM to do the search, then back to NRS (the English version I was using). I really can't explain why it's not working for you. I would just check and be very sure you've got an English version selected as your search version before starting the process. I find that it's very easy to accidentally select the wrong search version at the beginning. Beyond that, I'm stumped.
    David Rensberger
    Atlanta, Georgia

  7. #17

    Default

    OK.

    I think I have at least figured out what the problem is, and I wonder if anyone else can reproduce it. Here is what I found:

    1. View an OT text in multi-version mode (several English and WTT). Set search version to NAU (for example).

    2. Set the flag for "Enable Secondary Browse Windows" (see attachment)

    3. Right click on a Hebrew word and "Search on Lemma."

    4. The Secondary window should pop up. When you close it, the search version should be NAU.

    5. Now go to Matthew 1:1. Do the same thing, on a GREEK word in GNT or BGT.

    6. The Secondary window will pop up, and when you close it, the search version stays on the Greek version (BGT/GNT) instead of going back to NAU.

    If you turn off automatic Secondary Browse Windows, this behavior (#6) does not happen. The search version reverts back to NAU. If you manually open a second browse window, this behavior (#6) does not happen. The search version reverts back to NAU.

    Now here is the interesting part - I appear to be getting the right behavior (search version reverting back to what it should) for Hebrew, but not for Greek. So searching on an LXX lemma also changes the search version to Greek on me.

    Can anyone else reproduce this behavior? Looks an awful lot like a bug.
    Attached Images Attached Images  
    Fred Greco
    Senior Pastor, Christ Church PCA (Katy, TX)
    Christ Church Blog

    "The heart is the main thing in true religion...It is the hinge and turning-point in the condition of man's soul. If the heart is alive to God and quickened by the Spirit, the man is a living Christian. If the heart is dead and has not the Spirit, the man is dead before God." (J.C. Ryle)

  8. #18
    Join Date
    Mar 2009
    Posts
    382

    Default

    Fred,

    This is good (I know it doesn't feel good!), you've narrowed it down to the precise problem area. When I turn on the automatic Secondary Browse Windows, I get the same behavior -- with one difference: the problem occurs consistently in OT passages searching the Septuagint, but does not always occur in NT passages, even though it's searching the same database (BGT). Sometimes things run smoothly in NT searches; sometimes they go haywire, though in a different way: the secondary browse window does not sync up when I click on different passages in the results list. When that happens, then the search version remains stuck at BGM, not reverting back to NRS (the English version I started with). I do not get this behavior in OT passages.

    I think you've got this narrowed down enough to make a bug report of it at http://www.bibleworks.com/support.html. That way it will get to the programmers, who really do need to take a look at it.
    David Rensberger
    Atlanta, Georgia

  9. #19
    Join Date
    Mar 2009
    Posts
    382

    Default

    Fred,

    BTW, I knew nothing about automatic Secondary Browse Windows. Thanks for pointing them out; even if they're working a little hinky, it's a great tool!

    Every day I realize that there is so much great stuff about this program that I have yet to learn about!
    David Rensberger
    Atlanta, Georgia

  10. #20
    Join Date
    Mar 2004
    Posts
    839

    Default

    Quote Originally Posted by DavidR View Post
    I haven't updated to 008n, and maybe I won't! It's definitely working in 008j. Perhaps when fixing something else in 008n, they broke this again?
    Such a pessimist. Let's be a little more upbeat now
    If you guys want real time fixes ya gotta live with occasional back steps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •