Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Typing Hebrew in the Search w/ Vista and BW8

  1. #11

    Default Keyboard layout.

    I had not found that button on the top bar yet, but I had found the same keyboard diagram through the menus. When I type I do not get the characters shown on that keyboard; however, when I click the keys on the displayed keyboard with my mouse characters the correct characters are displayed in the search box. One more interesting thing I found as I was trying to post an example in this message. When I copied the text typed in the in the search box and pasted it here in this message I got the correct Greek letter i.e. 'ασδφ' for the keys 'asdf'; however, when I used the graphics keyboard and clicked 'asdf' the correct letters were displayed in the search window, but when those letters are copied and pasted here I simply get 'asdf'

    Note: In the Keyboard configuration for Greek I have chosen the 'Greek (Greece) (00000408)' keyboard. And the keys are laid out significantly different from the Greek displayed on the graphics keyboard.

  2. #12
    Join Date
    Apr 2004
    Posts
    2,096

    Default

    Quote Originally Posted by benelchi View Post
    I had not found that button on the top bar yet, but I had found the same keyboard diagram through the menus. When I type I do not get the characters shown on that keyboard; however, when I click the keys on the displayed keyboard with my mouse characters the correct characters are displayed in the search box. One more interesting thing I found as I was trying to post an example in this message. When I copied the text typed in the in the search box and pasted it here in this message I got the correct Greek letter i.e. 'ασδφ' for the keys 'asdf'; however, when I used the graphics keyboard and clicked 'asdf' the correct letters were displayed in the search window, but when those letters are copied and pasted here I simply get 'asdf'

    Note: In the Keyboard configuration for Greek I have chosen the 'Greek (Greece) (00000408)' keyboard. And the keys are laid out significantly different from the Greek displayed on the graphics keyboard.
    Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).

    Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.
    Michael Hanel
    PhD candidate Classics Univ. of Cincinnati
    MDiv Concordia Seminary
    MA Classics Washington University
    Unofficial BibleWorks Blog
    LibraryThing!

  3. #13

    Default

    Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).
    Actually, that is not what happens. When I am in the command line and type 'asdf' I get just some Greek accents, but if I select the accents that were typed in the command line, copy them, and then past them into any other program (like word or this forums page) I get 'ασδφ'; however, when I use the graphics keyboard and press the same keys (with mouse clicks) I get the correct 'ασδφ' in the command line window, but when I copy the correct Greek text from the command line and paste it into MS word I get 'asdf' (i.e. a bug)

    Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.
    The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected. Even when typing in the Bibleworks 8.0 editor screen on the right, the Greek and Hebrew keyboards function exactly like they should. (no bugs) The problem only exibits itself in the Bibleworks command line.

  4. #14

    Default

    Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).
    Actually, that is not what happens. When I am in the command line and type 'asdf' I get just some Greek accents, but if I select the accents that were typed in the command line, copy them, and then past them into any other program (like word or this forums page) I get 'ασδφ'; however, when I use the graphics keyboard and press the same keys (with mouse clicks) I get the correct 'ασδφ' in the command line window, but when I copy the correct Greek text from the command line and paste it into MS word I get 'asdf' (i.e. a bug)

    Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.
    The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected, and even when I am typing in the Bibleworks 8.0 editor screen on the right the Greek and Hebrew keyboards function exactly like they should (no bugs). The problem only exhibits itself in the Bibleworks command line.

  5. #15
    Join Date
    Apr 2004
    Posts
    2,030

    Default

    Quote Originally Posted by benelchi View Post
    The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected, and even when I am typing in the Bibleworks 8.0 editor screen on the right the Greek and Hebrew keyboards function exactly like they should (no bugs). The problem only exhibits itself in the Bibleworks command line.
    You should NOT have your keyboard set to Greek when you type in the Command Line in BibleWorks. Your keyboard should be set to English keyboard for both Greek and Hebrew. That is your problem.

  6. #16

    Default Hebrew and Gree in Vista

    The difficulty with using just the English keyboards is that Bibleworks uses a non-standard Keyboard layout. For those of us who use the Greek and Hebrew in other programs (like Microsoft word) it is very frustrating to not be able to use the same Keyboard layout in Bible works.

    Note: even in the Bibleworks editor screen the Greek and Hebrew Keyboards work correctly. There must be someway to get them to function correctly in the command line.


    Additional note: Bibleworks, automatically chooses the Hebrew or Greek Keyboard when I position the cursor in the command line (even when automatic langauge selection is turned off) I haven't tried setting the Greek and Hebrew keyboards to English in the Keyboard selections, but I have tried setting the option to always use English for Greek and Hebrew and that didn't work.

  7. #17
    Join Date
    Apr 2004
    Posts
    2,030

    Default

    Quote Originally Posted by benelchi View Post
    I haven't tried setting the Greek and Hebrew keyboards to English in the Keyboard selections, but I have tried setting the option to always use English for Greek and Hebrew and that didn't work.
    I'm talking about the Windows keyboard. I have a number of keyboards set through Windows so that all I have to do is use my mouse to select English, German, Greek, Hebrew, etc. When typing on the CL in BW, I have the Windows keyboard set to English, for that is how it works, and that is how it is supposed to work. As for allowing it to work with other keyboards, that is an issue that you must take to BW directly.

    In the meantime, if you want your CL searches to work properly, you need to have your Windows keyboard set to English.

  8. #18

    Default Windows Keyboard

    My default windows keyboard is set for English, but I do notice that bibleworks does change that setting automatically when the cursor is in the search box and the search versions is Hebrew or Greek. On Vista there is a keyboard language indicator on the lower right part of the screen and I can watch that change between EN (English), EL (Greek), HE (Hebrew) as I move the mouse cursor around on the Bible works Screen. In other programs (like MS word) I am required to change that setting manually when I want to switch between langauges. I can try setting the keyboards for Greek and Hebrew to English in the bibleworks config screen; however, I suspect doing so will change the Keyboard mapping.

  9. #19
    Join Date
    Apr 2004
    Posts
    2,030

    Default

    Quote Originally Posted by benelchi View Post
    My default windows keyboard is set for English, but I do notice that bibleworks does change that setting automatically when the cursor is in the search box and the search versions is Hebrew or Greek. On Vista there is a keyboard language indicator on the lower right part of the screen and I can watch that change between EN (English), EL (Greek), HE (Hebrew) as I move the mouse cursor around on the Bible works Screen. In other programs (like MS word) I am required to change that setting manually when I want to switch between langauges. I can try setting the keyboards for Greek and Hebrew to English in the bibleworks config screen; however, I suspect doing so will change the Keyboard mapping.
    I would just stick with what works instead of aiming for some sort of symmetry, as there is nether world of permutations in Windows from system to system and program to program.

    Like Vista, XP also has an indicator for the keyboard in use, and in addition to the mouse, you can very swiftly move from keyboard to keyboard with Alt+Shift

  10. #20
    Join Date
    Mar 2009
    Posts
    2

    Default

    yes, I have the same problem with Hebrew/Israeli keyboard. Must switch to caps lock to get any Hebrew text in the search box.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •