Results 1 to 9 of 9

Thread: Metheg issues

  1. #1
    Join Date
    May 2004
    Posts
    307

    Default Metheg issues

    It seems there are some issues with the metheg accent in both the WTT and WTM.

    Take the first word of 1 Kgs 21:29 as an example: הראית. The full parsing given in the WTM is as follows:

    הֲ@Pg+SxxxExHxNxZ8Rx
    ראה@vqp2ms+SxxxxJxCxAxExHxNxZqRx

    As can be seen, the word carries two accents: metheg and zaqef qatan. Thus in the printed version of BHS, the word looks like this:



    However, in the WTT in BW, the metheg is missing. Furthermore, a unicode cut-and-paste into Word does not have the metheg either and consequently an error is introduced into the document unless a double-check is made of the printed BHS or one is following the accent coding of the WTM. However, hovering over the word is not good enough either as it seems the full coding in the WTM isn't retrieved since hovering only retrieves the following:

    הֲ particle interrogative ראה verb qal perfect 2nd person masculine singular accent:Zaqep Parvum

    Nevertheless, the proper coding does exist as a CCAT export of the word reveals: H:A35_RF)I80YTF. The problem is BW is not handling the accent correctly, neither in display or cut-and-paste.

    Regards,
    David Kummerow.

  2. #2

    Default BW font issues?

    If the meteg really exists (sorry, but I do not understand the CCAT Morph parsing code, David cited above), then it's seems plausible that the issue is with the BWHebb font.
    As I've read once in the documentation of SBL fonts they tried to deal exactly with that level of 'little' things like the example above (they give the same case of meteg inside the hattaf-patah, but in some word in the Book of Job).
    The SBL font is free and I'd suggest that BW developers could give it a try...
    Guller Yuri
    MA Student, Bible Studies Dep.
    Hebrew University, Jerusalem
    gullerya@gmail.com

    The less time I have left, the more I appreciate it...
    (No, its neither a quotation nor a claim for 'revelation', nothing more then a simple self-expression).

  3. #3

    Default 1 Kgs 21:29

    For what it's worth, the biblical textbase included with Nota Bene looks the same, indicating that the problem is with the database. It looks like this:

    tfy)irFhj

    Dale A. Brueggemann

    כִּי עֶזְרָא הֵכִין לְבָבוֹ לִדְרוֹשׁ אֶת־תּוֹרַת יְהוָה וְלַעֲשֹׂת וּלְלַמֵּד בְּיִשְׂרָאֵל חֹק וּמִשְׁפָּט (Ezra 7:10)


  4. #4
    Join Date
    May 2004
    Posts
    307

    Default

    The problem is not with the WTT database itself as an export exports both the accents on the word: H:A35_RF)I80YTF. Neither is the problem with the WTT database either as the word is properly tagged with both accents:

    הֲ@Pg+SxxxExHxNxZ8Rx
    ראה@vqp2ms+SxxxxJxCxAxExHxNxZqRx

    The problem is at the level of software and/or font. BW is not properly displaying both in terms of the bowse window in regards to the WTT and in the Word Analysis window when hovering on the WTT and WTM.

    A unicode cut-and-paste should in my opinion be accurate and retrieve and convert on the level of the database. However, unicode cut-and-paste converts at the level of display. Consequently, if there is an error in the display of the WTT because of the font or whatever, that same error is introduced to the document.

    Regards,
    David Kummerow.

  5. #5

    Default

    Accordance, using as I know the same database, does display the Meteg properly...
    Definitely, font or rendering code issue.
    Guller Yuri
    MA Student, Bible Studies Dep.
    Hebrew University, Jerusalem
    gullerya@gmail.com

    The less time I have left, the more I appreciate it...
    (No, its neither a quotation nor a claim for 'revelation', nothing more then a simple self-expression).

  6. #6
    Join Date
    Mar 2004
    Posts
    839

    Default Metheg problem

    David,

    A fix for this issue has been posted. Your program should be 7.019g.9 after the update. If you find any other additional issues it is usually quicker to contact tech support. They visit the forum occasionally but not as often as they read e-mails. Hope this takes care of it for you.

    You may need to activate the medial metheg setting in the Setup | Flags | Hebrew accents section. It is likely off in your INI file.

    God bless,
    Mike

  7. #7
    Join Date
    May 2004
    Posts
    307

    Default

    Hi Mike,

    Thanks again for the fix! Metheg is now displaying and being copied when copying-and-pasting. There is a little inconsistency with fonts which you may be able to explain:




    As can be seen, the metheg in question from Lev 21:10 is on the 'asher. All examples have been pasted into Word. As can be seen, the BW font and the SBL Hebrew font both position the metheg to the left of the vowel, whereas Ezra SIL positions it correctly in the middle of the vowel, thus matching the printed BHS. But, oddly, the unicode display of the Westminster text rendered in SBL Hebrew on this site positions the accent correctly in the middle of the vowel: http://www.tanach.us/Tanach.xml#Lev21:10-21:10. A copy-and-paste from the site into Word retains the correct positioning of the accent with SBL Hebrew.

    Regards,
    David.
    Last edited by David Kummerow; 05-28-2008 at 10:56 PM.

  8. #8
    Join Date
    May 2004
    Posts
    307

    Default

    This issue of incorrect placement of metheg after a unicode export into Word may be repaired by running the following macro in Word:

    Code:
    Sub metheg_correct()
    '
    ' metheg_correct Macro
    '
    ' hatef-segol
        Selection.Find.ClearFormatting
        Selection.Find.Replacement.ClearFormatting
        With Selection.Find
            .Text = ChrW(1457) & ChrW(1469)
            .Replacement.Text = ChrW(1457) & ChrW(8205) & ChrW(1469)
            .Forward = True
            .Wrap = wdFindContinue
            .Format = False
            .MatchCase = False
            .MatchWholeWord = False
            .MatchWildcards = False
            .MatchSoundsLike = False
            .MatchAllWordForms = False
        End With
        Selection.Find.Execute Replace:=wdReplaceAll
    '
    ' hatef-pathah
        Selection.Find.ClearFormatting
        Selection.Find.Replacement.ClearFormatting
        With Selection.Find
            .Text = ChrW(1458) & ChrW(1469)
            .Replacement.Text = ChrW(1458) & ChrW(8205) & ChrW(1469)
            .Forward = True
            .Wrap = wdFindContinue
            .Format = False
            .MatchCase = False
            .MatchWholeWord = False
            .MatchWildcards = False
            .MatchSoundsLike = False
            .MatchAllWordForms = False
        End With
        Selection.Find.Execute Replace:=wdReplaceAll
    '
    ' hatef-qamets
        Selection.Find.ClearFormatting
        Selection.Find.Replacement.ClearFormatting
        With Selection.Find
            .Text = ChrW(1459) & ChrW(1469)
            .Replacement.Text = ChrW(1459) & ChrW(8205) & ChrW(1469)
            .Forward = True
            .Wrap = wdFindContinue
            .Format = False
            .MatchCase = False
            .MatchWholeWord = False
            .MatchWildcards = False
            .MatchSoundsLike = False
            .MatchAllWordForms = False
        End With
        Selection.Find.Execute Replace:=wdReplaceAll
    End Sub
    Regards,
    David.
    Last edited by David Kummerow; 06-05-2008 at 02:47 AM.

  9. #9
    Join Date
    May 2004
    Posts
    307

    Default

    I've edited the macro above to also correct metheg placement with hatef-segol and hatef-qamets.

    Regards,
    David.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •