Results 1 to 5 of 5

Thread: Lemma Agreement Operator Broken in BNM and GNM Searches?

  1. #1

    Default Lemma Agreement Operator Broken in BNM and GNM Searches?

    Until yesterday, I'd not used the lemma agreement operator (#) in command line searches for quite some time, but, on my PC at least, it seems no longer to work when searching the BNM and GNM databases, but appears to function correctly with other morphological databases.

    Before I contact BW support, would someone be kind enough to confirm the following results for the simple string search: <'#1 #1>

    BNM - 0 matches
    GNM - 1 match (1Co 12:12 - which isn't a lemma match!)

    Running this search on the BGM with search limits set to the NT produces 333 verses with one or more matches. I would have expected this result with the BNM search. Am I missing something here?

    I'm using BW7 with the latest patches.

    Thanks for any help.

    John
    --
    John Kendall
    Cardiff
    Wales

  2. #2

    Default Same results

    Hi, John,
    I get exactly the same results as you do...

    One would certainly think that the BNM and the BGM limited to NT should produce the same results.
    Mark G. Vitalis Hoffman
    Professor of Biblical Studies
    Lutheran Theological Seminary at Gettysburg
    ltsg.edu - CrossMarks.com
    Biblical Studies and Technological Tools

  3. #3
    Join Date
    Apr 2004
    Posts
    539

    Default

    Hi John,

    I found a problem with the GNM, though the BNM & BGM work fine on my system. I don't know what the problem may be. We'll have to look into it, but I can't say how soon we will be able to do so.

    You can, however, use the GSE to run the search. The fastest way to construct the GSE search is to type the .#1 #1 on the Command Line, then press F9 to open the GSE. The search will be created for you. Then run the search! I get 329 hits in the GNM, and 333 for both the BNM and BGM w/NT search limits set.

    Glenn

  4. #4
    Join Date
    Apr 2004
    Posts
    539

    Default Match lists set?

    Hi John,

    I just heard back about the lemma agreement problem. On my system (and I bet on yours, too) I had the Compound Word Forms search options set for the Command Line. Unchecking the 'Use Match Lists' button fixed the problem, and now my GNM searches work.

    To access the Compound Word Forms settings, place your cursor on the Command Line and right-click your mouse. On the context menu select 'Define Compound Word Forms.' Uncheck the box that says 'Use Match Lists', and your search should work.

    Glenn

  5. #5

    Default Thanks!

    That's solved it! Thanks yet again, Glen. My bafflement was caused by the remnants of some long-forgotten searches.

    John
    --
    John Kendall
    Cardiff
    Wales

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •