PDA

View Full Version : Briefly: repeating Database activation notice



Dan Phillips
12-30-2013, 10:44 AM
On my PC, each time I open BW9 I get the message that two db's are not activated. I go to the db listing, and all show as activated. I use the activate all by internet option and, of course, nothing happens. Then next time I open, I get the same message. This has gone on for weeks.

Any ideers?

Dan Phillips
01-01-2014, 11:32 AM
Hm; not a widespread issue, I'm guessing.

Jim Wert
01-01-2014, 05:02 PM
It hasn't shown up for me, but I'm wondering if unchecking

Main Menu
Tools
Options
General
Flags
Startup Options
Check for Locked Databases on Startup

might make the symptom go away.

Of course, this would do nothing about the underlying cause.

If you want to try some free-lance repair, I'd suggest the following:
When I get unexpected behaviour from BW, my first response is to exit BW, then restart with shift key held down, then under Option 1 select "Rebuild Version Data", and "Perform the selected options and run Bibleworks". This seems to do enough reinitialization to clean up many problems, without destroying any of my settings.
If that doesn't help I restore an earlier checkpointed Initialization file (assuming that you have the Shutdown Option to "Save checkpoint on exit" set on). If you can go back to an ini file before the annoying behaviour began it may clean it up for you, while losing only the settings you changed since that time. For this start BW with shift key held down, but use Option 3, "Restore Previous Version (restore checkpoint)", uncheck "Executable" and "Context file", and select the most recent checkpoint whose date is before the annoying behaviour.

Dan Phillips
01-03-2014, 11:01 AM
Thank you, Jim!