PDA

View Full Version : Targum variant colors



DavidR
03-10-2012, 06:45 PM
This is a bit esoteric. When viewing a Targum version (TAR), variant manuscript readings should be marked with a superscript numeral and optionally color coded, if this is selected in Tools | Viewing the Text | Choose Targum Variant Colors. I've had this working before, and that menu selection does show colors selected for the first 4 variants, with Show Colors checked (see Targum Variants dialog screenshot attached). These colors do appear when viewing the TAM morphological Targum file, but not in TAR itself. The other screenshot shows Gen. 15:11: in TAR, וַאֲתֵיב should be colored red and וְאַפרַח should be colored pink, as in TAM. Note that there are also no superscript numerals in the TAR display. Is there some other switch I need to set somewhere, or is this an issue in the program?

DavidR
03-13-2012, 04:08 PM
I should have mentioned that this is in BW v. 9.

Mark Eddy
03-13-2012, 07:43 PM
I get color in both TAR and TAM. So I don't know what your problem might be.
Mar Eddy

DavidR
03-13-2012, 09:36 PM
Are you also using BW 9? Because I know this was working in 8, and I don't believe I changed any settings that could affect it when I upgraded.

By the way, in Options : Browse Window Configuration Options, I do have both Enable Browse Window colors for text and Enable Browse Window colors for morphology text checked.

MGVH
03-14-2012, 12:03 AM
hmmm... I don't think it was working before, but I just updated to 9.0.008n.1, and it is behaving properly.
In default, variants show up in gray and with superscripts.
Turning on the Targum variants color now works too.

DavidR
03-14-2012, 11:29 AM
Well, I just updated from 9.0.008m.1 to 9.0.008n.1. Still no luck. There must be a setting turned off somewhere, but I can't find it.

Mark Eddy
03-15-2012, 12:16 AM
Are you also using BW 9? Because I know this was working in 8, and I don't believe I changed any settings that could affect it when I upgraded..
Yes, I am using BW9. But I have chosen a color for all 9 of the choices. You have only the first 4. Perhaps that makes a difference.


By the way, in Options : Browse Window Configuration Options, I do have both Enable Browse Window colors for text and Enable Browse Window colors for morphology text checked.
It is also possible that there is competetion between a combination of other Browse Window Configuration Options which you have chosen differently from what I have chosen. But from what you wrote, I have tried the same configuration.
Mark Eddy

DavidR
03-15-2012, 10:42 AM
Yes, I am using BW9. But I have chosen a color for all 9 of the choices. You have only the first 4. Perhaps that makes a difference.

Good suggestion. However, I tried it (even restarted BW after selecting the rest of the 9 colors), and still nothing.


It is also possible that there is competetion between a combination of other Browse Window Configuration Options which you have chosen differently from what I have chosen. But from what you wrote, I have tried the same configuration.
Mark Eddy

Very possible, but I've looked everywhere I can think of. It sounds like no one else is experiencing this, so at this point I'm just hoping that I will make some other random configuration choice some day that mysteriously makes it start working again. :confused:

DavidR
03-15-2012, 11:06 AM
Another question regarding this: Does anyone know in what file the color settings for Targum variants are stored? I looked in bw900.ini and found a setting for "vartcolors" that has 9 entries, and I suspect that that's it. But is there some other setting in bw900.ini that would trigger the actual use of these colors?

I thought of using BW9's installation disk to remove TAR from my installation and then reinstall it; but it seems to be part of the default installation, and as such there seems to be no way to remove it. I even located the various TAR files in C:\Program Files (x86)\BibleWorks 9\databases\ and thought about deleting them and then reinstalling from the installation disk. But that sounded a little too drastic to undertake without, shall we say, adult supervision. :)

Any other suggestions gladly welcomed!

brainout
03-27-2012, 09:00 AM
This is a bit esoteric. When viewing a Targum version (TAR), variant manuscript readings should be marked with a superscript numeral and optionally color coded, if this is selected in Tools | Viewing the Text | Choose Targum Variant Colors. I've had this working before, and that menu selection does show colors selected for the first 4 variants, with Show Colors checked (see Targum Variants dialog screenshot attached). These colors do appear when viewing the TAM morphological Targum file, but not in TAR itself. The other screenshot shows Gen. 15:11: in TAR, וַאֲתֵיב should be colored red and וְאַפרַח should be colored pink, as in TAM. Note that there are also no superscript numerals in the TAR display. Is there some other switch I need to set somewhere, or is this an issue in the program?

I had that problem in BW8; turns out that if you have set Internet Explorer to ignore colors in the Accessibility Tab, then BW can't recognize color, either. Check your IE settings. If that's not the problem, I'm not sure how to help. You can contact me at Youtube, 'brainouty', and I'll try to help.

BTW: I'm just a user, not a part of BibleWorks staff. But I wouldn't want to live without BibleWorks. I try to tell everyone I know, to buy it.

DavidR
03-27-2012, 11:27 AM
Interesting, and a little surprising. I don't use IE as my usual browser, but I do use it occasionally. I did check it just now, and I don't have colors turned off there, so that's not it either. Thanks for the suggestion, though.

brainout
03-27-2012, 12:24 PM
Interesting, and a little surprising. I don't use IE as my usual browser, but I do use it occasionally. I did check it just now, and I don't have colors turned off there, so that's not it either. Thanks for the suggestion, though.

This intrigues me. Will try to reproduce the problem, though still using BW8. In my case no color of either TAM or TAR showed up, until I changed the IE settings, which a BW staff member kindly helped me to figure out. BW uses IE because the underlying reading mechanism is like a .chm file (which annoys me to no end), so whatever settings affect .chm files, affect the Targums.

Will report back if I find anything useful.

DavidR
03-30-2012, 05:56 PM
Noting that the information on the latest update, v. 9.0.008w.1, said something about Targum variant formatting, I downloaded it (after avoiding it until the reported rebuild-loop error was fixed). I just checked, and I'm delighted to say that Targum variants are now displaying in my chosen colors. Thanks, Mike B.! All good now! :D