PDA

View Full Version : Unwanted switch to US keyboard layout



jgwalker
06-01-2010, 05:18 AM
Having used BibleWorks for around eight months now it has become invaluable. However there is a relatively small issue that I find very annoying.

It keeps on switching my keyboard layout from UK to US.

This seems to be associated with use of some of the lexicons, but it has happened on occasion without any such access. I find it difficult to determine exactly what sequence of actions makes the change since I don't usually notice until I try to enter a quotation (") and get the @ symbol instead (these symbols are in opposite locations on US and UK keyboards).

Is this a known issue? Is there any way to stop it? Are there any plans to fix it?

Adelphos
06-01-2010, 08:51 AM
BibleWorks attempts to teach as you use it. Thus, in an effort to break the bad habits of British English and educate Brits and Aussies and others into the correct American English, BibleWorks automatically changes the keyboard back to the correct American keyboard whenever it sees fit. :cool:

arggem
06-01-2010, 09:28 AM
Hi jgwalker! and welcome to the BibleWorks forum!

Are you changing the keyboard layout by going to Tools/Interface settings/keyboard layouts? (Also accessible by double clicking the layout option on the status bar at the bottom of the screen). Check out the help file if you aren't sure what each option does.

I think this set of options over-rides any keyboard changes you might make through your operation system (e.g. language bar in Win XP).

Check back and let us know if that helps.

jgwalker
06-01-2010, 11:50 AM
The keyboard layouts are set as follows:
Language: English
Keyboard layouts: English (United Kingdom) (00000809)
Change Command Line Keyboard Layout: Automatically
Default Keyboard layout: English (United Kingdom) (00000809)
Always use English

file:///C:/DOCUME%7E1/Gordon/LOCALS%7E1/Temp/moz-screenshot.png727

From what I can make of the Help this should be correct. I am definitely not using this dialog to make any changes, the keyboard layout is altered by normal use of Bibleworks (searches, note-making, lexicon access etc) without ever entering any configuration dialog.

The change is system wide. In other words it is the operating system keyboard that is altered, it is wrong in all applications and must be reset through the OS.

Oh yes, Adelphos. Sorry about your problems with English but really you Americans ought to be more careful. When you borrowed the language in the first place you broke it and ended up getting some really quite simple words wrong. Then after 400 years of that you make it clear you haven't learned anything at all by letting IBM design a keyboard that's broken. Admittedly we've made a few mistakes, Humphry Davies called it aluminum originally but the rest of us have sorted that out now. We're just waiting for you lot.

bkMitchell
06-01-2010, 08:08 PM
jgwalker,

Try un-selecting(un-checking) the box
"always use English keyboard Layout for Greek and Hebrew"

I am guessing "English Keyboard layout", doesn't mean English as in (United Kingdom 00000809), but rather English as in (USA 00000409). There are at least 16 different English keyboard layouts and it is doubtful that the "English Keyboard layout" refers to them all. So, it would appear that BW is automatically switching you from the UK keyboard layout to the USA one.

Although, an American; I use a Japanese OS as well as Japanese Keyboard, and at first I had same problem. I thought, that English Keyboard Layout meant any key board with Latin characters, but I was mistaken. The Japanese Keyboard has the Latin alphabet in basically the same locations as on the USA-IBM one. However, punctuation marks and other marks tend be in different places and that caused a lot of trouble for me when trying to use the command line. But, after I unselected "English Keyboard layout", all of those problems vanished.

David Kummerow
06-01-2010, 08:13 PM
I've had the same problem for years: http://www.bibleworks.com/forums/showthread.php?1953

Even though I'm "used to it" by now, I still find it very annoying.

Regards,
David.

jgwalker
06-02-2010, 08:14 AM
Brian

You say, "I am guessing "English Keyboard layout", doesn't mean English as in (United Kingdom 00000809), but rather English as in (USA 00000409)"

I have to say if that's the case it seems to me to be a bug that needs attention since I have explicitly selected "English (United Kingdom) (00000809)" for use with English language texts and also as the default keyboard layout.

The help file is (to me) quite opaque on this point but in re-reading it yet again I may have made a breakthrough. It says, "The bottom List Box associates a particular keyboard layout with each language". In other words, for each language the second combo box associates a particular keyboard to it.

When "English" is selected at the top the "Keyboard Layout" reads "English (United Kingdom) (00000809)".
However when I selected "Greek" in the top list box I found the "Keyboard Layout" was set to "English (USA 00000409)". I changed it to "English (United Kingdom) (00000809)"
Similarly I then selected "Hebrew" in the top list box and changed the "Keyboard Layout" to "English (United Kingdom) (00000809)"

I will watch this for a day or so and report back if it solves the problem. In the mean time, David, you may want to give it a go.

wie
06-03-2010, 02:45 AM
I've had the same problem for years:
Me, too.

But over the last several months or so, the problem is gone.
Perhaps they were able to fix it? Hope, hope ...
My setting is this:

728

jgwalker
06-08-2010, 05:56 PM
No, that hasn't fixed it entirely. I'm still getting unwanted shifts to the US keyboard layout while using Bibleworks. I haven't got any other ideas.

Any thoughts?