PDA

View Full Version : Keybord layout is changing



wie
08-12-2009, 02:38 AM
I already had this problem in BW7.
I use a German keyboard, but at some point, I don't know why, it is changing back to English.
I already tried all thinkable combinations of settings in the Keyboard Layout Settings, but to no awail. Sometimes the keyboard is reversing to English on its own.

Mark Eddy
08-13-2009, 12:51 AM
When you change the search version in BibleWorks to a different language, your keyboard will change to that language (if you have enabled that keyboard in Windows). Hebrew and Greek versions use the English keyboard by default. I do not know if you can change this. But if you want your German keyboard to be active, I think that you can just click on a German version and make it the search version in BibleWorks, and you should get your German keyboard back. At least that is what I do if my keyboard changes away from English. I just make an English (or Greek or Hebrew) version my search version, and I get my English keyboard back.
If this does not help, someone else may have a better answer.
Mark Eddy

wie
08-13-2009, 02:32 AM
I set all version to German, like this:

http://img205.imageshack.us/img205/3186/keyboardzsa.jpg

Still, this does not help.
At some point, I don't know when and why, it changes back to English.
This is annoying.
Is it not possible to fix the keyboard once and for all?

wie
08-14-2009, 04:15 AM
Just started BW this morning and again the keyboard has reverted itself to English.

:mad:

J Kendall
08-14-2009, 11:12 AM
Wieland,

In the past I've had problems with the keyboard reverting from my desired UK English to US English. I may be mistaken, but I seem to recall fixing this in earlier versions of BibleWorks by editing the ini file so that the defaultkblayout value was set to the UK keyboard code (00000809) and the KeyBoardIDs value had the UK keyboard code first in the list. Perhaps you might check your bw800.ini file to see if the German keyboard code is found at the correct points?

I've not had this problem with BW8. (In the settings box shown in your earlier post I have the "Manually" and the "Always use English keyboard layout ..." options selected.)

By the way, did you sort out the issue discussed here (http://www.bibleworks.com/forums/showthread.php?t=4017)?

John
--
John Kendall
Cardiff
Wales

wie
08-14-2009, 12:54 PM
Thanks Ken,
I tried what you suggested, but it doesn't work.
I changed the keyboard numbers by hand, but when I restarted BW, they returned back to the old list.

Isn't it possible to say BW once and for all which keyboard I am using?
Hello programmers?



Wieland,By the way, did you sort out the issue discussed here (http://www.bibleworks.com/forums/showthread.php?t=4017)?
No, there appears to be no such function in BW.

J Kendall
08-15-2009, 06:30 AM
Thanks Ken,
I tried what you suggested, but it doesn't work.
I changed the keyboard numbers by hand, but when I restarted BW, they returned back to the old list.

Isn't it possible to say BW once and for all which keyboard I am using?
Hello programmers?

No, there appears to be no such function in BW.

Did you miss the final post? I felt fairly sure that it dealt with the issue you raised. The list can be sorted alphabetically or by frequency as you require. See the attached image.

John
--
John Kendall
Cardiff
Wales

David Kummerow
08-16-2009, 07:54 PM
I've had a similar problem for years: http://bibleworks.com/forums/showthread.php?t=1953

Regards,
David.