PDA

View Full Version : Help with copying Syriac into MS Word 2007



jarnett0001
07-20-2009, 04:29 PM
Hey everybody, I need some help. I am writing an article and I need the Greek and the Syriac texts of Acts 22:16 in MS Word 2007. The Greek works fine, but the Syriac does something weird. When ever I make the font the size I want, the whole verse won't fit on one line, and instead of dropping the last part of the verse under the first part of the verse, it drops the beginning of the verse under the last part of the verse (but it does it on the right side of the paper as I have it in right to left mode). Any suggestions? Any help would be much appreciated.

ISalzman
07-21-2009, 12:28 PM
Hey everybody, I need some help. I am writing an article and I need the Greek and the Syriac texts of Acts 22:16 in MS Word 2007. The Greek works fine, but the Syriac does something weird. When ever I make the font the size I want, the whole verse won't fit on one line, and instead of dropping the last part of the verse under the first part of the verse, it drops the beginning of the verse under the last part of the verse (but it does it on the right side of the paper as I have it in right to left mode). Any suggestions? Any help would be much appreciated.

How are you copying the Syriac text? Have you tried selecting it in the Browse Window, then hitting CTRL + C, and then pasting into MS Word?

jarnett0001
07-22-2009, 03:46 AM
Yeah, just tried it and it does the same thing. I think it has something to do with the text mapping, but I have no clue how to fix it. Thanks for trying to help though!

Muhammad
07-22-2009, 04:24 AM
There are some questions you should perhaps ask yourself:
1. Do you have a Syriac font installed in your system?
2. Have you set your copying options to unicode?
3. Remember: Syriac is a Semitic script that runs from right to left. You may have to do some settings in your control panel to allow for non-Latin scripts to be displayed correctly.

I have a special software called GLOBAL WRITER that enables me to use and write over 300 scripts including non-Latin ones. There, I encountered a similar problem described in your post above. It was in the case of Hebrew I was typing. The solution was to keep the Hebrew passage as a separate paragraph from the rest of the text in Biblical Greek and English.

If you are having proper font display problems, one solution would perhaps be to create a PDF from the Syriac passage and then to convert it into an image file to be integrated into MS WORD 2003/2007. It is a work-around, but I need to make use of this as I am regularly working with many different kinds of non-Latin scripts (Chinese, Japanese, Korean, Arabic).

Please also make sure that you have the Windows support enabled for complex scriptts in your Regional Language settings of Windows (System Control Panel).

Good luck!

MBushell
07-22-2009, 12:40 PM
Hey everybody, I need some help. I am writing an article and I need the Greek and the Syriac texts of Acts 22:16 in MS Word 2007. The Greek works fine, but the Syriac does something weird. When ever I make the font the size I want, the whole verse won't fit on one line, and instead of dropping the last part of the verse under the first part of the verse, it drops the beginning of the verse under the last part of the verse (but it does it on the right side of the paper as I have it in right to left mode). Any suggestions? Any help would be much appreciated.

I added a Hebrew width setting option to the "Selected Browse Text" Setup Window. This should for non-Unicode. You'll have to create a new copy favorite with Hebrew Unicode turned off and use it for Syriac copies. And you'll have to set the Hebrew width seting to something appropriate. Eventually we will add a Unicode font to handle this and all this won't be necessary, but there are a lot of issues involved.
Mike