PDA

View Full Version : Verse reference Export full book names



Roger Horning
02-07-2009, 04:00 PM
I am using version 8.

When I export verse I would like them to appear like this:
Philippians 1:6 For I am confident of this very thing, that He who began a good work in you will perfect it until the day of Christ Jesus.

Not like this:
Phi 1:6 For I am confident of this very thing, that He who began a good work in you will perfect it until the day of Christ Jesus.

Can anyone help me figure out how to make this change?
I could do it with version 7 but I can't figure it out in 8. I am sure I am missing something really obvious. Thanks in advance for your help.

J Kendall
02-07-2009, 05:02 PM
I think this will do it. Go to Tools > Options > Output Format Options. Under (1) Verse List or Range and (2) Selected Browse Text uncheck Use User Defined Book Names.

John
--
John Kendall
Cardiff
Wales

Roger Horning
02-07-2009, 05:14 PM
Thank you very much for the reply. I followed those steps, shutdown and restarted and nothing changed.

When you export, do you get full book names?

Roger

J Kendall
02-07-2009, 05:30 PM
Hi Roger,


Thank you very much for the reply. I followed those steps, shutdown and restarted and nothing changed.

When you export, do you get full book names?

Yes, and I can change it at will without a restart.

I suspect your problem may depend on where you're exporting from. Try right clicking in the Search Window, select Copy Format Options and work through each set of options. Somewhere among them you'll have Use User Defined Book Names checked where you want it unchecked.

John

Roger Horning
02-07-2009, 06:43 PM
Well, I went through and changed every single option to no evail.

When I toggle the user defined book names the export goes from "1 Tim. 5:10" (user defined checked) to "1Ti 5:10" (user defined unchecked).

I could go through and modify the book name export field for each book however, I am guessing that there must be some other way to do it. Especially since it is working for you and you didn't rename all the books in your "book names" file.

Any way, thanks for your help. I guess I will just keep messing with things unitl I find something out.

J Kendall
02-07-2009, 07:45 PM
One more possibility ... Try Tools > Options > Flags > Browse Window Configuration Options and check Display Full Book Names in Browse Window.

I find that if I uncheck this, I get the results you describe.

John

Roger Horning
02-07-2009, 08:21 PM
I tried that as well. For me it makes no difference either way to my exported text.

Thanks for helping me with this. Maybe one of the BW support team will know what's going on. I am also going to read throught the help file more carefully and see if I can find something I missed.

If I ever figure out what is going on I will post it. :)

gesnipes
10-30-2013, 01:22 PM
I tried that as well. For me it makes no difference either way to my exported text.

Thanks for helping me with this. Maybe one of the BW support team will know what's going on. I am also going to read throught the help file more carefully and see if I can find something I missed.

If I ever figure out what is going on I will post it. :)

I know this is an old thread, but someone may still need the resolution. I tried every solution offered here without success. I finally found something that worked. I edited the books.bna file and replaced every abbreviated book name with the full one. For example, the file lists the following:
Gen, Genesis, Gen., Gen, Genesis, Gn, 1mo

I changed Gen. to Genesis. Then I enabled user defined books. Now when I export, it copies the full book name and not the abbreviated version.

Here is a quick way of editing the file. Since this is just a comma delimited file, I changed books.bna to books.csv and then opened with excel. I copied the full book names to the field with the abbreviated names. If you use this option, don't copy the whole column, since this will over right things at the bottom of the file. Only copy the cells that have the full Bible book names. Save the file, then rename back to books.bna. Then you are done.

Roger Horning
10-30-2013, 01:45 PM
I know this is an old thread, but someone may still need the resolution. I tried every solution offered here without success. I finally found something that worked. I edited the books.bna file and replaced every abbreviated book name with the full one. For example, the file lists the following:
Gen, Genesis, Gen., Gen, Genesis, Gn, 1mo

I changed Gen. to Genesis. Then I enabled user defined books. Now when I export, it copies the full book name and not the abbreviated version.

Here is a quick way of editing the file. Since this is just a comma delimited file, I changed books.bna to books.csv and then opened with excel. I copied the full book names to the field with the abbreviated names. If you use this option, don't copy the whole column, since this will over right things at the bottom of the file. Only copy the cells that have the full Bible book names. Save the file, then rename back to books.bna. Then you are done.

Thanks! Even though it's an old thread, I appreciate the response.