PDA

View Full Version : Hebrew copies backwards



ericjdaniels
01-24-2009, 03:19 PM
I am using BW7.0.020a.1. When I copy and paste Hebrew from the lexicon it will paste into MS Word backwards. I have my fonts set to be exported as unicode.

I was trying to paste bara from Gen. 1:1 and I selected the text in the HALOT analysis window. And when I hit control-c or right-click and select "copy the text to the clipboard" it is copied as arab in MS Word.

I tried to search the forum and couldn't find any help. I feel like this is a new problem for me. I don't have any memory of it being an issue in the past.

Any suggestions? Thanks!!

Yaku Lee
01-25-2009, 07:33 AM
Yes, copy-and-paste behaves rather strangely. In the case of Hebrew, it looks OK with MS Word, but with a Korean word processor or K-word, for instance, it is not OK. When copying a text directly from BW8 to K-word, the word boundary is screwed up. The last consonant of every word moves over to the next word. When copying from BW8 to MS Word and then from MS Word to K-word, all the character sequence is completely reversed! With a lexical item from the analysis window, it is essentially the same thing. Only it does not have the word boundary problem since it deals with a single item.



In the case of Greek, it looks OK with MS Word, again. But with K-word, it doesnít copy anything at all. If copied from BW8 to MS Word, and then from MS Word to K-word, it copies all right but the font is not nice.



None of these things happened before with BW7 when I did not bother with Unicode. Now it seems obvious that something is not right with BW8 (Unicode), or is it so complicated with BW8 that itís very hard to sort it out.



Sorry I offer you no help. I am only confirming your problem in a way.

greekgeek
01-25-2009, 08:03 PM
I've been struggling with copying issues too.

I had your problem the other day and wasted a lot of time trying to figure it out and searching the forums for help. It finally worked for me when I turned off the unicode copy options. But I had to uncheck it EVERY place it is mentioned. Once I turned it off I was able to copy correctly and not in reverse.

I don't know what causes the problem but I do have an older version of Word (97) which may have something to do with it, at least for me.

Hopefully that solution will work for you too.


Right now a related problem I have is that for some reason I can't use the SBL Hebrew font in Word. And everytime I change something related to fonts in the option dialog it does not "stick" and I have to go back and change it again and again and again. Very frustrating.

Michael Hanel
01-25-2009, 11:10 PM
I don't know what causes the problem but I do have an older version of Word (97) which may have something to do with it, at least for me.

Hopefully that solution will work for you too.


Right now a related problem I have is that for some reason I can't use the SBL Hebrew font in Word. And everytime I change something related to fonts in the option dialog it does not "stick" and I have to go back and change it again and again and again. Very frustrating.

You may have to talk to tech support on this, but esp when it comes to Hebrew, I want to say that Word 97 will not properly work with the right-to-left. I know in general Word versions get better at handling this (although Word for Mac still is unable to properly handle Hebrew). So I'm going to guess that your problem specifically is more Word 97/Hebrew right-to-left related than it is BibleWorks related.

greekgeek
01-26-2009, 01:20 AM
I do think that it is bc of the old version of Word - after all it's 12 years old!
But what confuses me is that I have the macro from BW6 on my Word - which allows me to type Hebrew right to left. And when I was fighting to get it to copy correctly I set it to Hebrew mode and it still did not work. Of course my knowledge of how the interal workings of the macro and the copy function work is very limited and they may not have anything to do with the other - so any computer genius who reads this may laugh that at my attempt to work around the problem.

benelchi
01-26-2009, 09:33 AM
I do think that it is bc of the old version of Word - after all it's 12 years old!
But what confuses me is that I have the macro from BW6 on my Word - which allows me to type Hebrew right to left. And when I was fighting to get it to copy correctly I set it to Hebrew mode and it still did not work. Of course my knowledge of how the interal workings of the macro and the copy function work is very limited and they may not have anything to do with the other - so any computer genius who reads this may laugh that at my attempt to work around the problem.

The Newer versions of word do copy correctly from Bibleworks 8.0; however, I have experienced the same problem described by another user. If I copy to other programs directly the text is not copied correctly; however, if I copy first to word and then from word to another program the copy works correctly. The double copy is annoying, but I haven't experienced the loss of font information described by the user above.

The biggest problems I have been having with multi-langauge support in BW 8.0 is trying to type in the search box. In Hebrew, you must have the caps lock on to type using an Israeli keyboard, and then sometimes BW inserts a daggesh/mapiq(hey) in every letter of the alphabet and then the search will fail because no Hebrew word is pointed like this. The only way I have found to get around this problem is to start another tab and hope BW doesn't get into this mode.

The Greek only seems to work if you select an English keyboard for the Greek Langauge (and use BW Greek keyboard mapping)

Note: in the BW editor window multi-langauge support works correctly, it is only in the search window where it fails.

Adamsen
01-26-2009, 10:05 AM
Note: in the BW editor window multi-langauge support works correctly, it is only in the search window where it fails.

It does not "fail", it is just "not supported", by design.

benelchi
01-26-2009, 07:50 PM
It does not "fail", it is just "not supported", by design.

Bible works has published information on how to use an Israeli keyboard with bible works, and it simply does not work as described. It only sometimes works when the caps lock is enabled (not described in any documentation), and does not work at all when the caps lock is not set.

Additionally the program has a menu option for setting the keyboard for the Greek and Hebrew languages under tools->interface/settings->Bibleworks Keyboards (part of the program "design"); however, if the Hebrew keyboard is chosen for Hebrew it works unpredictably and if the Greek keyboard is chosen for Greek it does not work at all. This is NOT a feature designed into the program, it is a bug.

Adamsen
01-27-2009, 03:17 AM
Bible works has published information on how to use an Israeli keyboard with bible works, and it simply does not work as described. It only sometimes works when the caps lock is enabled (not described in any documentation), and does not work at all when the caps lock is not set.

Additionally the program has a menu option for setting the keyboard for the Greek and Hebrew languages under tools->interface/settings->Bibleworks Keyboards (part of the program "design"); however, if the Hebrew keyboard is chosen for Hebrew it works unpredictably and if the Greek keyboard is chosen for Greek it does not work at all. This is NOT a feature designed into the program, it is a bug.

Sorry if I misunderstood something. But please, do contact Support. They will need details about your OS, keyboard drivers, i.e. the System Info from the BW8's About box.

Support often monitors the Forums, but you cannot rely on that.

Perhaps it is a bug, but it happens that the problem lies elsewhere. E.g., sometimes people have enabled vowel point sensitive searching.

I am sure that Tech Support will happily work with you to get it solved, whatever the cause.

benelchi
01-27-2009, 11:11 AM
I have contacted BW support, and am awaiting for an update on this problem. I know that they have been overwhelmed by this release, and have had a number of people out sick. Even so, they have already fixed some of the bugs I have reported i.e. the program no longer crashes when you try and search for a word form not found in the text you are searching. But the multilangage keyboard problems are still painfully broken.

Yaku Lee
01-28-2009, 05:10 AM
I have MS Word 2007 on Windows XP and BW8. And I have Greek font set to Bwgrkn, Hebrew to Bwhebb, Unicode Greek to Palatino Linotype, and Unicode Hebrew to SBL Hebrew on the Font window in Tools→Options→Font..





With “Export Greek resources … as Unicode,” “Export Hebrew resources … as Unicode,” and “Use these Unicode settings …” on the Font window checked, it works perfectly from BW8 to MS Word 2007, “bara” in Gen 1:1 and everything.. It looks as if BW8 is all geared to MS Word 2007.





When copying from BW8 to a different word processor, e.g. a Korean one, it’s all headaches. However once all “Export Greek resources ...,” “Export Hebrew resources…,” and “Use these Unicode settings…” unchecked, it works “normally” as before with WB7. But it’s unpredictable with MS Word 2007; it works OK with Greek sometimes, although it looks OK with Hebrew.






So it seems that the touted Unicode is causing more headaches than making life easier, at least for the present.

ericjdaniels
01-29-2009, 11:34 AM
Well, this post has definitely made the rounds! Let me try to bring it back to my original question:

I am using BW7.0.020a.1, not BW8. I have MSWord 2003, not 97. MSWord has all the latest patches and such. I update my XP Pro regularly.

My Hebrew does not copy correctly into MS Word 2003. It copies backwards.

Anyone have any suggestions?

ericjdaniels
02-05-2009, 12:04 PM
No suggestions huh. Bummer. I put a call into BW, and haven't heard. I have also been having another problem with the program not maximizing properly.

Hopefully I'll hear back from someone soon. I am sure BW8 presents a lot of increased needs, but I hope us BW7 users have not been forgotten.

Eric

MBushell
02-05-2009, 08:14 PM
Well, this post has definitely made the rounds! Let me try to bring it back to my original question:

I am using BW7.0.020a.1, not BW8. I have MSWord 2003, not 97. MSWord has all the latest patches and such. I update my XP Pro regularly.

My Hebrew does not copy correctly into MS Word 2003. It copies backwards.

Anyone have any suggestions?
Eric,
There are a gazillion questions. Are you copying in the BW font or Unicode. How are you doing the copy (export to clipboard, drag, etc.). Do you have the Right to Left Windows extensions installed? Does the text copy properly to Wordpad or the BibleWorks editor?

Mike

ericjdaniels
02-06-2009, 12:42 PM
Thanks for the response Mike!

My original post answers some of your questions:

I am using BW7.0.020a.1. When I copy and paste Hebrew from the lexicon it will paste into MS Word backwards. I have my fonts set to be exported as unicode.

I was trying to paste bara from Gen. 1:1 and I selected the text in the HALOT analysis window. And when I hit control-c or right-click and select "copy the text to the clipboard" it is copied as arab in MS Word.

With Unicode off: All is well in every sense. When I copy into the BW Editor, everything is fine.

Now that I am working with this problem more, I am more confused. When I paste Lev. 3:3 into MSWord using the copy center with unicode ON, it works fine with SBL Hebrew and Times new Roman for instance. But when I use Arial or Ezra SIL, it is all messed up. Also, the version type, book name, chapter, etc. is always left aligned with unicode on.

--> I also just discovered that with unicode on, when I copy/paste from the lexicon analysis window into MSWord using right click or ctrl-c, it will copy Hebrew words WITH VOWELS fine in any unicode font. But when a triconsonantal root without vowels is copied, it copies backwards with ANY unicode font, including Times New Roman and SBL (so see Lev. 3:3 - the first word triconsonantal root qrb copies fine, last word nominal qereb copies backwards). In this situation when I use the bwhebb font with Unicode OFF, it copies fine. With bwhebb and Unicode ON, it copies a ghost copy that I can't see, even if I change the font color.

I am not familiar with the "right to left windows extension" so I can't really answer that one. But it may be the ticket.

Hope this helps fill out the problem a bit. I hope is was clear. I REALLY appreciate the help!!

Eric

(edit: just updated BW to 7.0.020b.1)

MBushell
02-06-2009, 09:51 PM
Eric,

Can you send me you BW700.ini file (in the BW root dir). And then give me a specific list of steps that you go through from BW sratup to copying the text. Include the word file with the messed up text. With this info I can better assess the situation. Try the same thing with WordPad and send the RTF file to me as well if it misbehaves.

Sorry about the problem. We've come a long ways since the DOS days. NOT.

Mike

ericjdaniels
02-08-2009, 05:05 PM
Thanks again Mike.

I tried using Wordpad, and it works fine. So it seems to be a problem just with MSWord 2003. And I also discovered that it happens with Hebrew words with vowels as well. Once I hit the space bar or enter after the word, it switches to being backwards. You'll see that in the word document.

I attached A Word document with the backwards Hebrew and the text from my ini file. I couldn't attach it because it said it was an invalid file type. I use winrar, not winzip, so I couldn't send it that way either. Let me know if there is another way to do this.

Also, I used the SBL Hebrew font as export font with the Unicode option selected. Here was the process I used:

Open BW. Command line search to Lev. 3:3. Mouse over first Hebrew word which brings up the root in the Analysis Window. Press and hold shift. Move mouse into analysis window. Left click and highlight the Hebrew Qrb. Hit control C, or right-click and select "copy analysis window text to clipboard." Go into MS Word and type control-v.

I used the same process for the second Hebrew Qereb.

For the copied verse I went into the Copy Center, Selected "range of verses", type Lev. 3:3, Typed WTT for the version, And copied the verse to my word document using the "copy to application with this title" option.

I hope I've done well here. I appreciate your help. I tried reloading BW from scratch, and erasing my ini file and it didn't help.

Thanks for the help and for Bibleworks in general. Its a great program I use all week to prepare to preach the Gospel to my city. God is using it for His glory.

Bless you,

Eric

ericjdaniels
02-08-2009, 05:07 PM
Ok, the plot thickens. The Word Doc I sent you with the verse copied, it is now ok when you open it. Weird!? When I copied it, it was all jumbled. When I reopen it, the text is right.

Either way, you can see the Hebrew is backwards on the other parts. But still, that is weird.

MBushell
02-09-2009, 10:48 AM
Hi Eric,

In XP, click on the Start Button and then:
1. Select Settings and Controll Panel
2. Switch to CLassic View
3. Click on the Regional and Language Applet
4. Click on the Languages Tab
5. At the botton check the box titled "Install files for complex and right-to-left languages"
6. After that is done click on "Details" and add the Hebrew keyboard

This may help the behavior of Word for Unicode Hebrew.

Mike

ericjdaniels
02-13-2009, 11:39 AM
That was it Mike! Thanks so much. I can't think of another experience I have had with a software company where I received service like this.

May God bless your desire to serve Him.

Eric

MBushell
02-13-2009, 12:21 PM
That was it Mike! Thanks so much. I can't think of another experience I have had with a software company where I received service like this.

May God bless your desire to serve Him.

Eric
That's a relief! I am glad it works.
Mike