PDA

View Full Version : Typing Hebrew in the Search w/ Vista and BW8



benelchi
01-17-2009, 02:39 PM
I am new to Bibleworks, 8.0 is the first version I have tried. So far I have been unsuccessful at typing Hebrew (and to some extent Greek) in the Search command line. For Hebrew I am trying to use the Israeli Keyboard. In the BW editor the Keyboard works as expected, but in the Search window the characters appear as accented Latin characters.

I have tried searches by typing a period and then typing the equivalent keystrokes for the word I want to search on and every search fails and often BW crashes and has to be restarted. I have even tried simply copying text from the Hebrew bible in BW and pasting the text into the search window and although I do get some Hebrew characters, they are the wrong Hebrew characters and often have a lot of garbage characters mixed in. When I copy unpointed text typed into the editor window and paste it into the search window, I get vowel pointings (that were not in the text) without any of the original Hebrew letters (that were in the text)? Example אהבה when pasted into the search command line becomes a segol and a sheva, but all of the Hebrew letters themselves are lost.

I have tried setting the language option to manual and auto select; in auto the correct langauge is indicated on the vista status bar (bottom right part of the Screen) when the search text is set for Hebrew.

Obviously there are a lot of bugs still yet to be fixed, but I am wondering if anyone has a work around for the time being?

Adelphos
01-17-2009, 03:02 PM
I am new to Bibleworks, 8.0 is the first version I have tried. So far I have been unsuccessful at typing Hebrew (and to some extent Greek) in the Search command line.

I may be wrong, but it sounds to me that you do not have the correct version as your search version.

In the Command Line, first type WTT to make that your active search version. Now type in a period and then type your Hebrew characters. It should work. If not, then something is wrong.

benelchi
01-17-2009, 03:50 PM
The Search version always shows WTT, and when I have the language set to automatic it chooses Hebrew (as indicated by Vista) when the WTT version is selected as the search version. I did try forcing WTT as you suggested, but it didn't make a difference. After the . was entered I still get the accented/tildied latin characters.

One other interesting note. When using the graphical keyboard to enter the Hebrew characters. The first letter after the space follows the key definition displayed on the keyboard (using the mouse to click the key), but the subsequent characters use the Israeli keyboard definition (as set in my language preferences rather that the pictured letters. For example, the first click on a 'hey' produces a 'hey', but the next time a 'hey' is clicked I get a 'yod' (like an Israeli keyboard would produce). The key definitions remain Israeli until I get to another space.

Adelphos
01-17-2009, 04:22 PM
The Search version always shows WTT, and when I have the language set to automatic it chooses Hebrew (as indicated by Vista) when the WTT version is selected as the search version.

The only thing I can suggest is to play with the options, such as turning off automatic language selection, etc., and see if that fixes it. I would also email BibleWorks support and fill them in on your problem. You should probably enclose your ini files in the email so they can take a look at them. You can easily do this by going to About | System Info | Include ini files, then copy to clipboard, save it as text file and include it with your email.

Michael Hanel
01-17-2009, 04:26 PM
So it sounds like your problem has to do with using the Israeli keyboard? I personally haven't ever used that option, so I can't compare notes, but did you do all the necessary steps for setting that up? Right now it sounds like there's a problem with the language setup in Vista compared to what BibleWorks is expecting/using.

benelchi
01-17-2009, 05:29 PM
From what I can tell, I have correctly set all of the language settings, the problem appears to be just S/W bugs. I may try and set the keyboard settings back to non-Israeli settings and just use the graphics keyboard for the time being. Are you using 8.0 and how well is the Hebrew functioning for you with the non-Israeli settings?


Side note: I have been able to pretty consistently crash bible works by searching for Hebrew text (when the search text is not found). Fortunately, I realized I don't need to submit the search because the text turns red when the results will not be found before even hitting the return key.

Philip Brown
01-17-2009, 09:48 PM
With WTT as search version, type a period, then Chet, qamets, mem

If it doesn't show up in Hebrew, try hitting ctrl + page down. This is a toggle that shifts between ascii and Hebrew font display.

benelchi
01-18-2009, 02:51 AM
Initially that didn't seem to work, but after typing the mem I got a mem sophit. And then when I cleared out the text and typed again everything worked!!!

When it did start working, I did notice that the . moved from the '/' key to the '.' key (where it is on an English Keyboard. I was worried that I wasn't going to be able to type a Tsadi sophit, but realized that the normal Tsadi was automatically a sophit when it was on the end of the word. Other than the sophit letters everyting seems to work as expected (and now I can type!)

Thanks.

benelchi
01-18-2009, 08:17 PM
Although I have now got things working for Hebrew (sort of), it is still quite buggy. The key to getting the Hebrew characters to function seems to be having the caps lock enabled. (required on an MS Israeli Keyboard to type a qamats); however, sometimes having the caps lock on causes the insertion of a daggash/mapiq in every letter, and when that happens I have been unable to get the tab to work correctly even when other tabs are working correctly.

Greek doesnt seem to work at all (Caps locks enabled or not). However, unlike the Hebrew problem I always get Greek characters (or accents) but I haven't figured out the KB mapping because it doesn't seem to match either the MS Greek or the BW Greek and like the MS Greek keyboard the order of the keys pressed does make a difference.

Michael Hanel
01-18-2009, 08:40 PM
Greek doesnt seem to work at all (Caps locks enabled or not). However, unlike the Hebrew problem I always get Greek characters (or accents) but I haven't figured out the KB mapping because it doesn't seem to match either the MS Greek or the BW Greek and like the MS Greek keyboard the order of the keys pressed does make a difference.


Where or how doesn't the Greek work? On the button bar, about the sixth button from the right is a little alpha, if you click on that, it shows the default layout for the Greek keyboard in BibleWorks.

benelchi
01-18-2009, 09:01 PM
I had not found that button on the top bar yet, but I had found the same keyboard diagram through the menus. When I type I do not get the characters shown on that keyboard; however, when I click the keys on the displayed keyboard with my mouse characters the correct characters are displayed in the search box. One more interesting thing I found as I was trying to post an example in this message. When I copied the text typed in the in the search box and pasted it here in this message I got the correct Greek letter i.e. 'ασδφ' for the keys 'asdf'; however, when I used the graphics keyboard and clicked 'asdf' the correct letters were displayed in the search window, but when those letters are copied and pasted here I simply get 'asdf'

Note: In the Keyboard configuration for Greek I have chosen the 'Greek (Greece) (00000408)' keyboard. And the keys are laid out significantly different from the Greek displayed on the graphics keyboard.

Michael Hanel
01-18-2009, 11:05 PM
I had not found that button on the top bar yet, but I had found the same keyboard diagram through the menus. When I type I do not get the characters shown on that keyboard; however, when I click the keys on the displayed keyboard with my mouse characters the correct characters are displayed in the search box. One more interesting thing I found as I was trying to post an example in this message. When I copied the text typed in the in the search box and pasted it here in this message I got the correct Greek letter i.e. 'ασδφ' for the keys 'asdf'; however, when I used the graphics keyboard and clicked 'asdf' the correct letters were displayed in the search window, but when those letters are copied and pasted here I simply get 'asdf'

Note: In the Keyboard configuration for Greek I have chosen the 'Greek (Greece) (00000408)' keyboard. And the keys are laid out significantly different from the Greek displayed on the graphics keyboard.

Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).

Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.

benelchi
01-19-2009, 12:35 AM
Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).Actually, that is not what happens. When I am in the command line and type 'asdf' I get just some Greek accents, but if I select the accents that were typed in the command line, copy them, and then past them into any other program (like word or this forums page) I get 'ασδφ'; however, when I use the graphics keyboard and press the same keys (with mouse clicks) I get the correct 'ασδφ' in the command line window, but when I copy the correct Greek text from the command line and paste it into MS word I get 'asdf' (i.e. a bug)


Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected. Even when typing in the Bibleworks 8.0 editor screen on the right, the Greek and Hebrew keyboards function exactly like they should. (no bugs) The problem only exibits itself in the Bibleworks command line.

benelchi
01-19-2009, 12:37 AM
Hmm. So there is a little bit of confusion perhaps on how the Greek works. So for instance, you say when you have a Greek Bible version selected and in the command line type 'asdf it shows up 'ασδφ . That is normal behavior. When you copy that 'ασδφ from the command line to some place else, you get the Latin letters again 'asdf . Now I could be wrong on this, but I believe that is the normal behavior (i.e. not a bug).Actually, that is not what happens. When I am in the command line and type 'asdf' I get just some Greek accents, but if I select the accents that were typed in the command line, copy them, and then past them into any other program (like word or this forums page) I get 'ασδφ'; however, when I use the graphics keyboard and press the same keys (with mouse clicks) I get the correct 'ασδφ' in the command line window, but when I copy the correct Greek text from the command line and paste it into MS word I get 'asdf' (i.e. a bug)


Second. I suppose you would not get the right Greek characters (i.e. the ones shown on the BibleWorks keyboard) if you have selected the Greek keyboard configuration (but I don't know this since I have never toggled with this). This may or may not be a bug (for the past few years I've used Tavultesoft Keyman program for typing in Unicode Greek, so I don't have any Greek keyboard configurations I mess with other than that). So if I go to keyboard layout, when the language is Greek, the keyboard layout is English (United States) and I don't notice any problems with how the Greek works in BW8, which either leads me to believe that choosing the Greek keyboard configuration is causing some problem or else something else is going on because I haven't noticed any problems on my computer (granted I'm also using XP) with BW8 and the way Greek font works.The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected, and even when I am typing in the Bibleworks 8.0 editor screen on the right the Greek and Hebrew keyboards function exactly like they should (no bugs). The problem only exhibits itself in the Bibleworks command line.

Adelphos
01-19-2009, 05:42 AM
The Greek keyboard is supposed to be the same across all Microsoft programs, and when I am typing in MS Word the Greek Keyboard does function as expected, and even when I am typing in the Bibleworks 8.0 editor screen on the right the Greek and Hebrew keyboards function exactly like they should (no bugs). The problem only exhibits itself in the Bibleworks command line.

You should NOT have your keyboard set to Greek when you type in the Command Line in BibleWorks. Your keyboard should be set to English keyboard for both Greek and Hebrew. That is your problem.

benelchi
01-19-2009, 01:19 PM
The difficulty with using just the English keyboards is that Bibleworks uses a non-standard Keyboard layout. For those of us who use the Greek and Hebrew in other programs (like Microsoft word) it is very frustrating to not be able to use the same Keyboard layout in Bible works.

Note: even in the Bibleworks editor screen the Greek and Hebrew Keyboards work correctly. There must be someway to get them to function correctly in the command line.


Additional note: Bibleworks, automatically chooses the Hebrew or Greek Keyboard when I position the cursor in the command line (even when automatic langauge selection is turned off) I haven't tried setting the Greek and Hebrew keyboards to English in the Keyboard selections, but I have tried setting the option to always use English for Greek and Hebrew and that didn't work.

Adelphos
01-19-2009, 02:06 PM
I haven't tried setting the Greek and Hebrew keyboards to English in the Keyboard selections, but I have tried setting the option to always use English for Greek and Hebrew and that didn't work.

I'm talking about the Windows keyboard. I have a number of keyboards set through Windows so that all I have to do is use my mouse to select English, German, Greek, Hebrew, etc. When typing on the CL in BW, I have the Windows keyboard set to English, for that is how it works, and that is how it is supposed to work. As for allowing it to work with other keyboards, that is an issue that you must take to BW directly.

In the meantime, if you want your CL searches to work properly, you need to have your Windows keyboard set to English.

benelchi
01-19-2009, 06:03 PM
My default windows keyboard is set for English, but I do notice that bibleworks does change that setting automatically when the cursor is in the search box and the search versions is Hebrew or Greek. On Vista there is a keyboard language indicator on the lower right part of the screen and I can watch that change between EN (English), EL (Greek), HE (Hebrew) as I move the mouse cursor around on the Bible works Screen. In other programs (like MS word) I am required to change that setting manually when I want to switch between langauges. I can try setting the keyboards for Greek and Hebrew to English in the bibleworks config screen; however, I suspect doing so will change the Keyboard mapping.

Adelphos
01-19-2009, 06:46 PM
My default windows keyboard is set for English, but I do notice that bibleworks does change that setting automatically when the cursor is in the search box and the search versions is Hebrew or Greek. On Vista there is a keyboard language indicator on the lower right part of the screen and I can watch that change between EN (English), EL (Greek), HE (Hebrew) as I move the mouse cursor around on the Bible works Screen. In other programs (like MS word) I am required to change that setting manually when I want to switch between langauges. I can try setting the keyboards for Greek and Hebrew to English in the bibleworks config screen; however, I suspect doing so will change the Keyboard mapping.

I would just stick with what works instead of aiming for some sort of symmetry, as there is nether world of permutations in Windows from system to system and program to program.

Like Vista, XP also has an indicator for the keyboard in use, and in addition to the mouse, you can very swiftly move from keyboard to keyboard with Alt+Shift

jazzbird
03-04-2009, 05:24 PM
yes, I have the same problem with Hebrew/Israeli keyboard. Must switch to caps lock to get any Hebrew text in the search box.

SkipB
03-05-2009, 09:26 AM
Have you looked at these threads. I do not use vista so I can only suggest there may be a clue in some of these posts. But most of them do relate to xp.
http://www.bibleworks.com/forums/showthread.php?t=3534&highlight=Israeli+keyboard
http://www.bibleworks.com/forums/showthread.php?t=3209&highlight=Israeli+keyboard
http://www.bibleworks.com/forums/showthread.php?t=2957&highlight=Israeli+keyboard
http://www.bibleworks.com/forums/showthread.php?t=2192&highlight=Israeli+keyboard
http://www.bibleworks.com/forums/showthread.php?t=1226&highlight=Israeli+keyboard
hope if generates some ideas