PDA

View Full Version : WTM/WTT searches & Morph Assistant...



yugu
05-25-2008, 04:47 PM
Hello,
I have two questions:
1) Where has gone Morphology Assistant, which if I'm not missing something was in the Tools (Resources?) menu?
2) I'm sure that this q. has been already discussed somewhere here, but I've not found it, so: How can I make a search on (lets say) LXM version (lemma, inflection and so on) while having LXT version in the Browse Window, all that from the Command Line (not right click and search on lemma)? Its just too annoying to switch to LXM, search and then switch to LXT again in order to see some readable text!
Thanks in advance!

Mark Eddy
05-25-2008, 11:17 PM
Hello,
I have two questions:
1) Where has gone Morphology Assistant, which if I'm not missing something was in the Tools (Resources?) menu?
If you simply type on the command line in a morphology version after the @ BW7 automatically gives you a dropdown list. After you make your first choice another dropdown list will appear for you to make your next choice. etc.

2) I'm sure that this q. has been already discussed somewhere here, but I've not found it, so: How can I make a search on (lets say) LXM version (lemma, inflection and so on) while having LXT version in the Browse Window, all that from the Command Line (not right click and search on lemma)? Its just too annoying to switch to LXM, search and then switch to LXT again in order to see some readable text!
Thanks in advance!
I assume you want to search the BLM morphology.
In "Options" click on "Browse Window Configuration Options."
Then uncheck "Automatically make morphology versions display versions."
Then you can have LXT as your browse version and do one right click lemma search with the mouse. That will change the search version to BLM but keep the display version as LXT. From that point on you can do all your searches from the command line (BLM) but the results will display in LXT.
I agree that it is cumbersome to keep switching between LXT and BLM, but if you want to use the command line for lemma searches, you have no choice but to use to BLM as your search version.
However, you can also make BLM "readable" in the browse window. You can use the "interlinear toggle" button on the button bar, so that instead of BLM looking like this:
kai,@cc kale,w@viaa3p auvto,j@rpgms
it can look like this:
kai. evka,lesan auvtou/
kai, kale,w auvto,j
cc viaa3p rpgms
That way you can keep BLM as your browse version, yet the top line will read like LXT. I hope this helps.
Mark Eddy

yugu
06-01-2008, 09:36 AM
Thank you Mark, it is useful!

yugu
06-01-2008, 02:02 PM
By the way and in case someone here will be interested:
The Morphology Assistant can be accessed through the Button Bar only (haven't found it nowhere else), which you can of course customize!

yugu
06-01-2008, 02:32 PM
Mark (or anybody else), sorry, but once again: I've gone through according to your directions and it doesn't work for me:


Then you can have LXT as your browse version and do one right click lemma search with the mouse. That will change the search version to BLM but keep the display version as LXT.

I've chose LXT as browse text, accomplished right click lemma search and this works fine and exactly as you say... but...


From that point on you can do all your searches from the command line (BLM) but the results will display in LXT.

BW is not allowing me to do BLM searches in the command line until I switch to BLM (typing BLM in the command line), but then even before and definitely after I search for some lemma - the browse window sticks to BLM!


... uncheck "Automatically make morphology versions display versions."

All of those has been done with either this option was ON or OFF - the results are actually same! :confused:

Is that what you meant?

Mark Eddy
06-01-2008, 05:16 PM
I've chose LXT as browse text, accomplished right click lemma search and this works fine and exactly as you say... but
BW is not allowing me to do BLM searches in the command line until I switch to BLM (typing BLM in the command line), but then even before and definitely after I search for some lemma - the browse window sticks to BLM!...
I am sorry. I see now that in addition to unchecking the "Browse Window Configuration Options" box titled "Automatically make morphology versions display versions" you also have to check the box titled "Maintain search version after lemma search". What I suggested (in my first suggestion) is to make searches by right clicking on a word in LXT in the browse window. With the latter Option checked, the search version on the command line turns into BLM and remains BLM after your first search (using the right click). Thereafter the search version box to the left of the command line should read BLM, but LXT remains visible in your browse window. At least this works in multiple version mode in the browse window (the way I use it).


All of those has been done with either this option was ON or OFF - the results are actually same! :confused:
Is that what you meant?
So, if the first suggestion does not work for you, you have to use my second suggestion (in the previous post). Turn BLM into an interlinear by going to the button bar, clicking on the icon with 3 horizontal lines called "Interlinear Toggle." Then you can use BLM to search and in the browse window you will see the text of BLM in the three lines which I described previously. The top line will be the same as the LXT text, and you should be able to read it as easily ast the LXT (as long as you ignore lines 2 & 3).
Another option would be to use the multiple version option in the browse window. Then you could have both BLM and LXT in the browse window. But then you would be able to have only one verse in the browse window after doing a lemma search. If you need to see multiple verses of context, then you have to use browse mode in the browse window (only BLM in the browse window, but displaying multiple verses).
I hope one of these options works for you.
Mark Eddy

yugu
06-02-2008, 04:00 AM
Hi Mark,
Thanks again, really appreciate your efforts!
I'll work with the interlinear, as you suggested - that's the simplest solution!
Best Regards,
Yuri.