PDA

View Full Version : Lemma search question



etfjr
03-21-2008, 04:59 PM
If I want to find all occurances of paraklhtoj in the BGM, that's easy, but here's what I want to do...

I want to search for the lemma (ie paraklhtoj) and have the results display in the BGT so I can see the textual (not morphological) versions...

How do I do that?

Taylor

Greg Ward
03-21-2008, 07:49 PM
1) Display the BGT via menu or command line: d bgt
2) Perform the search in BGM: .paraklhtos@*
Or right click on the word in the browse window in either BGT or BGM and select Search on all Forms of Lemma

Is this what you were wanting?

etfjr
03-21-2008, 08:57 PM
1) I can't type "@" in a BGT search.
2) I can type "@" if I don't type the "." first, so I type "@*" then backarrow to the beginning and type ".paraklhtos"

BW responds with the following word or form cannot be found in the search version...

I can search in the BGM and then switch to the bgt, but I was hoping for a direct method...

Taylor

Mark Eddy
03-21-2008, 11:44 PM
When you type on the command line with a text version (BGT, BNT, GNT, etc.) as the search version, you just type the exact form of the word you want, never with @.
But you can use a wildcard. So, you could type:
.paraklh*
and you would get most instances of the lemma paraklhtos. To make sure you get them all, do option #2 which was suggested previously, namely right click on the highlighted word in the browse window , which should be a form of paraklhtos. Then choose the option "Search on lemma," and you should get the list of all verses which have any form of paraklhtos, which is what you want.
It also may help to uncheck the "Option" under "Browse Window Configuration Options" which says, "Automatically make morphology versions display versions." When you do this, the morphology version (e.g. BGM) will not be added to the display in the browse window (BGT) when you do a search in the morphology version.
Did I make this clear enough?
Mark Eddy

etfjr
03-21-2008, 11:59 PM
I think I can work with this...

Thanks for the help!

Taylor

Ben Spackman
03-23-2008, 08:15 PM
Edit: Just realized Mark Eddy told you how to do this.


Open your settings.

TOOLS>OPTIONS>BROWSE WINDOW CONFIGURATION OPTIONS

Make sure AUTOMATICALLY MAKE MORPHOLOGY VERSION DISPLAY VERSION is NOT checked.

Now go back to your command line. Type in BGT to display it, then BGT. BGT should be your search version, but NOT be visible. When you do the search, the results should display in the BGT, and the BGM should be invisible.

See how that works.

etfjr
03-23-2008, 10:56 PM
I unchecked the appropriate box in the options list.

when I type BGM, the BGM displays... even with the box unchecked...

I don't get it, what am i doing wrong?
T


Edit: OK, i toggled my browse mode and it's working now...