PDA

View Full Version : Hebrew copy-and-paste problem



David Kummerow
05-25-2007, 04:54 PM
I'm just wondering if the following problem is isolated to my machine or not:

When I copy-and-paste Hebrew text from a displayed verse into Word, Word pastes it in as anything but Hebrew. Hebrew characters are displayed, but the language assigned varies intermitently from English, Italian, Lithuanian, and Czech. I have unicode font export enabled and the problem happens with the two fonts I've tried, SBL Hebrew and Ezra SIL. In fact, SBL Hebrew doesn't even paste in as that font but as the default one in Word (Minion Pro on with me).

But when I first paste the copied Hebrew text into the BW Editor and then copy again that just-pasted text from the Editor and then paste that into Word everything works as expected.

A few weeks ago a had my laptop stolen so I had to get a new one and reinstall etc. I have not encounted the above problem in the past, but then I hadn't updated my BW executable for a while. So I suspect that it is either a bug that has crept in or that I have setup problem which I need to isolate. So I'm curious if it is happening for anyone else.

Thanks,
David Kummerow.

Eagle
05-25-2007, 05:40 PM
I also cut and paste into word using SBL Hebrew. I've had problems, too, though not that one. One of mine is the Hebrew left-to-right support (which can be fixed by using Copy Center to copy, then cutting and pasting from within Word).

The bigger problem is, certain Massoretic characters apparently do not translate correctly from bwebb to SBL Hebrew, giving me those dotted circles scattered through my pasted/copied text text...

There is a SBL Hebrew 2.0 due out sometime soon, and I hope that between SBL and BW, complete integration can be worked out. SBL Hebrew will soon be standard in the field, I suspect.

Chris

Adelphos
05-25-2007, 06:27 PM
When I copy-and-paste Hebrew text from a displayed verse into Word, Word pastes it in as anything but Hebrew. Hebrew characters are displayed, but the language assigned varies intermitently from English, Italian, Lithuanian, and Czech...

I can't duplicate your problem, David. I have SBL Hebrew selected as my export font, and I have the check box to enable unicode selected. I assume you do, too? That is, I assume you've double-checked to make sure all the proper export options are selected?

In any event, pasting directly into Word comes off without a hitch in most cases. In only a few test passages has one or two accents not translated properly, but that's about the only trouble I've had.

FWIW, I also have all the latest updates, and my OS is XP SP2.

David Kummerow
05-25-2007, 07:32 PM
OK, thanks guys for replying to me regarding this.

Unicode export box is checked, yes. I'll have to try reinstalling one or both pieces of software and see if that fixes things. It's strange that copying-and-pasting from the BW Editor is free of the glitch.

Regarding accents, some complex combinations aren't even encoded in BW, eg Job 7:11 which I raised here: http://www.bibleworks.com/forums/showthread.php?t=334

Thanks again,
David.

MBushell
05-26-2007, 12:13 AM
Whate version of Word are you using. Hebrew support prior to Word 2003 was spotty.
Mike

David Kummerow
05-26-2007, 05:04 AM
Hi Mike,

Word 2000 is what I'm using. It's all been fine until the last install of everything. I'll try reinstalling stuff next week and see what happens. I was just curious since copying text from the Editor works fine, just not text from the display version.

Thanks for asking anyway. In the end, its not a great problem for me to copy first to the editor if I have to.

Regards,
David.