PDA

View Full Version : Changing the default English keyboard layout does not work



teilo
05-19-2007, 06:31 PM
In the lastest rev of Bibleworks (7.0.018x.8) changing the default keyboard layout does not work for any languages at all. Just the "Default" language. This is using Tools->Keyboard Layouts...

You are allowed to select a different layout for any given language in the dialog box, but as soon as you close it, it reverts back. I only need to change "English" but I tested it on other languages as well. Nothing would change except "Default".

Is there some sort of workaround for this? I use the Dvorak layout exclusively, and have to change layouts using the Windows shortcuts, EVERY time I change versions in Bibleworks (And I have the "Change Command Line Keyboard Layout" option set to Manually, not Automatic).

teilo
09-08-2007, 04:06 PM
I finally found the answer to this problem.

The Tools->Keyboard Layouts->Set Keyboard Layouts command simply does not work at all if you have the following Option Flag turned off:

Command Line Configuration Options: Auto-Select CL Keyboard when version changes.

Once this flag is enabled, it will then be possible to change the default keyboard layouts for various languages, and the settings will be saved. For whatever reason, having that flag unchecked causes the dialog box to ignore whatever defaults you select, and your choices are not saved.

After choosing your layout assignments, you can then disable the Auto-Select CL Keyboard when version changes flag. Your default CL layout will then be loaded when BWW launches, and more importantly will not change as you flip from version to version. For instance, I switch from German to English all the time, and don't really want my Dvorak keyboard reverting to German whenever I read L45.