PDA

View Full Version : whad97 & wheb32



Roger Greene
09-04-2006, 02:54 AM
For a long time I've used the macros in Word to insert hebrew references. Recently, it stopped working. I get an error when I click on any of the macro buttons in Word:

Run-time error '4198'
Application-defined or object-defined error.

I've uninstalled and re-installed the macros, but no joy.

Is there a 'new' way to do this, or some way to figure out what happened?

Rog.

Charlie
09-05-2006, 01:03 PM
Roger,

The file names listed on your subject line (whad97 & wheb32) are files associated with the Hebrew Add-in for Word. If you just want to insert a Hebrew verse from BibleWorks you don't need the add-in. Just copy it in BW and then paste it in your word processor. For more info see: http://www.bibleworks.com/forums/showthread.php?t=202

If you wish to compose text in Word in Hebrew and you don't want to use the native Windows Hebrew support the add-in will "trick" Word into allowing you to input Hebrew right-to-left using our Hebrew font (bwhebb). However, Word will still wrap the text as if it were English text (i.e. it will start a new line with the word that is farthest to the right). So in order to keep Word from wrapping the text you'll need to hit Enter before the end of the line, as if you were using an old fashioned type writer.

I would recommend that you not use the Hebrew add-in since Windows XP and Word now offer right-to-left Hebrew support. We even offer a Unicode keyboard that assigns the same keys to each Hebrew character as in our font bwhebb.

If you do wish to install the Hebrew add-in open the document named hebwrd97.doc (found in your BibleWorks installation folder) and double-click the button that says "double click here to install."



NOTE: Word's macro security feature must be set to “enable macros” in order to install the add-in. If you open the document and see 'macros not enabled' written on the buttons then do the following:
1. Select "Tools|Macros|Security" (you may have to expand the menu to see all of the options).
2. Click "Medium"
3. Exit Word
4. Re-start Word
5. Open hebwrd97.doc
6. Answer "enable Macros" when it asks if you want to allow macros to run.
7. Double-click the Install button.

Roger Greene
09-05-2006, 10:25 PM
I don't need to install the macros. I've been using them for years.
They just stopped working.

I tried installing the BWHEB.msi in the keyboards folder of BibleWorks 7, but an error message came up in Hebrew indicating that the install failed.

Any other suggestions?

Charlie
09-06-2006, 12:13 PM
Regarding the Word Addin:
Try uninstalling and then reinstalling the Addin using the document found in your BibleWorks 7 folder.

Regarding the BWHEB.msi keyboard:
What version of Windows and Word are you using?