PDA

View Full Version : Editor formatting



Ben Spackman
06-15-2006, 04:10 PM
In both the notes and editor window of BW 7, I hit "Insert current verse as link" and then keep typing. The text following the inserted link is always blue, like the link, unless I hit ctrl-d before typing again. See the bottom link of the picture.

http://home.uchicago.edu/%7Espackman/editor.bmp

Michael Hanel
06-15-2006, 05:06 PM
I'm not sure if this is related to that coding at all, but it is a mild annoyance of mine in the Editor. When I copy something from Liddell-Scott lexicon to the editor it always copies it and then inserts a carriage return (i.e. leaves the cursor not on the line I pasted, but on the line after the line I pasted). This seems to be a common problem with copying from other resources too.

I don't know if that's how it was intended to work or this is still a bug to work through, but just for my peace of mind are there people who prefer the pasting function the way it is now (i.e. that it pastes and leaves the cursor on the next line)? I didn't want to tell them to change it if this is how it's supposed to work, so I thought I'd ask.

Adelphos
06-15-2006, 05:44 PM
I'm not sure if this is related to that coding at all...

Actually, if you change the font color to blue in any WP program, it will stay blue until you change it to another color. That's the way it's supposed to work. When BW inserts a link, it changes the font color to blue, and it stays blue until it's changed, just like in any WP program.

The fact that it can be changed back in the BW editor with a simple Ctrl-d is a bonus, as this is much simpler than selecting the color box, etc.

As for the carriage return, this MAY be due to selecting more than just the text. That is to say, you MAY be selecting the space after the text, and if so, this will automatically insert the carriage return. I don't know this to be the case for sure, but that's the way it usually is.

Try selecting ONLY up to the last letter of the text and see if that changes the behavior.

Michael Hanel
06-15-2006, 05:59 PM
As for the carriage return, this MAY be due to selecting more than just the text. That is to say, you MAY be selecting the space after the text, and if so, this will automatically insert the carriage return. I don't know this to be the case for sure, but that's the way it usually is.

Try selecting ONLY up to the last letter of the text and see if that changes the behavior.

Try it out on your end. Select one letter from a lexicon (in the middle of a word) and then copy it to the Editor. When I do that it basically copies this
"D
x"
(with x being where the cursor is left after the copy) and I'd rather it be this
"Dx" it saves me having to press back space all the time, and I'm pretty lazy :p

Adelphos
06-15-2006, 06:23 PM
Try it out on your end.

Okay, I tried it.

If I copy a single letter (even in the middle of a word), or a single word, or even a whole sentence, as long as I don't select more than than the last letter in the sentence, my cursor remains at the end of the letter, word, or sentence WITHOUT moving to a new line.

The only difference I get is when I copy from the lexicon in the Analysis window as opposed to having a lexicon fully open.

In the former case, it works as I described above. In the latter case, although it doesn't move to a new line, it does leave a space after the word I've copied.

I wonder if it could be the operating system? I'm back to using 98 SE while I decide on a new computer to buy. I don't think I can wait for Vista.

BTW, anybody who has suggestions on a computer and the features I should look for, feel free to let me know.

At any rate, if you don't experience the same behavior then it has to be the OS.

Michael Hanel
06-15-2006, 06:26 PM
I wonder if it could be the operating system? I'm back to using 98 SE while I decide on a new computer to buy. I don't think I can wait for Vista.



Interesting. My current hypothesis is that it might have something to do with Export Font settings, I'll have to keep playing around to see what causes it and what doesn't.

Adelphos
06-15-2006, 07:38 PM
I'm back to using 98 SE while I decide on a new computer to buy. I don't think I can wait for Vista...

Whoops! I just heard Bill Gates is stepping down from day-to-day control of MS.

Maybe I better wait and see if Steve Jobs takes his place! ;)

David Kummerow
06-15-2006, 10:06 PM
And while not strictly an Editor issue, I also have this problem mentioned here (http://www.bibleworks.com/forums/showthread.php?t=1475#2).

Adelphos
06-15-2006, 10:21 PM
And while not strictly an Editor issue, I also have this problem mentioned here (http://www.bibleworks.com/forums/showthread.php?t=1475#2).

David,

I don't have the problem you mentioned, i.e., if I type --

The clause

into Word, and then paste the Hebrew clause immediately after it, it formats properly. So it's probably somthing specific to your machine/configuration.

In any case, I wonder why you still bother with Word? I use Davka whenever possible, especially when I have any Hebrew to type. Even if you use BW fonts, Davka handles Hebrew much better than Word. And if you have to format it to Word for some reason, Davka allows you to export to RTF, etc., so that's no problem either.

In short, with Davka you can intersperse Hebrew any way you want. It takes all the hassle out of Hebrew/English formatting. If you haven't used Davka, I'll tell you right now it is truly one of the really great bargains of our day. Here's their link, just in case you haven't explored it --

http://www.davka.com/cgi-bin/index.cgi

Just out of curiosity, which grammar(s) do you use primarily for teaching these days?

David Kummerow
06-15-2006, 10:53 PM
Hi Scott,

Well, it's good to know that it's something to do with my system, although that's not so good. The problem only occurs with unicode (both SBL Hebrew and Ezra SIL), but not with the non-unicode BW font. You don't have the problem with unicode?

Currently, I'm using the textbook by Allen P. Ross, Introducing Biblical Hebrew. I have something of a love-hate relationship with it; but then this will probably always be the case with anything but your own! Fancis Andersen has a helpful review in Ancient Near Eastern Studies 39 (2002): 223-229.

Regarding Davka, does it support open type font programming like ligatures, for example? Also, do you know if EndNote functions with Davka OK. This is my main reason for using Word.

Regards,
David Kummerow.

Adelphos
06-15-2006, 11:40 PM
The problem only occurs with unicode (both SBL Hebrew and Ezra SIL), but not with the non-unicode BW font. You don't have the problem with unicode?

I haven't tried it with unicode, but perhaps I'll give it a go tomorrow.

I don't have any idea if Davka can talk to EndNote or not (I confess I don't even know what EndNote is).

With regard to open font programming, there is a capability within Davka to do this, but I've never used it.

I did ask a while back about the furtive patah, which Davka does not yet make any special arrangements for, (of course, I don't consider that to be really necessary since the function of the patah is pretty clear), but still, the furtive patah is even emphasized in some Israeli texts, and one or two other users besides myself asked for it to be included in the next upgrade, so it's possible Davka will include it.

Other than that, I'm pretty sure you can do what you want with vowels and accents, including altering the spacing, etc., but I've never done so. You might want to post that question, along with any others you might have, on the Davka Writer Forum, which you can access from the previous link I gave you. There are some people over there who know the Davka program inside out, so they could answer any and all questions you have with regard to its capabilities.

I also might add, Davka is pretty much like BW in responding to its users, i.e., they are very responsive.

Bottom line, though, is that Hebrew is FAR simpler to integrate and display with Davka -- I mean FAR simpler -- so if Davka Writer works with all your other stuff, after giving it a try you would become a true believer in no time flat.:cool: