PDA

View Full Version : Font issue copying NET notes



MGVH
06-08-2006, 03:46 PM
In copying notes from the NET Bible over to MSWord, some of the text critical symbols (in particular, the fraktur M for the Majority Text and the italic f with the hook for the Family symbol) do not copy correctly. (Instead of the M, I get a Y with umlaut; instead of the f, I get broken vertical bar.)

I set my font export options to Unicode (using the Cardo font which does contain those symbols), and all the other Greek in the notes copies into MSWord just fine.
If I don't use Unicode (and use Times New Roman), all the Greek is a mess.

I can get the Majority Text and Family symbols in MSWord using their hex values, but I can't figure out the font being used in the NET Bible notes in BW7. (I do get the symbols correctly when copying from the online version of the NET Bible where TimesNewRoman and Greek fonts are used.)

Not a big deal, but it is an annoyance. Thanks for any help.

song_robin
06-24-2006, 08:48 PM
You might have a corrupted Bwgrkl.ttf font.

Instructions:
1. Download this file onto your computer
2. Unzip it
3. Copy it into your C:\WINDOWS\FONTS directory
4. Reboot your computer.

MGVH
06-24-2006, 10:45 PM
The text looks fine within BW7. It's only when I copy/paste into Word that the family sign and the Majority tex symbol are not being converted correctly. See the attached file for what I mean. You will note that it works fine if I export using bwgrkl and non-Unicode.
file:///C:/DOCUME%7E1/Mark/LOCALS%7E1/Temp/moz-screenshot.jpgfile:///C:/DOCUME%7E1/Mark/LOCALS%7E1/Temp/moz-screenshot-1.jpg

song_robin
06-24-2006, 11:13 PM
Hi Mark,

How do you export a text into Word using Unicode fonts?

When I copy and paste into Word directly, it seems to turn out fine (see below). I'm not using Cardo or any Unicode font for it.

Is there an advantage to importing to Word using Unicode fonts?

http://img60.imageshack.us/img60/3583/font18fj.th.jpg (http://img60.imageshack.us/my.php?image=font18fj.jpg)

Michael Hanel
06-24-2006, 11:19 PM
Hi Mark,

How do you export a text into Word using Unicode fonts?

When I just copy and paste into Word (not using Cardo or any Unicode font), it seems to turn out fine (see below). Is there an advantage to importing to Word using Unicode fonts?

Go to Options : Fonts: and then make sure you have Font Set to Edit checked on Export Fonts. You can then enable exporting via Unicode-based fonts. The advantages of Unicode are based mainly on the hope that eventually all characters can be used via one font and that there won't be issues of font-remapping or character conversion between fonts. (see http://en.wikipedia.org/wiki/Unicode for a primer among other websites)

song_robin
06-24-2006, 11:21 PM
Oh, never mind.

I've been re-reading your post and I think I finally understand your situation.
Unfortunately, I don't necessarily have a solution for you at this point. If I find something, I'll let you know.

Sorry for the confusion.

Also, thanks Michael for the clarification on Unicode.

song_robin
06-25-2006, 02:32 AM
Your problem appears to be described as the following: Certain characters such as the fraktur "M" (which has a value of 219 (or hexadecimal DB)) are not being mapped properly to the Unicode fonts.

There's a font mapping tool built into BibleWorks 7 that appears to be the solution to this problem. To access this utility, go to Tools --> Options --> Fonts --> Edit Export Maps. A sample image of this screen is given below.

Instructions on using this utility is given in the BibleWorks 7 Online Help at: Fonts --> Font Remapping

However, I've read this through and I've also played around with this utility and I could not get it to work for myself. At this point, I'm not even sure that the utility is even working properly. If there's someone else on this forum that has gotten the mapping utility to work, I would also appreciate any suggestions on this.

Thanks.

http://img207.imageshack.us/img207/788/fontmap1jk.th.jpg (http://img207.imageshack.us/my.php?image=fontmap1jk.jpg)

p.s. I also found that the character "fraktur M" has a value of 120080 (or hexadecimal 1D510) in the latest version of the Cardo font. Hope that helps at all.

MGVH
06-26-2006, 01:56 PM
I don't think the font remapping will work with Unicode. (The font remapper was designed to handle differences in mapping among non-Unicode, TrueType fonts.) The Unicode export conversion is run through some routine...

For now, in MS Word, one can always enter the special symbols using the Hex value followed immediately by Alt-X. (Conversely, put the cursor after any character, hit the Alt-X, and it will give you its hex.) One can always set up short cut keys as well. Here's my list of special symbols with their hex value.
Text Critical Marks and Annotations

Majority Text symbol , 1D510 𝔐
Papyrus symbol, 1D513 𝔓
Septuagint, Greek Old Testament, 1D516 𝔖
Lectionary symbol, 1D459 𝑙
Family symbol 0192 (or use italic f in TimesNewRoman)

2E00 2E01 2E02 2E03 2E04 2E05 2E06
⸀ ⸁ ⸂ ⸃ ⸄ ⸅ ⸆

2E07 2E08 2E09 2E0A 2E0B 2E0C 2E0D
⸇ ⸈ ⸉ ⸊ ⸋ ⸌ ⸍

MBushell
06-27-2006, 09:58 AM
This is probably an issue with BibleWorks internal Unicode mapping tables. I will try to get to it in the next day or two. Thanks for your patience.
Mike

MBushell
06-30-2006, 12:54 PM
This should be fixed now. See the post instructions. I remapped the Fraktur characters to a non-Unicode font. They are defined in the Unicode standard but in a plane above FFFF, which means that very few programs can handle it and very few Unicode fonts will have them.

Mie

MGVH
06-30-2006, 02:07 PM
Thanks, Mike. The export from NET notes to MS Word now does work. (Note to others: Be sure, as Mike notes, to delete bwgrkl, bwhebb, and bwsupp TTF files and then reinstall them from the BW7 root directory.)

As noted in an earlier post, some of the characters, like the M Fraktur or the LXX symbol, are in the 1D### range, but I checked, and it does appear that only Cardo has those characters. (The following do NOT: Gentium, TitusCyberbit, Sil Galatia, Galillee, Arial Unicode MS, Athena Unicode, Minion Pro, Palatino Linotype...)

Thanks again.