PDA

View Full Version : How many Search Steps?



ingosorke
02-24-2006, 11:24 AM
Just for the fun of it . . .

Cruising through an Accordance blog (mea culpa!), someone claimed that it took Logos 47 steps and Accordance 27 steps to construct the following search:

"all instances in the Pastoral epistles of the Greek adjective kalos within three words of a noun which agrees with it in number and case"

I'm curious to how many steps this search could be reduced (irreducible necessity!) in BW?

BW geeks, ready for the Olympics?

Ingo

Joe Fleener
02-24-2006, 12:05 PM
Just for the fun of it . . .

Cruising through an Accordance blog (mea culpa!), someone claimed that it took Logos 47 steps and Accordance 27 steps to construct the following search:

"all instances in the Pastoral epistles of the Greek adjective kalos within three words of a noun which agrees with it in number and case"

I'm curious to how many steps this search could be reduced (irreducible necessity!) in BW?

BW geeks, ready for the Olympics?

Ingo
If you already have a Custom Search Limit set for the Pastoral Epistles (which I do, in my case called pastoral) and if you count one command line sequence as one step then this can be done in 2 steps:

On the command line type:

Step #1: l pastoral (that is a lower case L) <enter>

Step #2: ('kalos =cn *3 *@n*)/('*@n* *3 kalos =cn) <enter>

ingosorke
02-24-2006, 12:50 PM
Yeap. BW. Gold Metal.

Mark Eddy
02-24-2006, 12:52 PM
If you already have a Custom Search Limit set for the Pastoral Epistles (which I do, in my case called pastoral) and if you count one command line sequence as one step then this can be done in 2 steps:

On the command line type:

Step #1: l pastoral (that is a lower case L) <enter>

Step #2: ('kalos =cn *3 *@n*).('*@n* *3 kalos =cn) <enter>
Even if you don't have a custom search limit for the pastorals, this is a two-step operation.
1: l 1ti-tit +enter (lower case L means "limit")
2) 'kalos =cn *3 *@n* +enter (c means "case" n means "number")

I don't see the need for the last search in parentheses. When I used Joe's search I got 3 hits. Using my simpler search I got 12 hits, all of which seem to qualify.
Perhaps Joe meant to make an "or" search, substituting / for . between the two parenthetical phrases.
Mark Eddy

Joe Fleener
02-24-2006, 12:59 PM
I don't see the need for the last search in parentheses. When I used Joe's search I got 3 hits. Using my simpler search I got 12 hits, all of which seem to qualify.
Perhaps Joe meant to make an "or" search, substituting / for . between the two parenthetical phrases.
Mark Eddy

Oops. Yes I did mean the / for a OR search

With only one set of () or a single search as Mark had it will only find those instances where kalos preceeds the noun, since this is a phrase search.

I thought the criteria was for kalos to be within 3 words of the noun, so kalos could be before or after the noun, but must be within 3 words. Hense the second set of ().

ingosorke
02-24-2006, 03:18 PM
Joe, Mark, which search version are you using? I can't duplicate either search. I'm missing a step (no pun . . .)
In BNM, for example, the command line continues in Greek font. I can't even type in the examples in the Online Help section. Yes, my computer is plugged in. :)

Joe Fleener
02-24-2006, 04:32 PM
Joe, Mark, which search version are you using? I can't duplicate either search. I'm missing a step (no pun . . .)
In BNM, for example, the command line continues in Greek font. I can't even type in the examples in the Online Help section. Yes, my computer is plugged in. :)

It should work for any Greek Morphology Version...

Notice there is no command line parameter outline the first opening ( on my example. (i.e. no ' . or /)

However, if you are able to get Marks to work either I am not sure.

Did you try just copying and pasting them from here.

Ruben Gomez
02-24-2006, 04:43 PM
Joe, Mark, which search version are you using? I can't duplicate either search. I'm missing a step (no pun . . .)
In BNM, for example, the command line continues in Greek font. I can't even type in the examples in the Online Help section. Yes, my computer is plugged in. :)
Also, you can always click on the BibleWorks Keyboard button (the alpha with a gray background), and press the keys that you need, in the language of your choice, on the keyboard that pops up.

Best,

Rubén Gómez

ingosorke
02-25-2006, 11:12 PM
Hm, copy/paste doesn't do the trick, nor does typing it through the BW keyboard. Greek fonts show up in Arial in the command line.

I'll wait and see how BW7 handles it.

ingosorke
02-25-2006, 11:14 PM
Hm, copy/paste doesn't to the trick, nor does typing it through the BW keyboard (Greek fonts don't show up Greek in the command line). I'll wait and see how the actual BW7 handles it when I get it.

Joe Fleener
02-25-2006, 11:41 PM
Hm, copy/paste doesn't to the trick, nor does typing it through the BW keyboard (Greek fonts don't show up Greek in the command line). I'll wait and see how the actual BW7 handles it when I get it.

With your search version set to BNM (or some Greek version) go to Tools - Keyboard Layouts and make sure the Language is set to Greek.

Other than that I have no idea! :confused:

ingosorke
02-26-2006, 03:36 AM
I'm lost with BW and these searches. The keyboard is set to Greek. I'll ask whoever does the training in Fort Worth next week.

I can't even construct Ruben's sample (see link below): The GSE does not keep a search entry like kaloj@a (kaloj@a)*. The GSE changes it to kaloj[@a (kaloj@a)* and other wild stuff. My second Word Box entry is *@n*, but that gets changed to *[v*@* when I hit o.k. :o

Here Ruben's sample (scroll down to the BW example):
http://www.bsreview.org/weblog/2005/08/graphical-searches-test-case.html

Ingo

Adamsen
02-26-2006, 04:01 AM
I'm lost with BW and these searches. The keyboard is set to Greek. I'll ask whoever does the training in Fort Worth next week.

I can't even construct Ruben's sample (see link below): The GSE does not keep a search entry like kaloj@a*. The GSE changes it to kaloj[@a* and other wild stuff. My second Word Box entry is *@n*, but that gets changed to *[v*@* when I hit o.k. :o

Here Ruben's sample (scroll down to the BW example):
http://www.bsreview.org/weblog/2005/08/graphical-searches-test-case.html

Ingo

I am not sure what causes this. Maybe, just maybe, it is a faulty language and keyboard configuration. Do you, perhaps, use a German keyboard?

In the Options > Option Flags > Command Line Configuration Options, you should select "Always Use English Font Maps for Hebrew/Greek" *if* you always use an English keyboard, and deselect it if you use, e.g. a German or Danish keyboard.

Then you should double-click on the language button in the Status bar and make sure that the Default Keyboard layout is *your* default one (English, Danish, German or whatever; it should be what you have chosen in the Windows configuration, I think).

You should also - at least this is what I have found to be necessary - keep an eye to the language button, the first time you use a new language. If it says Greek for Greek, you must somehow have a Greek keyboard or a software interface for such a one (unicode, perhaps). I am not sure whether that would work, though. If you have not a Greek keyboard, it should say English, if your keyboard layout is English, German if it is German, and so forth.

If the keyboard *layout* is said to be *Greek*, then I think you should change it. (Please, backup you ini files, before you follow my advice!). E.g., selecting a Greek version you should double-click on the keyboard layout button in the status bar, make sure that the Default Keyboard Layout is your chosen keyboard layout.

if you delected the "Always Use English Font Maps for Hebrew/Greek", then you should select Greek in the language box at the top in the dialog box and select German or whatever you keyboard layout is.

If there is a mismatch somehow, you will not be able to use the command line as intended. But again, I am not sure whether this is the problem, but give it a try. My guess is that the culprit is somewhere in this area.

Georg

ingosorke
02-26-2006, 04:12 AM
Thanks Dr. Adamsen!

I was able to construct the search through the GSE. I had entered everything in the Word Agreement box instead of splitting it up between "Word" and "Morph"! However, I get 13 verses with 15 hits, with the top Merge Box (AND (BNM): vs: 89 Tot: 13.

Still haven't figured out the command line issue. Sure would be nice if a GSE construction could be translated back to a Command Line phrase. Keyboard languages are all set correctly from what I can tell. Kein Deutsch!

Vielen Dank.

Adamsen
02-26-2006, 04:23 AM
OK. Then I would suggest that you mail to support and include the command line search you cannot perform as well as all the information you can garner in the Help > About Bibleworks ... > System info; select the Include locale information and text of INI files. Copy the report to Clipboard and from there into a mail to support@bibleworks.com.

I am pretty sure that it is a configuration issue. They may be able to figure it out.

Georg

PS added a little later: I am no longer sure that it is a configuration issue, but do ask Support anyway.

ingosorke
02-26-2006, 04:35 AM
Tried it all on my laptop; it works, both Command Line and GSE!

Restarted my desktop and it works too. So, never mind. Back on track.
This forum is great though; I thought I was going nuts.

Thanks to everyone.

Ingo