PDA

View Full Version : Using MS Word with two languages simulatneously



dbielby
10-18-2005, 12:39 PM
Every week I take the text for my sermon and try to put it into MS Word so that I can play with it and add my own stuff around it. The problem is that MS Word always flags almost every word with a red squiggly line under it showing it is not spelled correctly. To work around this I have been adding all the Greek words to the English dictionary (which transliterates them-and it's messy). This gives my English dictionary a lot of unuseable words and caused a problem recently where my spell checker missed an easy word in english.

I wondering if anyone knows how I can configure MS Word or some other software to automatically select the spell checker that matches a words original language rather than always reading the english dictionary.

Dale A. Brueggemann
10-18-2005, 01:08 PM
One way to do this is to use a macro to configure a F-key to your BW Greek font, and one for your BW Hebrew font. Here's my procedure:

I use F6 for Greek, F7 for Hebrew, and F8 for "Regular".
F6 is set (a) to turn off smart quotes, so it doesn't interfer with typing Greek accents, (b) to turn off spell-checking for this, and (c) to turn on BW Greek font. This can be done under the tools menu when recording the macro. I do not select a type size or characteristic (e.g., regular, italics, bold, etc.), because I want my Greek or Hebrew to pick up the existing font characteristics of the text into which it's embedded.
F7 does (a) and (b) above and turns on the BW Hebrew font.
F8 reverses (a), (b), and (c). I under (c) by recording <shft><ctrl>z rather than using the font menu and picking the size and characteristics, because I want to return to my existing text's characteristics, whether in running text (12-point Roman), a block quote (11-point Roman), or a header (12-point Arial, bold and/or italics or not depending upon heading level).
When I import Greek or Hebrew, I quickly select it and hit F6 or F7 as fitting; then if I'm not going to continue typing Greek or Hebrew, I hit F8 to get my spelling checking and smart quotes back, and continue.
This leaves the Greek and Hebrew text identified as text that doesn't get checked for spelling and grammar.

dbielby
10-19-2005, 11:29 AM
Thank you Dale! I assume I need to create a macro that runs on F6, F7 and F8 to accomplish this? If so, how do i do that?

Dale A. Brueggemann
10-20-2005, 07:32 AM
Under Tools menu, you select the option for recording macro, name it, and assign it to a key, e.g., F6 for Greek.

Then you click to start recording and do the following:

Go to the format fonts menu, and select BW Greek, and de-select any choices for point-size or style (i.e., regular, italics, bold). You want the font style and size to stay what it is already in the sentence.
Then go to the Tools menu and I think you go down to options, where you can check and un-check as needed for turning the smart quotes OFF, so they don't interfer with accents. Somewhere under the Tools menu you would also find a language sub-menu where you would turn of spelling and grammar checking.
Then you would click the button to stop recording and save the new macro.You would so the same by analogy for your Hebrew (e.g., on F7).

For "Normal" (e.g., on F8), you would essential reverse all of these settings:

Shft-Ctrl-z to return the font to whatever is "Normal" on your particular document. I do it that way rather than from the fonts menu, so the normal can vary dynamically with what was normal in its setting in its particular document and document structure.
Go to the Tools menu to re-select the smart quotes and the spell checking.
Stop the recording and save the macro.Try them, and if you get anomalous results, re-record to correct for whatever you missed the first try.

hudsonhauck
03-08-2007, 10:00 PM
Another option is to have Bibleworks export Greek and Hebrew in unicode (Tools --> Options --> Fonts)

SCSaunders
03-09-2007, 11:29 AM
David - Great question. I'd juzt ben terning offf tha spel chekkur.

Dale - Brilliant! Much thanks!

Greg Ward
11-24-2008, 10:36 PM
It's been a while since I've pasted a lot of original language text into MS Word documents. (I've been ignoring the red squiggles underneath.) Since I last used Dale's macros I've got a new computer, a new OS (Vista), and a new version of Word (2007). I'm going to have to re-record the macros.

I'm asking is this still a good way to handle BW original language texts in MS Word? Any one still using these? Is there a better way?

Thanks.

spitzerpl
11-24-2008, 11:19 PM
It depends on exactly what you want to do. If all you want to do is is ignore the spelling for any word written in a particular font, I believe I could make an addin that would do this. If you actually want to spell check those Greek/Hebrew words, thats a different story.

Greg Ward
11-25-2008, 06:17 AM
I don't need to spell check Greek and Hebrew--I usually paste in the text or lemma.

I recorded the macros and removed the extra statements and was left with the following. Only thing is the Microsoft 'protect me from evil macros' is protecting me from me. I can't figure out this digital signature thing yet.

Sub Greek_BW_text()
'
' Greek_BW_text Macro
'
With Selection.Font
.Name = "Bwgrkl"
End With
With Options
.AutoFormatAsYouTypeReplaceQuotes = False
End With
With Options
.AutoFormatReplaceQuotes = False
End With
Selection.NoProofing = True
End Sub

Sub Hebrew_BW_text()
'
' Hebrew_BW_text Macro
'
With Selection.Font
.Name = "Bwhebb"
End With
With Options
.AutoFormatAsYouTypeReplaceQuotes = False
End With
With Options
.AutoFormatReplaceQuotes = False
End With
Selection.NoProofing = True
End Sub

Sub English_text()
'
' English_text Macro
'
Selection.Font.Reset
With Options
.AutoFormatAsYouTypeReplaceQuotes = True
End With
With Options
.AutoFormatReplaceQuotes = True
End With
Selection.LanguageID = wdEnglishUS
Selection.NoProofing = False
Application.CheckLanguage = True
End Sub

Greg Ward
12-05-2008, 10:26 PM
I'm still confused by this MS Office 2007 Digital Signatures for Macros thing. I have created the previous macros, which reside in by Normal template. I have created a self signature. I have myself listed in the trusted publishers list.

I open my document in which I want to use these formating macros. I type and run a macro---up pops a warning that say I have to sign the document. After signing it, I can't edit it because it is locked by the signing.:confused:

All I want to do is run my own macro freely. Any suggestions?

Thanks.

Greg Ward
12-09-2008, 10:12 PM
The above macros are working! If you have any suggestions for modification (any other options which should be on or off), please let me know.

I assigned the marcos to the F keys that were suggested previously as I recorded the macros. Somehow all three keys got assigned to "Digital Sign Document." Once I re-assigned the keys to the macros, they work.